Acer travelmate overheats in Mepis

If you are having a problem with getting any of your computer's hardware to work with MEPIS or you can't find the right driver, this is the forum to use. It's for newbies and regular users to post questions. Just make sure to post what hardware you are having problems with, in the subject and not just in the post's text area, please.
Message
Author
User avatar
moksha
Forum Regular
Forum Regular
Posts: 573
Joined: Sun Dec 09, 2007 4:19 am

Acer travelmate overheats in Mepis

#1 Postby moksha » Sat Apr 21, 2012 9:23 pm

I have an Acer travelmate 5740G, running M11 64 bit, it constantly overheats, I recently discovered this problem does not occur in W7 much to my dismay. I have tried playing with the perfomance parameters and had no luck with it constantly running at 70 degrees, it should be around 50 degrees.
### Edit ###
I suspect it is a CPU frequency scaling issue and am looking at this possibility, any alternate views or experience with these issues is appreciated, this artical looks promising http://www.pantz.org/software/cpufreq/usingcpufreqonlinux.html

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11147
Age: 57
Joined: Fri Dec 15, 2006 8:07 pm

Re: Acer travelmate overheats in Mepis

#2 Postby Stevo » Sun Apr 22, 2012 11:29 am

The standard 2.6.36 M11 kernel may also be too old for this hardware, so I'd experiment with a newer one from squeeze-backports to see if that fixes the problem, as well as the newer xorg drivers there.
The optimist proclaims that we live in the best of all possible worlds, and the pessimist fears this is true.

James Branch Cabell

User avatar
moksha
Forum Regular
Forum Regular
Posts: 573
Joined: Sun Dec 09, 2007 4:19 am

Re: Acer travelmate overheats in Mepis

#3 Postby moksha » Sun Apr 22, 2012 7:53 pm

Stevo wrote:The standard 2.6.36 M11 kernel may also be too old for this hardware, so I'd experiment with a newer one from squeeze-backports to see if that fixes the problem, as well as the newer xorg drivers there.


I have been looking at how to tinker with cpufreq scaling governors http://www.thinkwiki.org/wiki/How_to_make_use_of_Dynamic_Frequency_Scaling what do you think is it a good move or a dead end

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11147
Age: 57
Joined: Fri Dec 15, 2006 8:07 pm

Re: Acer travelmate overheats in Mepis

#4 Postby Stevo » Sun Apr 22, 2012 9:03 pm

The KDE in M11 does support CPU scaling, but it seems to be stuck on dynamic--that is, it varies depending on the load. whether you choose performance or powersave. This is OK, but your Travelmate may be stuck on High Speed, and maybe only a new kernel will let cpu scaling work. I did write a little guide in Tips and Tricks here on how to manually control the CPU speed:

viewtopic.php?f=23&t=29018
The optimist proclaims that we live in the best of all possible worlds, and the pessimist fears this is true.

James Branch Cabell

User avatar
moksha
Forum Regular
Forum Regular
Posts: 573
Joined: Sun Dec 09, 2007 4:19 am

Re: Acer travelmate overheats in Mepis

#5 Postby moksha » Sun Apr 22, 2012 9:15 pm

Stevo wrote:but your Travelmate may be stuck on High Speed, and maybe only a new kernel will let cpu scaling work. I did write a little guide in Tips and Tricks here on how to manually control the CPU speed:

http://www.mepiscommunity.org/forum/vie ... 23&t=29018

your right no matter what setting I use the frequency is 2266000
I will have a look at your guide

User avatar
moksha
Forum Regular
Forum Regular
Posts: 573
Joined: Sun Dec 09, 2007 4:19 am

Re: Acer travelmate overheats in Mepis

#6 Postby moksha » Sun Apr 22, 2012 9:37 pm

moksha wrote:
Stevo wrote:but your Travelmate may be stuck on High Speed, and maybe only a new kernel will let cpu scaling work. I did write a little guide in Tips and Tricks here on how to manually control the CPU speed:

http://www.mepiscommunity.org/forum/vie ... 23&t=29018

your right no matter what setting I use the frequency is 2266000
I will have a look at your guide

I have succesfully reduced the speed to 933M using your guide but the temp is still stubbornly sitting on 65 - 67 degrees

### edit ### 23 April 2012
it seems to be a major problem with a number of current linux kernels at the moment, I am also wondering about the acpi setting as a GRUB option

### edit 2 ### 24 April 2012
from what I have read online setting acpi in GRUB doesn't fix it, the problem is fixed in kernel 3.3 so I might be looking at the backports as you suggested Stevo

### edit 3 ### 25 April 2012
the backports only have 3.2 currently available, and from all I have read it is not fixed until 3.3, anyways I have set up an experimental install so I will backport 3.2 for the practice


Return to “Hardware General”

Who is online

Users browsing this forum: Google [Bot] and 2 guests