Speakers not muting when headphones plugged in

Problems with your sound card are to be posted here, as well as tutorials to share with others.
Message
Author
CC'z
Forum Novice
Forum  Novice
Posts: 17
Joined: Thu Oct 27, 2011 3:01 am

Speakers not muting when headphones plugged in

#1 Postby CC'z » Mon Jan 30, 2012 6:02 am

Mepis 11 on ASUS K52J. Speakers will not mute when the headphones are plugged in. Various other small problems with audio too. Much Googling pointed to a patch found here: http://www.linuxant.com/alsa-driver/als ... ll.deb.zip This works on Mepis 8 but breaks sound completely on 11? I conntacted Conexant and they told me to update my kernel? Can anyone help?

User avatar
zeeone
Forum Regular
Forum Regular
Posts: 899
Joined: Fri Jul 14, 2006 12:50 am

Re: Speakers not muting when headphones plugged in

#2 Postby zeeone » Mon Jan 30, 2012 8:53 am

We need a litle more info.
Are you running 32 bit or 64 bit M11?
Check Kinfo and post the kernel number.
How much memory is in the machine?
Research, Research, Research, Before You Walk The Plank.
Registered Linux User # 398829

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11193
Age: 57
Joined: Fri Dec 15, 2006 8:07 pm

Re: Speakers not muting when headphones plugged in

#3 Postby Stevo » Tue Jan 31, 2012 12:26 am

You can try a 2.6.39 Liquorix kernel in the community repo, or a 3.2 kernel in squeeze-backports (backports.org)

The ALSA sound drivers are built into the kernels, which is why they suggested an upgrade. Newer kernel=newer drivers.
The optimist proclaims that we live in the best of all possible worlds, and the pessimist fears this is true.

James Branch Cabell

CC'z
Forum Novice
Forum  Novice
Posts: 17
Joined: Thu Oct 27, 2011 3:01 am

Re: Speakers not muting when headphones plugged in

#4 Postby CC'z » Tue Feb 07, 2012 2:01 am

Sorry, been away...........

Zeeone, 32 bit Kernel: 2.6.36-1-mepis-smp 8Gb RAM

Stevo, Is upgrading the kernel to the one you suggest going to wreak havoc with my machine? I use it for work so can't afford to be down for long.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11193
Age: 57
Joined: Fri Dec 15, 2006 8:07 pm

Re: Speakers not muting when headphones plugged in

#5 Postby Stevo » Tue Feb 07, 2012 2:24 am

Keep the standard 2.6.36 kernel as well. A new kernel just adds another line to the GRUB initial boot menu, so the old one is good to keep as a backup.

Be aware that if you are using proprietary ATI or Nvidia drivers, you will have to rebuild them after a new kernel install, unless you're using a dkms version of the driver which does that automatically after the linux-image and linux-headers packages for that kernel are installed.

The kernel developers and those that build the kernel try not to wreak havoc :). The 2.6.39 kernel in the community repo has had a lot of good reports about it.
The optimist proclaims that we live in the best of all possible worlds, and the pessimist fears this is true.

James Branch Cabell

CC'z
Forum Novice
Forum  Novice
Posts: 17
Joined: Thu Oct 27, 2011 3:01 am

Re: Speakers not muting when headphones plugged in

#6 Postby CC'z » Tue Feb 07, 2012 4:03 am

Thanks Stevo, upgraded the kernel and all is good! Sound is now as it should be. However SMB4K is not working?

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11193
Age: 57
Joined: Fri Dec 15, 2006 8:07 pm

Re: Speakers not muting when headphones plugged in

#7 Postby Stevo » Tue Feb 07, 2012 12:52 pm

I have to admit I have no experience with SMB4K...anybody else have any?
The optimist proclaims that we live in the best of all possible worlds, and the pessimist fears this is true.

James Branch Cabell

User avatar
richb
Administrator
Posts: 13030
Joined: Wed Jul 12, 2006 2:17 pm

Re: Speakers not muting when headphones plugged in

#8 Postby richb » Tue Feb 07, 2012 1:27 pm

smb4k queries should be started in a new thread.
Forum Rules
Guide - How to Ask for Help

Rich

Laptop: Acer V5-572G: Intel i5, 12 GIG mem, Intel graphics, SanDisk SSD, 256GB
Virtualbox: Win 7
Desktop: MX-15- 64, AMD A8 7600 FM2+ CPU R7 Graphics, fglrx driver, 16 GIG Mem. Samsung EVO SSD 250 GB

DrEvS
Forum Novice
Forum  Novice
Posts: 1
Joined: Thu Mar 22, 2012 7:15 pm

Re: Speakers not muting when headphones plugged in

#9 Postby DrEvS » Thu Mar 22, 2012 7:46 pm

Hi!
I have a variant on the same theme. Plug in the headphones and they are ignored. Sound goes through built-in speakers anyway. Had the same problem with my previous Xubuntu installation. I shifted to Mepis because it is much lighter on this oldish laptop (compaq presario cq60-130eo).
OS is 2.6.36-1-mepis-smp. A check with lspci gives me that an Intel Corp 82801I (ICH9 family) HD audio controller (rev 3) is detected.
Hardware specifications tell me that there should be a "3D Sound Blaster Pro compatible sound 16 bit integrated" under the hood.
Can you help? Would be great for me (and my environment) if I could get that headset socket working. :-)

Installed Mepis today btw and I love what I've seen so far.

Best regards
Erik

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11193
Age: 57
Joined: Fri Dec 15, 2006 8:07 pm

Re: Speakers not muting when headphones plugged in

#10 Postby Stevo » Thu Mar 22, 2012 9:47 pm

We used to suggest building a newer set of ALSA drivers from the alsa-source package, but that seems to be broken with recent kernels. The other fix, adding and booting a newer kernel from the community repository or squeeze-backports, still applies. The newer drivers in the kernels have tweaks and fixes for various newer audio chipsets.
The optimist proclaims that we live in the best of all possible worlds, and the pessimist fears this is true.

James Branch Cabell


Return to “Sound”

Who is online

Users browsing this forum: No registered users and 1 guest