Monitor not powersaving

You can ask for help with video cards, tv cards, dvb, monitors, webcams, digital cameras and software related to these devices, here. Tutorials about these devices can be posted here, too.
Message
Author
User avatar
chatan
Forum Regular
Forum Regular
Posts: 798
Joined: Fri Oct 17, 2008 8:19 pm

Monitor not powersaving

#1 Postby chatan » Sat Jul 24, 2010 4:40 am

This is another one those issues I have running 8.5: My computers running 8.5 (one ATI and one nVidia) can't seem to use monitor power saving.
I've been searching and I see lots of threads, for example:
http://mepislovers.org/forums/showthread.php?t=25656
http://mepislovers.org/forums/showthread.php?t=26104
http://mepislovers.org/forums/showthread.php?t=24168

So I've found several areas that address screen management:

  1. Alt-F2 >>> Power Management >>> General Settings >>> Let PowerDevil manage screen powersaving
  2. Alt-F2 >>> Power Management >>> Edit Profiles >>> Performance profile (since it's a Desktop and ac is plugged in) >>> Screen >>> Enable display power management
  3. Alt-F2 >>> Power Control >>> Enable display power management

I've tested every combination of those to set a standby time and suspend time, but no luck.

I don't have a screensaver running.
And these monitors do go to standby fine running MEPIS 8.


Here is the output from this command:

Code: Select all

xset q

DPMS (Energy Star):
Standby: 1200 Suspend: 1800 Off: 0
DPMS is Enabled
Monitor is On


What's missing?
Thanks

User avatar
loobyloo
Forum Regular
Forum Regular
Posts: 224
Joined: Fri Jun 26, 2009 8:54 am

#2 Postby loobyloo » Sat Oct 09, 2010 4:23 pm

I also have this problem since moving from 8 to 8.5. Like the OP I've tried the suggestions in the above threads, but something's overriding everything I try. I'm just going to stop typing now and then post how long it takes for the screen to go blank.

60 seconds.

xset -q gives (some irrelevant info deleted) gives

Screen Saver:
prefer blanking: yes allow exposures: yes
timeout: 0 cycle: 600
Colors:
default colormap: 0x20 BlackPixel: 0 WhitePixel: 16777215
DPMS (Energy Star):
Standby: 720 Suspend: 1800 Off: 3600
DPMS is Enabled
Monitor is On

If anyone's got any new ideas, I'd be very glad to hear them. I can't watch anything longer than a cat falling off a shelf.
Dell Inspiron 640m, WinXP, Linux Mint, Mepis 8.5

User avatar
GoManutd
Forum Guide
Forum Guide
Posts: 2952
Joined: Mon Jun 30, 2008 8:06 pm

#3 Postby GoManutd » Sat Oct 09, 2010 4:51 pm

i have an issue with 8.5 not being able to stop the console from being locked when the screen saver/power saver kicks in.

User avatar
loobyloo
Forum Regular
Forum Regular
Posts: 224
Joined: Fri Jun 26, 2009 8:54 am

#4 Postby loobyloo » Sat Oct 09, 2010 5:02 pm

[off topic] Wish I'd never changed from 8 to 8.5 [/off topic]

User avatar
GoManutd
Forum Guide
Forum Guide
Posts: 2952
Joined: Mon Jun 30, 2008 8:06 pm

#5 Postby GoManutd » Sat Oct 09, 2010 6:35 pm

8.5 is different, and the desktop locking thing will likely drive me nuts, but i've found it to be snappier on my notebook than 8.0.

i'm in the process of by a larger drive that will be used for a fresh 8.5 install on my desktop.

User avatar
lucky9
Forum Veteran
Forum Veteran
Posts: 12360
Joined: Wed Jul 12, 2006 5:54 am

#6 Postby lucky9 » Sat Oct 09, 2010 6:54 pm

What happens if you do a 'kdesu systemsettings' (WOQs) and then set things? (I'm away from mepis at the moment)
Yes, even I am dishonest. Not in many ways, but in some. Forty-one, I think it is.
--Mark Twain

User avatar
loobyloo
Forum Regular
Forum Regular
Posts: 224
Joined: Fri Jun 26, 2009 8:54 am

#7 Postby loobyloo » Sun Oct 10, 2010 4:52 am

kdesu systemsettings:
Display > Power Control.
Enable display power management Disabled, StandyBy after disabled, Suspend After disabled.
Screensaver settings: Start automatically Disabled

OK going to apply it now and put a stopwatch on.

1 minute exactly, the display disappears. There must be something telling it to shut down after 60 seconds.
Dell Inspiron 640m, WinXP, Linux Mint, Mepis 8.5

User avatar
lucky9
Forum Veteran
Forum Veteran
Posts: 12360
Joined: Wed Jul 12, 2006 5:54 am

#8 Postby lucky9 » Sun Oct 10, 2010 2:06 pm

Is it possible that the monitor is timing out due to Energy Star settings? (independent of the OS)
Yes, even I am dishonest. Not in many ways, but in some. Forty-one, I think it is.
--Mark Twain

User avatar
loobyloo
Forum Regular
Forum Regular
Posts: 224
Joined: Fri Jun 26, 2009 8:54 am

#9 Postby loobyloo » Sun Oct 10, 2010 2:33 pm

Thanks - would disabling DPMS solve that do you think?
Dell Inspiron 640m, WinXP, Linux Mint, Mepis 8.5

User avatar
loobyloo
Forum Regular
Forum Regular
Posts: 224
Joined: Fri Jun 26, 2009 8:54 am

#10 Postby loobyloo » Sun Oct 10, 2010 2:55 pm

Ah... nearly there. As root, edit /etc/X11/xorg.conf and change three three places where DPMS occurs, in the Monitor sections, to "false". Display now dims after a minute or two but doesn't go off altogether, thank goodness. Just need to stop the dimming now.
Dell Inspiron 640m, WinXP, Linux Mint, Mepis 8.5


Return to “Video-Related”

Who is online

Users browsing this forum: No registered users and 1 guest