MEPIS Community Forum

A Linux operating system based on Debian Stable
View unanswered posts | View unsolved topics | View active topics |



Reply to topic  [ 6 posts ] 
no nvidia module found 
Author Message
Forum Novice
Forum  Novice
User avatar

Joined: Tue Feb 24, 2009 6:06 pm
Posts: 35
Location: West Chicago, Il
Has thanked: 2 times
Have thanks: 1 time
Post # 298421
Post no nvidia module found
I get both no nvidia module found and no nvidia drivers loaded. I've be google for a couple of hours looking for an answer with no luck. I can access my /(root) partition with the live DVD but don't know what to do from there. I update my xserver-xorg-input-wacom and it looked like it remove glx.
any help would be great.
Thanks Sawer


Sun Apr 08, 2012 6:43 pm
Profile YIM
Forum Guide
Forum Guide
User avatar

Joined: Wed Jul 12, 2006 4:05 pm
Posts: 2809
Location: Pinellas Park, FL
Has thanked: 104 times
Have thanks: 1760 times
Post # 298423
Post Re: no nvidia module found
In order to update your xserver-xorg-wacom, you would have updated nearly all of the xserver-xorg packages as dependencies. That breaks the Nvidia driver that comes with MEPIS. It's one of the reasons that package is in the testing CR instead of in Main.

If you have a wired data connection, the easiest way to fix this will be with sgfxi.

Booting from the hard drive, you should be able to get to a Console terminal by pressing Ctl+Alt+F1
log in as root, then run these commands
Code:
cd /usr/local/bin
wget smxi.org/sgfxi
chmod +x sgfxi
sgfxi

Follow the prompts. It should install the latest nvidia driver.

_________________
XFX Nforce 750 (built in GeForce 8300), Athlon X2 5000
Lenovo G550 , Intel T4400 , Intel Mobile 4 graphics


Sun Apr 08, 2012 6:52 pm

timkb4cq thanked by: Frank_v7, lucky9
Profile
Forum Novice
Forum  Novice
User avatar

Joined: Tue Feb 24, 2009 6:06 pm
Posts: 35
Location: West Chicago, Il
Has thanked: 2 times
Have thanks: 1 time
Post # 298424
Post Re: no nvidia module found (solved)
Thanks for the quick reply. I'll give that a try


Sun Apr 08, 2012 7:03 pm
Profile YIM
Forum Novice
Forum  Novice

Joined: Fri May 11, 2012 9:51 pm
Posts: 1
Has thanked: 0 time
Have thanks: 0 time
Post # 299773
Post Re: no nvidia module found
cd /usr/local/bin
wget smxi.org/sgfxi
chmod +x sgfxi
sgfxi

No idea how this works but I followed the instructions after vainly trying for an hour to load nvidia drivers to a fresh install of M11 for my new GTX 560.

It works perfectly.

Thank you.


Fri May 11, 2012 10:00 pm
Profile
Administrator
User avatar

Joined: Wed Jul 12, 2006 2:17 pm
Posts: 10686
Location: Rochester NY
Has thanked: 832 times
Have thanks: 1431 times
Post # 299774
Post Re: no nvidia module found
DaveJT wrote:
cd /usr/local/bin
wget smxi.org/sgfxi
chmod +x sgfxi
sgfxi

No idea how this works but I followed the instructions after vainly trying for an hour to load nvidia drivers to a fresh install of M11 for my new GTX 560.

It works perfectly.

Thank you.

This might help explain how sgfxi works.

http://smxi.org/docs/sgfxi-manual.htm

_________________
Forum Rules
Guide - How to Ask for Help
Link to Wiki
Rich

Acer Laptop V5-572G: Intel i5, 12 GIG mem, nVidia GT720M/Intel integrated graphics
Mx-14 Symbiosis
Kubuntu 13.10, KDE 4.11.2


Fri May 11, 2012 10:04 pm
Profile
Forum Veteran
Forum Veteran
User avatar

Joined: Wed Jul 12, 2006 5:54 am
Posts: 10945
Location: Tulsa, Oklahoma U.S.A.
Has thanked: 3698 times
Have thanks: 887 times
Post # 299789
Post Re: no nvidia module found
I've always found that the wiki was where/how I used sgfxi. Copy&Paste is a real time-saver. Along with reading the doc included before starting.

_________________
Yes, even I am dishonest. Not in many ways, but in some. Forty-one, I think it is.
--Mark Twain


Sat May 12, 2012 12:37 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.