MX & MEPIS Community Forum

Linux operating systems based on Debian Stable
View unanswered posts | View unsolved topics | View active topics |



Reply to topic  [ 24 posts ]  Go to page 1, 2, 3  Next
Printer config failure: no kcmodule - known bug elsewhere 
Author Message
Forum Novice
Forum  Novice

Joined: Fri Jul 21, 2006 2:28 am
Posts: 71
Has thanked: 0 time
Have thanks: 2 times
Post # 290049
Post Printer config failure: no kcmodule - known bug elsewhere
I am running Mepis 11 with Community Repo enabled - all up-to-date. I am trying to install an HP all-in-one 6510e printer. When running the Printer Config application I get this: "The service Printer Configuration does not provide an interface module KCModule with the key word system-config-printer-kde/system-config-printer-kde.py .....

I was successful, however, in installing the printer using CUPS. But I thought I would report this as it doesn't seem to appear in this forum but is a common "comes and goes" bug in Debian/Ubuntu going back at least two years. Each time it is "fixed" it reappears in later updates - see for example http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=550620

I have tried various suggestions found via Google including:

1. Launch systemsettings as root then try Printer Configuration but this just gives:
Code:
systemsettings(4043)/python (plugin): Failed to import module
Traceback (most recent call last):
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 70, in <module>
    import dbus.mainloop.qt
ImportError: No module named qt
systemsettings(4043)/python (plugin): Failed to import module
systemsettings(4043)/kcontrol KCModuleLoader::loadModule: This module has no valid entry symbol at all. The reason could be that it's still using K_EXPORT_COMPONENT_FACTORY with a custom X-KDE-FactoryName which is not supported anymore
systemsettings(4043)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:


2. Remove and re-install system-config-printer-kde (now at version 4:4.4.5-4)
3. Remove and reinstall python-qt4-dbus (4.7.3-1+b1)

None of these worked. Not much more I can do as this is the limit of my knowledge. Perhaps a dev might pick up on this or a mod could move it to a more appropriate sub-forum?


Mon Dec 05, 2011 5:03 am
Profile
Forum Guide
Forum Guide
User avatar

Joined: Sun Mar 25, 2007 5:49 pm
Posts: 2664
Location: Doncaster UK
Has thanked: 110 times
Have thanks: 738 times
Post # 290052
Post Re: Printer config failure: no kcmodule - known bug elsewher
You need the latest version of hplip, which is 3.11.10,

_________________
*Never be afraid to try something new. Remember that a lone amateur built the Ark. A large group of professionals built the Titanic(Windoze)*

Kubuntu KDE 4.11.00 / KDE 4.11.60 / Debian Wheezy KDE 4.10.4 / Plasma Active 3 Tablet


Mon Dec 05, 2011 8:44 am
Profile
Forum Novice
Forum  Novice

Joined: Fri Jul 21, 2006 2:28 am
Posts: 71
Has thanked: 0 time
Have thanks: 2 times
Post # 290054
Post Re: Printer config failure: no kcmodule - known bug elsewher
Danum wrote:
You need the latest version of hplip, which is 3.11.10,


Thanks for the reply. Actually, I installed that version before trying Printer Configuration. The full version number, according to Synaptic is 3.11.10-1mcr110+1


Mon Dec 05, 2011 9:04 am
Profile
Forum Guide
Forum Guide
User avatar

Joined: Sun Mar 25, 2007 5:49 pm
Posts: 2664
Location: Doncaster UK
Has thanked: 110 times
Have thanks: 738 times
Post # 290055
Post Re: Printer config failure: no kcmodule - known bug elsewher
I got the above from here, note the fixes,
http://hplipopensource.com/hplip-web/release_notes.html

_________________
*Never be afraid to try something new. Remember that a lone amateur built the Ark. A large group of professionals built the Titanic(Windoze)*

Kubuntu KDE 4.11.00 / KDE 4.11.60 / Debian Wheezy KDE 4.10.4 / Plasma Active 3 Tablet


Mon Dec 05, 2011 9:09 am
Profile
Forum Veteran
Forum Veteran
User avatar

Joined: Wed Jul 12, 2006 5:54 am
Posts: 11079
Location: Tulsa, Oklahoma U.S.A.
Has thanked: 3849 times
Have thanks: 903 times
Post # 290091
Post Re: Printer config failure: no kcmodule - known bug elsewher
The Packagers here are doing a great job of keeping hplip current. There's an HP configuration tool that I thought several people had needed. My old LaserJet 1012 is automagically found and installed at the original OS installation. I've never had to set it up manually since KDE 4 came on the scene if I remember correctly. Since M 11 things have been bullet-proof for me and my printer.

hp-toolbox? Or something similar.

_________________
Yes, even I am dishonest. Not in many ways, but in some. Forty-one, I think it is.
--Mark Twain


Mon Dec 05, 2011 3:23 pm
Profile
Forum Novice
Forum  Novice

Joined: Fri Jul 21, 2006 2:28 am
Posts: 71
Has thanked: 0 time
Have thanks: 2 times
Post # 290135
Post Re: Printer config failure: no kcmodule - known bug elsewher
Danum wrote:
I got the above from here, note the fixes,
http://hplipopensource.com/hplip-web/release_notes.html


Thanks for the link but read it as I can I can't for the life of me see ANY reference to this problem or any fixes for anything come to that? Can you point to exactly where the fix is or do you have anything specific as a fix for this problem?

TIA

BTW - I experimented with a clean install and update of Mepis 11 on a spare PC with a new hard disk. The Printer Config worked fine but of course did not have my printer (as the hplip version was way back). I then added the community repo, updated and tried again. The Printer Config still worked but only with version 3.10.7 of hplip. To get 3.10.11 for my printer I had to add the testing repos as well. As soon as I did that, I got 3.10.11 but printer config would no longer run (see my earlier post re "kcmodule missing" etc.) As I say I got the printer running by adding it under CUPS but no way will the print config run once hplip 3.10.11 is installed

As I say - I have the printer running under cups but no way will the print config application run....


Mon Dec 05, 2011 5:32 pm
Profile
Forum Veteran
Forum Veteran
User avatar

Joined: Wed Jul 12, 2006 2:26 pm
Posts: 7348
Has thanked: 408 times
Have thanks: 2427 times
Post # 290145
Post Re: Printer config failure: no kcmodule - known bug elsewher
@arjay, which version of KDE do you have installed?

In your first post you said "I am running Mepis 11 with Community Repo enabled - all up-to-date". I don't know if that means you also installed the upgrade to KDE 4.6.5, or if you are still running the KDE 4.5.3 that M11 comes with.

The version of the system-config-printer-kde package that gets installed with KDE 4.5.3 is a 4.4.5 version from the Debian squeeze repo. The version mismatch might be part of the problem.

If you upgraded to KDE 4.6.5, it has it's own 4.6.5 version system-config-printer-kde package (actually it's version 4:4.6.5-2mcr110+1) which matches up with the KDE version.


Mon Dec 05, 2011 6:32 pm
Profile
Forum Novice
Forum  Novice

Joined: Fri Jul 21, 2006 2:28 am
Posts: 71
Has thanked: 0 time
Have thanks: 2 times
Post # 290192
Post Re: Printer config failure: no kcmodule - known bug elsewher
kmathern wrote:
@arjay, which version of KDE do you have installed?

In your first post you said "I am running Mepis 11 with Community Repo enabled - all up-to-date". I don't know if that means you also installed the upgrade to KDE 4.6.5, or if you are still running the KDE 4.5.3 that M11 comes with.

The version of the system-config-printer-kde package that gets installed with KDE 4.5.3 is a 4.4.5 version from the Debian squeeze repo. The version mismatch might be part of the problem.

If you upgraded to KDE 4.6.5, it has it's own 4.6.5 version system-config-printer-kde package (actually it's version 4:4.6.5-2mcr110+1) which matches up with the KDE version.


Ah - that sounds promising. I am still using kde 4.5.3 after I borked my system with a poor upgrade to kde 4.6.5. (Totally my fault- didn't read the guide properly). I now have a second install on a spare PC and will upgrade that to kde 4.6.5 and see how that affects the printer config package. I'll report back here when done.

Thanks mate

RJ


Tue Dec 06, 2011 6:31 am
Profile
Forum Guide
Forum Guide

Joined: Tue Jul 25, 2006 12:47 pm
Posts: 1493
Location: Savannah, GA
Has thanked: 88 times
Have thanks: 308 times
Post # 290200
Post Re: Printer config failure: no kcmodule - known bug elsewher
I've got the same problem.

I have not upgraded to KDE 4.6.5.

I noticed I couldn't print anything yesterday and the HPLIP toolbox wouldn't load and tried reinstalling HPLIP from the Community repos with nothing changing. So, I went into System Settings>Printer Configuration and I see that same error shown. When I check Synaptic, the version of system-config-printer-kde installed is 4.4.4.5-4 (and that's the only version I see available when I check the Versions tab). So, I just booted into Windows to print something I needed to print until I could figure out what's going on with it.


Tue Dec 06, 2011 9:39 am
Profile
Forum Guide
Forum Guide

Joined: Tue Jul 25, 2006 12:47 pm
Posts: 1493
Location: Savannah, GA
Has thanked: 88 times
Have thanks: 308 times
Post # 290203
Post Re: Printer config failure: no kcmodule - known bug elsewher
IOW, if anyone has any suggestions, I'm all ears, as I see that exact same error now and I have not attempted to upgrade to KDE 4.6.5 yet. I don't know for sure when the problem started (i.e., what update may have caused it, or if something I installed recently may have caused it), as I just noticed it yesterday when I needed to print something (so that's when I realized I had a problem).


Tue Dec 06, 2011 9:50 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 24 posts ]  Go to page 1, 2, 3  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.