getting Wireless networking to work

Questions about Networking that deals with wireless cards, ethernet, modems, samba and anything else related to these, including software help. Tutorials for any of these can be posted too.

Remember to provide relevant info in your posts, such as the following information:

Version of Mepis being used
Card Manufacturer (i.e. Linksys)
Card Model (i.e. WMP54G)
Type: (PCI or PCMCIA)
Current Kernel in use on their system (i.e. 2.6.10)
Udev or Hotplug
Exact steps taken to get the card working if it is not immediately recognized by MEPIS.
Message
Author
User avatar
robert1
Forum Regular
Forum Regular
Posts: 187
Joined: Thu Jul 12, 2007 11:19 pm

getting Wireless networking to work

#1 Postby robert1 » Sun Apr 22, 2012 9:20 pm

Hi All, it's been a while since i have been here, but i guess that is because of the rock solidness of my Mepis 8.5 desktop.
i apologise for this post if it is considered rude because of asking for a little help with a different distro then Mepis. so here goes.

i have a HP Pavillian zt1130 laptop that was made in 2001 - 02. it has a intel mobil celeron 1.2 ghz processor with 512 Mb of memory. unfortunately, it cannot boot DVD's..only CD's. i have been using Mepis 8 on it for a long time & it served me well. My Linksys Wireless PC Card was supported perfectly. however the problem is that there really is not many choices of distributions that come on CDR sized I.S.O's. so what i did was replaced the hard drive with a blank drive, downloaded the Debian "Testing" version of the netinstall image & installed it using the "desktop=xfce" option.

the install started out ok, up until it got to the hardware discovery... at that point, it stalled. i had to do a hard shutdown with the power button. i decided to eject the wireless card from the card bus & start again. this time, the install with smoothly, without a hitch. the problem is now, i cannot get my wireless card to work. wicd does not list it, however, this shows up at the bottom of the listings in lspci:

02:00.0 Network controller [0280]: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)
Subsystem: Linksys WPC54G v3 802.11g Wireless-G Notebook Adapter [1737:0048]
Flags: bus master, fast devsel, latency 64, IRQ 11
Memory at 24000000 (32-bit, non-prefetchable) [size=8K]
Kernel driver in use: b43-pci-bridge

it appears that there is a kernel driver loaded. however, when i do a iwconfig, this is what i get:

root@debian:/home/robert# iwconfig
lo no wireless extensions.

wlan0 IEEE 802.11bg ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on

eth0 no wireless extensions.

can someone tell me what i need to do. it would really be appreciated.

mads65
Forum Novice
Forum  Novice
Posts: 19
Joined: Mon Apr 23, 2012 4:48 am

Re: getting Wireless networking to work

#2 Postby mads65 » Mon Apr 23, 2012 5:07 am

Hi!
Use a wired connection, and install "firmware-b43-installer" and "b43-fwcutter".

User avatar
robert1
Forum Regular
Forum Regular
Posts: 187
Joined: Thu Jul 12, 2007 11:19 pm

Re: getting Wireless networking to work

#3 Postby robert1 » Mon Apr 23, 2012 2:32 pm

mads65 wrote:Hi!
Use a wired connection, and install "firmware-b43-installer" and "b43-fwcutter".


Thanks. i installed b43-fwcutter a couple of days ago as well as copied the b43-legacy folder off of my Mepis 8.5 PC out of /lib/firmware to a flash drive & transferred it to the same directory on the laptop. however, that did not do anything...so i decided to shut it down, & try the AntiX 11 CD on it to see what happens there & to try to compare differences. it too, was having the same problem. in fact, lsmod, & iwconfig was showing that the card was there & the module was loaded, but wicd could not see it. i run ceni, & it saw the card, it needed to create a supplicant file, so i followed the directions & after i applied, the link light on the wireless card come on.

today, i removed the b43 legacy folder & used apt to install the b43-installer & then after that, i run b43-fwcutter -l to see the list of drivers. the application also showed a link to the linux wireless website : http://www.linuxwireless.org/en/users/D ... cefirmware . after checking that site out, i found that i did not need to run b43-fwcutter. i also found that the kernel driver is allready loaded. apparently, i would need ceni to make this work, but it is not in the debian repositories.

User avatar
robert1
Forum Regular
Forum Regular
Posts: 187
Joined: Thu Jul 12, 2007 11:19 pm

Re: getting Wireless networking to work

#4 Postby robert1 » Mon Apr 23, 2012 4:41 pm

Well, i was able to get ceni (Thanks Steveo) installed & it did find my wireless card. i was able to run the scan & it found my network. since i run wpa2 incryption on my network, i had to go further into the ceni setup & give my passkey info. however after following the steps, i am still having a problem. the link light on the card just flashes. wicd still does not see a wireless extention, but, when i run iwconfig, i get this:

root@debian:/home/robert# iwconfig
lo no wireless extensions.

wlan0 IEEE 802.11bg ESSID:"linuxuser"
Mode:Managed Frequency:2.437 GHz Access Point: 00:16:B6:BF:45:B8
Bit Rate=54 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=68/70 Signal level=-42 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:2 Invalid misc:35 Missed beacon:0

anything i am missing?

mads65
Forum Novice
Forum  Novice
Posts: 19
Joined: Mon Apr 23, 2012 4:48 am

Re: getting Wireless networking to work

#5 Postby mads65 » Mon Apr 23, 2012 6:27 pm

Try to bring up wlan0 interface
# ifconfig wlan0 up

Check if you can scan your ssid
# iwlist wlan0 scan

Check if /etc/resolv.conf shows your DNS nameservers. If not, add them manually
$ cat /etc/resolv.conf

Another thing. I have never used wicd, but I think it is not a good idea to have both wicd and networkmanager installed
# /etc/init.d/network-manager stop
# apt-get purge network-manager plasma-widget-networkmanagement knm-runtime libnm-glib2 libnm-util1

User avatar
robert1
Forum Regular
Forum Regular
Posts: 187
Joined: Thu Jul 12, 2007 11:19 pm

Re: getting Wireless networking to work

#6 Postby robert1 » Mon Apr 23, 2012 11:38 pm

mads65 wrote:Try to bring up wlan0 interface
# ifconfig wlan0 up


Did That. it was allready running

mads65 wrote:Check if you can scan your ssid
# iwlist wlan0 scan


Here's what iwlist shows:
root@debian:/home/robert# iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:16:B6:BF:45:B8
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=55/70 Signal level=-55 dBm
Encryption key:on
ESSID:"linuxuser"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=000001013f329819
Extra: Last beacon: 36ms ago
IE: Unknown: 00096C696E757875736572
IE: Unknown: 010882848B962430486C
IE: Unknown: 030106
IE: Unknown: 2A0104
IE: Unknown: 2F0104
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: Unknown: 32040C121860
IE: Unknown: DD09001018020014000000
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
Cell 02 - Address: C0:3F:0E:93:DE:F2
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=27/70 Signal level=-83 dBm
Encryption key:on
ESSID:"bugeja"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=0000000612b44b78
Extra: Last beacon: 1792ms ago
IE: Unknown: 0006627567656A61
IE: Unknown: 010882840B162430486C
IE: Unknown: 030101
IE: Unknown: 2A0104
IE: Unknown: 2F0104
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: Unknown: 32040C121860
IE: Unknown: DD7F0050F204104A00011010440001021041000100103B00010310470010D294107B4477DE1BFDE3A8511BBF86F91021000D4E4554474541522C20496E632E10230009574752363134763130102400095747523631347631301042000538333235381054000800060050F204000110110009574752363134763130100800020084
IE: Unknown: DD090010180202F0050000
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00

mads65 wrote:Check if /etc/resolv.conf shows your DNS nameservers. If not, add them manually
$ cat /etc/resolv.conf


cat: /etc/resolv.comf: No such file or directory

mads65 wrote:Another thing. I have never used wicd, but I think it is not a good idea to have both wicd and networkmanager installed


networkmanager is not installed

mads65 wrote:# /etc/init.d/network-manager stop
# apt-get purge network-manager plasma-widget-networkmanagement knm-runtime libnm-glib2 libnm-util1


this does not apply as i am not working on a Mepis installation...what i am working on is a Debian with xfce installation. there is no KDE libs installed on this installation. the laptop does not have enough memory for Mepis 11 & the only way i can install a Linux distribution is with CDR media only.
Last edited by robert1 on Tue Apr 24, 2012 7:34 pm, edited 1 time in total.

mads65
Forum Novice
Forum  Novice
Posts: 19
Joined: Mon Apr 23, 2012 4:48 am

Re: getting Wireless networking to work

#7 Postby mads65 » Tue Apr 24, 2012 3:37 am

robert1 wrote:
mads65 wrote:Check if /etc/resolv.conf shows your DNS nameservers. If not, add them manually
$ cat /etc/resolv.conf


cat: /etc/resolv.comf: No such file or directory

It is resolv.conf, and not resolv.comf.

First make sure that wlan0 is listed as the wireless interface in the wicd preferences.
Next, check the output of the "$ cat /etc/resolv.conf" command.
If it is empty, you need to add the DNS nameservers manually.
If it is not, and it shows the nameservers, then I don't know.

User avatar
robert1
Forum Regular
Forum Regular
Posts: 187
Joined: Thu Jul 12, 2007 11:19 pm

Re: getting Wireless networking to work

#8 Postby robert1 » Tue Apr 24, 2012 2:24 pm

mads65 wrote:Check if /etc/resolv.conf shows your DNS nameservers. If not, add them manually
$ cat /etc/resolv.conf


this is what shows up as entries in /etc/resolv.conf
nameserver 66.76.227.48
nameserver 208.180.42.68

however, i believe these were added there when connected through the ethernet connection. when i ran ceni, after entering my passkey, after advancing to the next field, there were no entries in the DNS nameserver fields.

mads65 wrote:It is resolv.conf, and not resolv.comf.


sorry, my bad. must have been a case of fumblefingers.

mads65 wrote:First make sure that wlan0 is listed as the wireless interface in the wicd preferences.


it is not showing up at all. all it is showing is "No wireless networks found"

User avatar
JBoman
Forum Guide
Forum Guide
Posts: 1473
Age: 58
Joined: Wed Jul 12, 2006 4:30 pm

Re: getting Wireless networking to work

#9 Postby JBoman » Tue Apr 24, 2012 4:35 pm

On a similar setup I had to do the following with Wicd &Ceni installed and no network manager.... First had to start the Mepis Network Assistant and go to the wireless on 2nd screen and there scan for the network with passkey entered... Whether anything showed or not doesn't matter.. go back to first screen and uncheck all listed drivers, click on dhcp and start network.... on mine it would not start so just close the assistant with X at top right of screen and reboot. Network did not start for me but then starting Ceni allowed a scan with passkey and connection was made. Closed Ceni and rebooted and finally wireless was recognized by Wicd and connected. May or may not work for your situation but figured I would share. I am beginning to think the Mepis assistant is what causes the wireless problems as other systems I have tried do not have the same problem connecting.
http://patentabsurdity.com/
AMD 64x2 2.6GHz 4GB ram MX-15 regular updates
"beware a frequent flirt with potential disaster"

User avatar
lucky9
Forum Veteran
Forum Veteran
Posts: 12274
Age: 70
Joined: Wed Jul 12, 2006 5:54 am

Re: getting Wireless networking to work

#10 Postby lucky9 » Tue Apr 24, 2012 6:49 pm

@JBoman : robert1 is not running Mepis.
Yes, even I am dishonest. Not in many ways, but in some. Forty-one, I think it is.
--Mark Twain


Return to “Networking”

Who is online

Users browsing this forum: No registered users and 1 guest