MX & MEPIS Community Forum

Linux operating systems based on Debian Stable
View unanswered posts | View unsolved topics | View active topics |



Reply to topic  [ 1 post ] 
VMWare Workstation 7 on Mepis11 and Windows98 as Guest 
Author Message
Forum Novice
Forum  Novice

Joined: Tue Jan 24, 2012 12:58 am
Posts: 23
Has thanked: 4 times
Have thanks: 2 times
Post # 295266
Post VMWare Workstation 7 on Mepis11 and Windows98 as Guest  [Solved]
Perhaps someone will be helped by my experience of installing VMWare Workstation 7.1.4 on Mepis11, and then Windows98 as Guest. I'm not sure whether this should have been placed in the "Success" or the "Testimonials" forums instead. If so, someone is welcome to move it, or, if it is of no value, delete it.

In the first place, I was amazed that VMWare installed with zero problems! I was expecting some significant problems here because it doesn't seem to be directly supported. The steps here were to download it to the folder of your choice. Then in a terminal (Konsole), as root, move to the folder where it was placed, and enter the command:
Code:
sh [package name].

When I tried to install Windows98, the first thing that happened was I got the error message that there is no /dev/vmmon device. When this happened in SLED11, I had found on Internet the command
Code:
mknod /dev/vmmon c 18 165
. Somehow I "slipped though the crack", because I believe that is not correct. There is a "Devices.txt" list maintained at this Web site:
http://www.mjmwired.net/kernel/Documentation/devices.txt
which shows the /dev/vmmon to be located at 165 in group 10. So I used the command:
Code:
mknod /dev/vmmon c 10 165
and it worked.

Next I got the error message about "Too Many Virtual Machines Running". The fix for that was the command
Code:
/etc/init.d/vmware.start
Now I could start the install.

In the install of Windows98, I first tried to install directly from the CD. It didn't work. Mine needs the boot floppy, and I used a boot floppy image. Here are 2 sources for boot floppy images:
http://www.bootdisk.com/bootdisk.htm
http://www.allbootdisks.com/download/98.html
In the VMWare settings, set the Floppy to "connected" and to "image", and browse to the file. After this was done, it found the A: drive.

Use FDISK to define all the drives you established when defining the Windows98 guest in VMWare, and then format them. I think you have to exit before you can FORMAT.

Now you can go to the cd drive where Windows98 is mounted. If you have both 98 & 98SE, choose the one you want and find the "setup.exe" file and enter it. The Install process will begin. Sometime after the point that it offers to make a "Start-up Floppy", and before it wants to re-start Windows, you need to disconnect the boot image, or it won't restart. I went through the installation 3 times before I realized that was the problem! Also, after Windows is installed, Install the "VMWare Tools" if you didn't get them initially.

There is a 2-Part set of a youtube tutorial that you might like to see at:
http://www.youtube.com/watch?v=ihDQaYquLrA&feature=related
http://www.youtube.com/watch?v=vvBlhIav7tA&feature=related

I am happy that this worked, as I was afraid it might take a lot more study.
Lauren


Tue Feb 07, 2012 12:54 am

mr.Lauren thanked by: lucky9, Utopia
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.