MX & MEPIS Community Forum

Linux operating systems based on Debian Stable
View unanswered posts | View unsolved topics | View active topics |



Reply to topic  [ 17 posts ]  Go to page 1, 2  Next
e2fsprogs upgrade broken 
Author Message
Forum Regular
Forum Regular
User avatar

Joined: Wed Aug 30, 2006 1:44 am
Posts: 606
Location: Midway between the Washington State rainforest, ocean and volcanoes
Has thanked: 773 times
Have thanks: 69 times
Post # 278027
 e2fsprogs upgrade broken
Greetings and hope you are surviving the heat - which seems to be everywhere except the chilly and overcast area of Southwestern Washington where I am .

I was mid-upgrading with Synaptic a few days ago and lost my wireless connection.

Besides not having wireless, I also ended up with a broken package
Searched with Synaptic and found that e2fsprogs was broken - I think I understand that the dependency is off but am clueless about how to repair it.

Any links or ideas would be appreciated. I really don't have time to do my regular research as I am on the road for work ( and lucky that a client let me use their wired connection :alien: )


Code:
[root@gove user]# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 e2fsprogs : PreDepends: e2fslibs (= 1.41.12-2) but 1.41.12-4stable1 is installed
E: Unmet dependencies. Try using -f.

[root@gove user]# apt-get -f install e2fsprogs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  gpart e2fsck-static
The following packages will be upgraded:
  e2fsprogs
1 upgraded, 0 newly installed, 0 to remove and 30 not upgraded.
Need to get 0 B/818 kB of archives.
After this operation, 0 B of additional disk space will be used.
debconf: unable to initialize frontend: Kde
debconf: (Unable to load QtGui -- is libqtgui4-perl installed?)
debconf: falling back to frontend: Dialog
(Reading database ... 118452 files and directories currently installed.)
Preparing to replace e2fsprogs 1.41.12-2 (using .../e2fsprogs_1.41.12-4stable1_amd64.deb) ...
Unpacking replacement e2fsprogs ...
Replaced by files in installed package util-linux ...
dpkg: error processing /var/cache/apt/archives/e2fsprogs_1.41.12-4stable1_amd64.deb (--unpack):
 unable to create `/usr/share/locale/tr/LC_MESSAGES/e2fsprogs.mo.dpkg-new' (while processing `./usr/share/locale/tr/LC_MESSAGES/e2fsprogs.mo'): No such file or directory
configured to not write apport reports
                                      dpkg-deb: subprocess paste killed by signal (Broken pipe)
Processing triggers for man-db ...
debconf: unable to initialize frontend: Kde
debconf: (Unable to load QtCore -- is libqtcore4-perl installed?)
debconf: falling back to frontend: Dialog
Errors were encountered while processing:
 /var/cache/apt/archives/e2fsprogs_1.41.12-4stable1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


I am running Mepis 11 and need to go to a meeting, so apologies if I am short.

Enjoy

_________________
...Ostara.................................... minni
Image Image
...Mepis 11_64...........................Mepis 11_32


Last edited by iridesce on Tue Jul 12, 2011 9:37 pm, edited 1 time in total.



Tue Jun 28, 2011 5:51 pm
Profile
Forum Regular
Forum Regular

Joined: Wed Jul 29, 2009 6:05 pm
Posts: 355
Location: New Zealand
Has thanked: 25 times
Have thanks: 76 times
Post # 278028
Post Re: e2fsprogs upgrade broken
Have you tried synaptics > edit > fix broken packages?

_________________
Mepis 11 64bit Linux 3.2.0-0.bpo.4-amd64, KDE 4.5.1
Intel i5 2400, Asus P8H67-M-EVO, G-Skill Ripjaws 2x4GB DDR3-1333, nVidia GeForce GT430, Seagate 500GB sata3 HDD


Tue Jun 28, 2011 6:09 pm

chippy52 thanked by: iridesce
Profile
Forum Regular
Forum Regular
User avatar

Joined: Wed Aug 30, 2006 1:44 am
Posts: 606
Location: Midway between the Washington State rainforest, ocean and volcanoes
Has thanked: 773 times
Have thanks: 69 times
Post # 278228
Post Re: e2fsprogs upgrade broken
chippy52 wrote:
Have you tried synaptics > edit > fix broken packages?


Thanks for the idea - now that I am back home with a wired connection, I did try 'fix broken packages' the output is below ( had to PrintScreen as I couldn't copy )
Image

Any ideas?

_________________
...Ostara.................................... minni
Image Image
...Mepis 11_64...........................Mepis 11_32


Fri Jul 01, 2011 5:57 pm
Profile
Forum Veteran
Forum Veteran
User avatar

Joined: Wed Jul 12, 2006 2:26 pm
Posts: 7348
Has thanked: 408 times
Have thanks: 2427 times
Post # 278229
Post Re: e2fsprogs upgrade broken
There's a bugreport here: http://www.mail-archive.com/debian-bugs ... 16204.html that seems to be the same problem that you are having. It doesn't really have any fixes or workarounds though.

Does the /usr/share/locale/tr directory exist? (what does ls -l /usr/share/locale/tr show?)

Does the /usr/share/locale/tr/LC_MESSAGES directory exist? (what does ls -l /usr/share/locale/tr/LC_MESSAGES show?)


Fri Jul 01, 2011 7:07 pm

kmathern thanked by: iridesce
Profile
Forum Regular
Forum Regular
User avatar

Joined: Wed Aug 30, 2006 1:44 am
Posts: 606
Location: Midway between the Washington State rainforest, ocean and volcanoes
Has thanked: 773 times
Have thanks: 69 times
Post # 278253
Post Re: e2fsprogs upgrade broken
kmathern wrote:
There's a bugreport here: http://www.mail-archive.com/debian-bugs ... 16204.html that seems to be the same problem that you are having. It doesn't really have any fixes or workarounds though.

Thanks for the research - good? that at least someone else ....
kmathern wrote:
Does the /usr/share/locale/tr directory exist?
No
kmathern wrote:
(what does ls -l /usr/share/locale/tr show?)

Code:
user@gove:~$ ls -l /usr/share/locale/tr
ls: cannot access /usr/share/locale/tr: No such file or directory

kmathern wrote:
Does the /usr/share/locale/tr/LC_MESSAGES directory exist?
No
kmathern wrote:
(what does ls -l /usr/share/locale/tr/LC_MESSAGES show?)

Code:
user@gove:~$ ls -l /usr/share/locale/tr/LC_MESSAGES
ls: cannot access /usr/share/locale/tr/LC_MESSAGES: No such file or directory


Then did create /usr/share /tc and /usr/share/tc/LC_MESSAGES/ - ran apt-get upgrade, still no joy

Am I correct to understand that using the -4stable1 version of e2fslibs instead of the -2 is causing the problem?

I did get as far as attempting to replace e2fslibs with Synaptic when I was stopped at the numerous warnings. Again, am I to understand that as this is a file system file, removing it in the process of upgrading it would destabilize the system?

Thanks for your input.

Edit: Forgot to advise that I now do have wireless.....
.......Remember, this all started when I was upgrading via Synaptic and lost wireless midupgrade - then could not reestablish connection during that session.

Edit 2: I'm going camping for the 4th tomorrow am, enjoy your weekend

_________________
...Ostara.................................... minni
Image Image
...Mepis 11_64...........................Mepis 11_32


Sat Jul 02, 2011 1:16 am
Profile
Forum Veteran
Forum Veteran
User avatar

Joined: Wed Jul 12, 2006 2:26 pm
Posts: 7348
Has thanked: 408 times
Have thanks: 2427 times
Post # 278261
Post Re: e2fsprogs upgrade broken
iridesce wrote:

Then did create /usr/share /tc and /usr/share/tc/LC_MESSAGES/ - ran apt-get upgrade, still no joy

That was going to be the next thing that I was going to suggest, adding the directories yourself. But if those are the directories you created (and not typos) it wouldn't have fixed anything. You might try creating them again with:
Quote:
su -c 'mkdir -p /usr/share/locale/tr/LC_MESSAGES'


Sat Jul 02, 2011 6:18 am

kmathern thanked by: iridesce
Profile
Forum Veteran
Forum Veteran
User avatar

Joined: Fri Dec 15, 2006 8:07 pm
Posts: 8902
Location: Skullcrusher Mountain, Santee, CA USA
Has thanked: 638 times
Have thanks: 2053 times
Post # 278279
Post Re: e2fsprogs upgrade broken
I think those updates were part of the Debian 6.0.2 upgrade, and went through fine on all my installs. No doubt the interruption cause some kind of problem.

I wonder what would happen if you downloaded both the problem deb packages and installed them with "dpkg -i" as root?

http://packages.debian.org/squeeze/e2fsprogs
http://packages.debian.org/squeeze/e2fslibs

dpkg also has some force-install options that will install the packages despite errors, though that can be dangerous.


Sat Jul 02, 2011 1:37 pm

Stevo thanked by: iridesce
Profile
Forum Regular
Forum Regular
User avatar

Joined: Mon Jan 14, 2008 2:00 am
Posts: 588
Location: w/coast 5555 ;) high5
Has thanked: 88 times
Have thanks: 122 times
Post # 278442
 Re: e2fsprogs upgrade broken
.
hi,

I would try the old apt-get dist-upgrade and see if that will configure it for you. if not, possibly a apt-get -f install to kind of fix broken packages or something like that.

cool bug report :) then, found another one over here, hey, we're famous even mentions that he's using M11 and that he found your thread helpful :thumbup:.

plus -> anything that Stevo says :biggrin:.

Quote:
-> -> quote quote quote

apt-get clean

apt-get update

you might have to hit UP ARROW about 10 or more times till it finally updates, I see this problem alot

Edit: -r tab -i UP ARROW -> -> from that thread ;)


easys now, and happy fourth *boom* ;-)

“do you have localepurge installed and configured?” (another quote:) :smiley2:. * BOOM *

Code:
loco@yee-hahaha:~$ inxi -Fr
System:    Host yee-hahaha Kernel 2.6.39-2.slh.2-aptosid-amd64 x86_64 (64 bit) Desktop KDE 4.6.4 Distro MEPIS 11.0 squeeze
Machine:   System HP-Pavilion product FK954AAR-ABA a6535c
           Mobo PEGATRON model Benicia version 1.01 Bios American Megatrends version 5.30 date 09/05/2008
CPU:       Quad core Intel Core2 Quad CPU Q6600 (-MCP-) cache 4096 KB flags (lm nx sse sse2 sse3 ssse3 vmx)
           Clock Speeds: (1) 1600.00 MHz (2) 1600.00 MHz (3) 1600.00 MHz (4) 1600.00 MHz
Graphics:  Card: Intel 82G33/G31 Express Integrated Graphics Controller
           X.Org 1.10.2 driver intel Resolution 1920x1080@60.0hz
           GLX Renderer Mesa DRI Intel G33 GLX Version 1.4 Mesa 7.10.3
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller driver HDA Intel Sound: ALSA v: 1.0.24
Network:   Card Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver r8169
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:00:15:00:55:ed
Drives:    HDD Total Size: 500.1GB (1.1% used) 1: /dev/sda Hitachi_HDP72505 500.1GB
Partition: ID:/ size: 15G used: 5.1G (37%) fs: ext4 ID:swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap
           ID:swap-2 size: 2.11GB used: 0.00GB (0%) fs: swap ID:swap-3 size: 2.25GB used: 0.00GB (0%) fs: swap
Sensors:   System Temperatures: cpu: 41.0C mobo: 28.0C
           Fan Speeds (in rpm): cpu: 1443 fan-2: 1045 fan-3: 0 fan-4: 0
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb ftp://ftp.us.debian.org/debian/ testing main contrib non-free
           deb ftp://ftp.us.debian.org/debian/ unstable main contrib non-free
           deb ftp://ftp.us.debian.org/debian/ experimental main
           deb http://qt-kde.debian.net/debian/ experimental-snapshots main
           deb http://www.debian-multimedia.org testing main non-free
           deb http://aptosid.com/debian/ sid main fix.main
           Active apt sources in file: /etc/apt/sources.list.d/opera.list
           deb http://deb.opera.com/opera/ stable non-free #Opera Browser (final releases)
Info:      Processes 159 Uptime 3:53 Memory 743.7/5977.2MB Client Shell inxi 1.7.13
ps version 1.41.12-4stable1 installed here :) wheezy/M11 64bit, hmm, looks the same to me. * boom * ;-)

_________________
.
.

speedtest.net
:happy: >>> :spoon-fed: ;-)

Mon Jul 04, 2011 7:41 pm

loco thanked by: iridesce
Profile WWW
Forum Veteran
Forum Veteran
User avatar

Joined: Fri Dec 15, 2006 8:07 pm
Posts: 8902
Location: Skullcrusher Mountain, Santee, CA USA
Has thanked: 638 times
Have thanks: 2053 times
Post # 278448
Post Re: e2fsprogs upgrade broken
Followed up on the debian bug report--there is now an official bug report and the fix has been committed:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=631808

So expect an update for dpkg to appear sometime soon, after which the packages should update correctly. The root cause would seem to be that some directories shared between packages have been deleted, somehow.


Mon Jul 04, 2011 8:57 pm

Stevo thanked by: iridesce
Profile
Forum Regular
Forum Regular
User avatar

Joined: Wed Aug 30, 2006 1:44 am
Posts: 606
Location: Midway between the Washington State rainforest, ocean and volcanoes
Has thanked: 773 times
Have thanks: 69 times
Post # 278532
Post Re: e2fsprogs upgrade broken
The only way to outshine seeing the insane amount of fireworks up and down the Washington coast is to have three solid days of sunshine while camping.:beach:

OK, I cheated and brought my notebook to check on work :killcomputer: and am sitting in the Ocean Shores Tully's but really I've been good and polished off a book and some magazines, walked on the beach and generally relaxed.

Weirdly, though I was able to connect with my broken M11 to the access point here, I wasn't able to browse - forunately I still have M8.5 on a partitiion and am able to fully connect using that. For whatever reason, I had been able to fully connect to my access point at home, but never on the road :confused: since the breakage.

So, anyways thanks to everyone who has input so far. When I get home in a few days or while I am in Houston over the weekend I will get back to this.

Hope you all had a safe and playful Fourth with more summer fun to go.

_________________
...Ostara.................................... minni
Image Image
...Mepis 11_64...........................Mepis 11_32


Tue Jul 05, 2011 6:09 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 17 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.