MEPIS Community Forum

A Linux operating system based on Debian Stable
View unanswered posts | View unsolved topics | View active topics |



Reply to topic  [ 16 posts ]  Go to page 1, 2  Next
Random Mouse errors - Locking system 
Author Message
Forum Guide
Forum Guide
User avatar

Joined: Sun Apr 01, 2007 4:54 pm
Posts: 1271
Location: Las Vegas, NV
Has thanked: 167 times
Have thanks: 75 times
Post # 253280
Post Random Mouse errors - Locking system
I am not certain what is happening, but randomly when I left click on the "x" in the upper right corner of Google Chrome, Fire Fox or Konqueror, the system locks up and I have no keyboard either...

Only recourse at that moment is to pull the electric power (pull cord, hold power button down for five-ten seconds)

This mouse change all took place after the Xorg update, and I had to use sgfxi script to update my ATI drivers...

I am getting a few shutdown errors machine will not shut down:

Code:
PID:7472
Comm" Xorg tanted:P
Call trace   <--- lots of memory locations are listed


Has anyone seen this propblem, or might it be that i have a motherboard failure taking place.

I have change mice, and I have changed USB ports it is still occurring 1-3 time in a two hour session... I am going to locate a PS2 port mouse to see if that solves the situation.

But any suggestions would be appreciated, I do not think the Xorg problem would be related...

JR
* * *
64-bit Mepis 8.0.15 and a quick antiX


Sat Dec 04, 2010 11:40 am
Profile
Forum Guide
Forum Guide
User avatar

Joined: Wed Jul 12, 2006 1:31 am
Posts: 1457
Has thanked: 45 times
Have thanks: 78 times
Post # 253281
Post 
Any Nokia mobile device connected via usb at the time by any chance? If so it's this:

http://code.google.com/p/chromium/issues/detail?id=54617

Solution - patch kernel or upgrade or avoid using phone via usb while browsing...I haven't heard about it affecting Firefox or Konqueror though...

_________________

::AMD Phenom II X2 550 BE 3.1GHz::Gigabyte GA-MA785GMT-UD2H::Crucial 2gig DDR3 1333MHz/PC3-10600::Hitachi DeskStar 1TB Hard Drive SATAII 7200rpm 16MB Cache::
::O² Joggler::


Sat Dec 04, 2010 12:15 pm
Profile WWW
Forum Guide
Forum Guide
User avatar

Joined: Sun Apr 01, 2007 4:54 pm
Posts: 1271
Location: Las Vegas, NV
Has thanked: 167 times
Have thanks: 75 times
Post # 253285
Post 
Acesabe wrote:
Any Nokia mobile device connected via usb at the time by any chance? If so it's this:

http://code.google.com/p/chromium/issues/detail?id=54617

Solution - patch kernel or upgrade or avoid using phone via usb while browsing...I haven't heard about it affecting Firefox or Konqueror though...

* * *
Acesabe,

Now it seems to be most "X" in the upper corner of any window, and window dialogs boxes. Just crashed not a "x" in the upper corner, it was email dialog box with the choices cancel or send. I pressed send and computer froze solid... No keyboard, to shut down computer just a complete lockup...

No Nokia phone attached or used with this system...

I am using a Gigabyte motherboard GA-MA785GM-US2H AM3/AM2+/AM2 AMD 785G HDMI Micro ATX. Unfortunately it only has a single PS2 port. That does not let me test the PS2 mouse. I might have a splitter some place, that might work, but I have never tried that type of arrangement.
http://www.newegg.com/Product/Product.aspx?Item=N82E16813128394

USB Printer still works, or the random error did not happen while printing several pages.

JR
* * *
64-bit version of mepis 8.0.15 and a quick antiX


Sat Dec 04, 2010 4:10 pm
Profile
Forum Guide
Forum Guide
User avatar

Joined: Sun Dec 16, 2007 6:29 pm
Posts: 1046
Location: UK
Has thanked: 810 times
Have thanks: 87 times
Post # 253287
Post 
What happens in Antix?

If no problem in Antix, I suggest a reinstall of Mepis.


Sat Dec 04, 2010 5:09 pm
Profile
Forum Guide
Forum Guide
User avatar

Joined: Wed Jul 12, 2006 1:31 am
Posts: 1457
Has thanked: 45 times
Have thanks: 78 times
Post # 253289
Post 
I have the same mobo but have not experienced this, sounds like a video driver issue to me-I suggest you go through a driver sanity check to see if u have any installed package conflicts.

_________________

::AMD Phenom II X2 550 BE 3.1GHz::Gigabyte GA-MA785GMT-UD2H::Crucial 2gig DDR3 1333MHz/PC3-10600::Hitachi DeskStar 1TB Hard Drive SATAII 7200rpm 16MB Cache::
::O² Joggler::


Sat Dec 04, 2010 5:36 pm
Profile WWW
Forum Guide
Forum Guide
User avatar

Joined: Sun Apr 01, 2007 4:54 pm
Posts: 1271
Location: Las Vegas, NV
Has thanked: 167 times
Have thanks: 75 times
Post # 253295
Post 
GuiGuy wrote:
What happens in Antix?

If no problem in Antix, I suggest a reinstall of Mepis.


AntiX is in another system, and since there is no working XBMC in mepis 8.0.15 I am trying to save this installation...

This computer is my movie player, no TV or cable TV...

I have two other 64-bit Mepis systems this is the last install with a working XBMC... Was not able to install the Unbuntu version previously suggested. Thus I would like to save this one install...

JR
* * *
64-bit version of Mepis 8.0.15 and a quick AntiX


Sat Dec 04, 2010 11:02 pm
Profile
Forum Guide
Forum Guide
User avatar

Joined: Sun Apr 01, 2007 4:54 pm
Posts: 1271
Location: Las Vegas, NV
Has thanked: 167 times
Have thanks: 75 times
Post # 253299
Post 
Acesabe wrote:
I have the same mobo but have not experienced this, sounds like a video driver issue to me-I suggest you go through a driver sanity check to see if u have any installed package conflicts.


System did not finish shutting down:

Code:
PID:7355, Comm:Xorg Taninted:P  2.6.27-1-Mepis64-smp #1

Call Trace:
[<ffffffff8055861b>] schedule+Oxab/0x574
[<ffffffff8022d4a9>] __wake_up+0x38/0x4f
[<ffffffff80559f2f>] __lock_text_start+0x2f/0x36
[<ffffffffa021c2c0>] KAS_Thread_WaitForFinish+0x9e/0xb8 [fglrx]
[<ffffffff80249038>] autoremove_wake_function+0x0/0x2e
[<ffffffffa0232877>] MCIL_WorkerThread_0x177/0x230 [fglrx]
[<ffffffffa0233f16>] MCIL_GetExecutionLevel1+0x66/0x80 [fglrx][<ffffffffa02e0451>] Passivering_Cleanup+0x61/0xc0 [fglrx]
[<ffffffff80559f2f>] __Lock_text_start+0z2f/0x36
[<ffffffff8026cd99>] synchronize_irq+0x3e/0x36
[<ffffffff8026cd98>] free_irq+0xc7/0x10c
[<ffffffffa02dfaa0>] IRQMGR_FreResources+0x20/0x60 [fglrx]
[<ffffffffa023510c>] irqmgr_wrap_sutdown+0x12c/0x180
[<ffffffffa0227302>] firegl_takedown+0x7a2/0x840 [fglrx]
[<ffffffffa02f47a2>] amdPcsengine_Initdatabase+0x12/0x20 [fglrx]
[<ffffffffa0226455>] firegl_release+0x125/0x1c0 [fglrx]
[<ffffffff802952bc>] __fput+0xa1/0x16b
[<ffffffff80292bca>] flip+close+0x5e/0x66
[<ffffffff80238af6>] put_files_struct+0x66
[<ffffffff80239db0>] do_exit+0x22e/0x7cc
[<ffffffff80240c4c>] __dequeue_signal+0xee/011c
[<ffffffff8055a2b7>] _spin_unlock+0x5/0x2d
[<ffffffff8023a3b7>] do_group_exit+0x67/096
[<ffffffff80242eb6>] get_signal_to_deliver+0x2f7/0x342
[<ffffffff8020b5b5>] sysret_signal1+0x3d/0x67
[<ffffffff8020a7cc>] do_notify_resume+0x8c/0x85
[<ffffffff8024d27e>] sched_clock_cpu+0x10a/0x116
[<ffffffff80559fb3>] _spin_lock+0x14/0x16
[<ffffffff8022d5ac>] taskrq_lock+05x50/0x85
[<ffffffff80232764>] try_to_wake_up+0x175/0187
[<ffffffff80240c9a>] signal_wake_up+0x20/0x2f
[<ffffffff80241155>] send_signal+0x1c4/0x1e0
{<ffffffff8055a2b7>] _spin_unlock+0x5/0x2d
[<ffffffff802a44b9>] dput+0xad/0x138
[<ffffffff802a9c26>] mntput_no_expire+0x20/0x125
[<ffffffff8055a37a>] _spin_unlock_irq+0x5/0x35
[<ffffffff8020b5b5>] sysret_signal+0x3d/0x67
[<ffffffff8020b957>] ptregscall_common+0x67/0xb0


I believe I have transcribed the above correctly, was not able to cut and paste...

Any hand holding before I try to go back and reinstall the Xorg update, and redo the "sgfxi" script? I hope this is tainted Xorg is the problem with my mouse and keyboard becoming non functional not enabling me to do a proper shutdown...

JR
* * *
64-bit version of Mepis 8.0.15 and a quick AntiX


You do not have the required permissions to view the files attached to this post.


Sun Dec 05, 2010 1:19 am
Profile
Forum Veteran
Forum Veteran
User avatar

Joined: Fri Dec 15, 2006 8:07 pm
Posts: 8695
Location: Skullcrusher Mountain, Santee, CA USA
Has thanked: 582 times
Have thanks: 1954 times
Post # 253300
Post 
Yeah, that's a kernel bug error trace, but I don't think anyone here has the knowhow to fix it. The "tainted" message is because you are using a closed source driver--anyone using one will get that message, crash or not.


Sun Dec 05, 2010 1:22 am
Profile
Forum Guide
Forum Guide
User avatar

Joined: Wed Jul 12, 2006 1:31 am
Posts: 1457
Has thanked: 45 times
Have thanks: 78 times
Post # 253306
Post 
Yep - essentially you are getting an kernel oops (kernel panic) caused by some yet to be identified issue with xorg and fglrx. This is as Stevo says, beyond the likely abilities of folks here, although maybe H2 (smxi/sgfxi) may have some info.

Good news is, that once Warren gets the kernel firmware needed by the Xorg Radeon drivers working/installed (currently missing)- it is likely that you won't need fglrx (this is for M11 onwards). On my Ubuntu install I have only the Xorg Radeon driver working and can say that even full screen Flash video streaming is pretty much perfect, and possibly even better now Flash have released their hardware accelerated gl version:

http://labs.adobe.com/technologies/flashplayer10/

It seems for us Ati users - things are getting better all the time - wish it was true for Nvidia...

_________________

::AMD Phenom II X2 550 BE 3.1GHz::Gigabyte GA-MA785GMT-UD2H::Crucial 2gig DDR3 1333MHz/PC3-10600::Hitachi DeskStar 1TB Hard Drive SATAII 7200rpm 16MB Cache::
::O² Joggler::


Sun Dec 05, 2010 8:39 am
Profile WWW
Forum Guide
Forum Guide
User avatar

Joined: Sun Apr 01, 2007 4:54 pm
Posts: 1271
Location: Las Vegas, NV
Has thanked: 167 times
Have thanks: 75 times
Post # 253308
Post 
Acesabe wrote:
Yep - essentially you are getting an kernel oops (kernel panic) caused by some yet to be identified issue with xorg and fglrx. This is as Stevo says, beyond the likely abilities of folks here, although maybe H2 (smxi/sgfxi) may have some info.

Good news is, that once Warren gets the kernel firmware needed by the Xorg Radeon drivers working/installed (currently missing)- it is likely that you won't need fglrx (this is for M11 onwards). On my Ubuntu install I have only the Xorg Radeon driver working and can say that even full screen Flash video streaming is pretty much perfect, and possibly even better now Flash have released their hardware accelerated gl version:

http://labs.adobe.com/technologies/flashplayer10/

It seems for us Ati users - things are getting better all the time - wish it was true for Nvidia...


I use the proprietary video drivers to get full 16:9 monitor displays 1920x1080, and I am eager to go up to the new 16:9 2560x1440 resolution, since I have seen the Dell 2711 unit selling below $700... It would be nice to see a few 16:9 display options pressing F3 with Mepis 11 Live DVD
http://www.anandtech.com/show/2922

JR
* * *
Mepis 8.0.15, Mepis 11 Alpha3, and a quick antiX


Sun Dec 05, 2010 11:12 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 16 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.