3.1 Liquorix kernel debs.

Those who have created deb or tar packages to share with other MEPIS users can create a thread in this forum to do that. Also those that request someone to create a package for them, can be posted here.
Message
Author
User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11025
Age: 57
Joined: Fri Dec 15, 2006 8:07 pm

3.1 Liquorix kernel debs.

#1 Postby Stevo » Fri Nov 18, 2011 12:43 am

As always, use at your own risk, and keep a working kernel as a backup. Refer to the 3.0 thread for more info.

Aufs has not been updated yet for the 3.1 Liquorix kernel, and PAE is still broken.

What's new in the 3.1 kernel: http://www.h-online.com/open/features/W ... 47364.html

Links: 32-bit: http://ubuntuone.com/2tVlJv1ByWG9nAgtEsSWuN

64-bit: http://ubuntuone.com/2g5wRgBZd3hde862QNSFL9

Hmmm--it may consume less power than previous Liquourix kernels, too: http://techpatterns.com/forums/about1963.html
The optimist proclaims that we live in the best of all possible worlds, and the pessimist fears this is true.

James Branch Cabell

User avatar
dsptech
Forum Novice
Forum  Novice
Posts: 96
Age: 46
Joined: Sat Jul 15, 2006 4:56 am

Re: 3.1 Liquorix kernel debs.

#2 Postby dsptech » Sat Nov 19, 2011 12:18 am

Installed 32 bit version and all seems fine so far.
Had to manually edit menu.lst and update symlinks though.

User avatar
richb
Administrator
Posts: 12961
Age: 71
Joined: Wed Jul 12, 2006 2:17 pm

Re: 3.1 Liquorix kernel debs.

#3 Postby richb » Sat Nov 19, 2011 7:17 am

Also installed 3.1 kernel. Used update-grub for menu.list. It appears to have solved my problem with the system freezing. And desktop effects with OpenGL are working. (The xserver updates from Debian Squeeze backports also installed).
Forum Rules
Guide - How to Ask for Help

Rich

Laptop: Acer V5-572G: Intel i5, 12 GIG mem, Intel graphics, SanDisk SSD, 256GB
Virtualbox: Win 7
Desktop: MX-15- 64, AMD A8 7600 FM2+ CPU R7 Graphics, fglrx driver, 16 GIG Mem. Samsung EVO SSD 250 GB

User avatar
smilliken
Forum Guide
Forum Guide
Posts: 1980
Age: 57
Joined: Tue Feb 06, 2007 11:47 pm

Re: 3.1 Liquorix kernel debs.

#4 Postby smilliken » Sat Nov 19, 2011 5:12 pm

Installed 32bit on the partition that I had set up for the testing of your 4.6.5 upgrade and all installed just fine. The re-boot was the same and all seems to work to date.

I did try to install 32 bit on another partition with I have M11 with the Danum 4.6.5 upgrade on it and received the following error:

Code: Select all

dpkg -i *.deb
(Reading database ... 122012 files and directories currently installed.)
Preparing to replace initramfs-tools 0.99 (using initramfs-tools_0.99-1mcr110+1_all.deb) ...
Unpacking replacement initramfs-tools ...
Selecting previously unselected package linux-headers-3.1.0-1.dmz.2-liquorix-686.
Unpacking linux-headers-3.1.0-1.dmz.2-liquorix-686 (from linux-headers-3.1.0-1.dmz.2-liquorix-686_3.1.0-2mcr110+1_i386.deb) ...
Selecting previously unselected package linux-image-3.1.0-1.dmz.2-liquorix-686.
Unpacking linux-image-3.1.0-1.dmz.2-liquorix-686 (from linux-image-3.1.0-1.dmz.2-liquorix-686_3.1.0-2mcr110+1_i386.deb) ...
Preparing to replace module-init-tools 3.16-1 (using module-init-tools_3.16-1mcr110+1_i386.deb) ...
Unpacking replacement module-init-tools ...
Setting up linux-headers-3.1.0-1.dmz.2-liquorix-686 (3.1.0-2mcr110+1) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.1.0-1.dmz.2-liquorix-686
Setting up module-init-tools (3.16-1mcr110+1) ...
Processing triggers for man-db ...
Setting up initramfs-tools (0.99-1mcr110+1) ...
update-initramfs: deferring update (trigger activated)
Setting up linux-image-3.1.0-1.dmz.2-liquorix-686 (3.1.0-2mcr110+1) ...
Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 3.1.0-1.dmz.2-liquorix-686 /boot/vmlinuz-3.1.0-1.dmz.2-liquorix-686
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.1.0-1.dmz.2-liquorix-686 /boot/vmlinuz-3.1.0-1.dmz.2-liquorix-686
update-initramfs: Generating /boot/initrd.img-3.1.0-1.dmz.2-liquorix-686
E: /usr/share/initramfs-tools/hooks/plymouth failed with return 1.
update-initramfs: failed for /boot/initrd.img-3.1.0-1.dmz.2-liquorix-686 with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.1.0-1.dmz.2-liquorix-686.postinst line 774.
dpkg: error processing linux-image-3.1.0-1.dmz.2-liquorix-686 (--install):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for initramfs-tools ...
update-initramfs: /boot/initrd.img-2.6.36-1-mepis-smp has been altered.
update-initramfs: Cannot update. Override with -t option.
Errors were encountered while processing:
 linux-image-3.1.0-1.dmz.2-liquorix-686
Last edited by smilliken on Sat Nov 19, 2011 5:33 pm, edited 1 time in total.
There is no "Ctrl+Z" in life!
Acer 7551G MX-15
Dell 1525, MX15 XFCE4 & Win 10
HP DV4-1118 Mepis 12 4.14 & Win 10
HP CP1215/Brother DCP-7065DN
Linux User# 4523410

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11025
Age: 57
Joined: Fri Dec 15, 2006 8:07 pm

Re: 3.1 Liquorix kernel debs.

#5 Postby Stevo » Sat Nov 19, 2011 5:25 pm

It's weird that the build won't complete the repository packages.

debuild -B works to create the arch-dependent debs only, which be great if the -sa flag also worked.

debuild -sa dies after creating the real packages but while building the metapackages.

debuild -B -sa also fails in the same place...
The optimist proclaims that we live in the best of all possible worlds, and the pessimist fears this is true.

James Branch Cabell

User avatar
smilliken
Forum Guide
Forum Guide
Posts: 1980
Age: 57
Joined: Tue Feb 06, 2007 11:47 pm

Re: 3.1 Liquorix kernel debs.

#6 Postby smilliken » Sat Nov 19, 2011 5:46 pm

Just gave this kernel ago on one of the 64 bit systems. Lots of messages about needing firmware for ATI, re-booted just fine and seems to be working. 3D desktop effects worked OOTB with no need to re-run sgfxi. This is also an upgrade 4.6.5 thru the Stevo/Kmathern thread.

So far the only problem I have is that conky does not run.

Get this:

Code: Select all

conky .conkyrc1
Conky: can't open '/sys/bus/platform/devices/coretemp.0/temp1_input': No such file or directory
please check your device or remove this var from Conky
Conky: Error destroying thread
Conky: Error destroying thread
Conky: Error destroying thread
Conky: Error destroying thread
***** Imlib2 Developer Warning ***** :
        This program is calling the Imlib call:

        imlib_context_free();

        With the parameter:

        context

        being NULL. Please fix your program.                                                                                               
Scott@Mepis11:~$ uname -r                                                                                                                   
3.1.0-1.dmz.2-liquorix-amd64


Also the lower right taskbar is a bit off.
You do not have the required permissions to view the files attached to this post.
There is no "Ctrl+Z" in life!
Acer 7551G MX-15
Dell 1525, MX15 XFCE4 & Win 10
HP DV4-1118 Mepis 12 4.14 & Win 10
HP CP1215/Brother DCP-7065DN
Linux User# 4523410

User avatar
chippy52
Forum Regular
Forum Regular
Posts: 372
Joined: Wed Jul 29, 2009 6:05 pm

Re: 3.1 Liquorix kernel debs.

#7 Postby chippy52 » Sat Nov 19, 2011 8:07 pm

smilliken wrote:Installed 32bit on the partition that I had set up for the testing of your 4.6.5 upgrade and all installed just fine. The re-boot was the same and all seems to work to date.

I did try to install 32 bit on another partition with I have M11 with the Danum 4.6.5 upgrade on it and received the following error:

Code: Select all

dpkg -i *.deb
(Reading database ... 122012 files and directories currently installed.)
Preparing to replace initramfs-tools 0.99 (using initramfs-tools_0.99-1mcr110+1_all.deb) ...
Unpacking replacement initramfs-tools ...
Selecting previously unselected package linux-headers-3.1.0-1.dmz.2-liquorix-686.
Unpacking linux-headers-3.1.0-1.dmz.2-liquorix-686 (from linux-headers-3.1.0-1.dmz.2-liquorix-686_3.1.0-2mcr110+1_i386.deb) ...
Selecting previously unselected package linux-image-3.1.0-1.dmz.2-liquorix-686.
Unpacking linux-image-3.1.0-1.dmz.2-liquorix-686 (from linux-image-3.1.0-1.dmz.2-liquorix-686_3.1.0-2mcr110+1_i386.deb) ...
Preparing to replace module-init-tools 3.16-1 (using module-init-tools_3.16-1mcr110+1_i386.deb) ...
Unpacking replacement module-init-tools ...
Setting up linux-headers-3.1.0-1.dmz.2-liquorix-686 (3.1.0-2mcr110+1) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.1.0-1.dmz.2-liquorix-686
Setting up module-init-tools (3.16-1mcr110+1) ...
Processing triggers for man-db ...
Setting up initramfs-tools (0.99-1mcr110+1) ...
update-initramfs: deferring update (trigger activated)
Setting up linux-image-3.1.0-1.dmz.2-liquorix-686 (3.1.0-2mcr110+1) ...
Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 3.1.0-1.dmz.2-liquorix-686 /boot/vmlinuz-3.1.0-1.dmz.2-liquorix-686
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.1.0-1.dmz.2-liquorix-686 /boot/vmlinuz-3.1.0-1.dmz.2-liquorix-686
update-initramfs: Generating /boot/initrd.img-3.1.0-1.dmz.2-liquorix-686
E: /usr/share/initramfs-tools/hooks/plymouth failed with return 1.
update-initramfs: failed for /boot/initrd.img-3.1.0-1.dmz.2-liquorix-686 with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.1.0-1.dmz.2-liquorix-686.postinst line 774.
dpkg: error processing linux-image-3.1.0-1.dmz.2-liquorix-686 (--install):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for initramfs-tools ...
update-initramfs: /boot/initrd.img-2.6.36-1-mepis-smp has been altered.
update-initramfs: Cannot update. Override with -t option.
Errors were encountered while processing:
 linux-image-3.1.0-1.dmz.2-liquorix-686


Had the same result installing 64bit on clean install. But had success with fresh install on vbox. Will try again on spare hdd.
Mepis 11 64bit Linux 3.2.0-0.bpo.4-amd64, KDE 4.5.1
Intel i5 2400, Asus P8H67-M-EVO, G-Skill Ripjaws 2x4GB DDR3-1333, nVidia GeForce GT430, Seagate 500GB sata3 HDD

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11025
Age: 57
Joined: Fri Dec 15, 2006 8:07 pm

Re: 3.1 Liquorix kernel debs.

#8 Postby Stevo » Sat Nov 19, 2011 8:20 pm

'/sys/bus/platform/devices/coretemp.0/temp1_input':


The newer kernel may have renamed this, so conky can't find it. Does it run if you remove the line calling it in conkyrc? Or maybe rerunning 'sensors-detect' will pick up new sources.
The optimist proclaims that we live in the best of all possible worlds, and the pessimist fears this is true.

James Branch Cabell

User avatar
smilliken
Forum Guide
Forum Guide
Posts: 1980
Age: 57
Joined: Tue Feb 06, 2007 11:47 pm

Re: 3.1 Liquorix kernel debs.

#9 Postby smilliken » Sat Nov 19, 2011 8:35 pm

Stevo wrote:
'/sys/bus/platform/devices/coretemp.0/temp1_input':


The newer kernel may have renamed this, so conky can't find it. Does it run if you remove the line calling it in conkyrc? Or maybe rerunning 'sensors-detect' will pick up new sources.


Re-ran 'sensors-detect' and removed the section calling for the temp. Neither did anything. Still receiving the same error.

Edit: Stevo, I found this https://lists.linux-foundation.org/pipe ... 27743.html
There is no "Ctrl+Z" in life!
Acer 7551G MX-15
Dell 1525, MX15 XFCE4 & Win 10
HP DV4-1118 Mepis 12 4.14 & Win 10
HP CP1215/Brother DCP-7065DN
Linux User# 4523410

User avatar
smilliken
Forum Guide
Forum Guide
Posts: 1980
Age: 57
Joined: Tue Feb 06, 2007 11:47 pm

Re: 3.1 Liquorix kernel debs.

#10 Postby smilliken » Sun Nov 20, 2011 1:53 am

Found a change for the temp, in red, instead of the ${platform coretemp.0 temp 1}

{color red}CPU1:
${color green}${cpubar cpu0 3,300} ${color #cc0033}$color
${color}CPU Temp: ${color #FF0000}${acpitemp}${color}Celsius
${color red}CPU2:
${color green}${cpubar cpu1 3,300} ${color #cc0033}$color
${color}CPU Temp: ${color #FF0000}${acpitemp}${color}Celsius
${color red}CPU3:
${color green}${cpubar cpu2 3,300} ${color #cc0033}$color
${color}CPU Temp: ${color #FF0000}${acpitemp}${color}Celsius
${color red}CPU4:
${color green}${cpubar cpu3 3,300} ${color #cc0033}$color
${color}CPU Temp: ${color #FF0000}${acpitemp}${color}Celsius

Conky loads and displays properly, but the temp is 0 degrees instead of the proper temp. Running sensors, I get

Code: Select all

coretemp-isa-0000
Adapter: ISA adapter
Core 0:      +27.0°C  (high = +74.0°C, crit = +100.0°C) 
Core 1:      +34.0°C  (high = +74.0°C, crit = +100.0°C) 
Core 2:      +35.0°C  (high = +74.0°C, crit = +100.0°C) 
Core 3:      +35.0°C  (high = +74.0°C, crit = +100.0°C)
There is no "Ctrl+Z" in life!
Acer 7551G MX-15
Dell 1525, MX15 XFCE4 & Win 10
HP DV4-1118 Mepis 12 4.14 & Win 10
HP CP1215/Brother DCP-7065DN
Linux User# 4523410


Return to “Package Sharing”

Who is online

Users browsing this forum: No registered users and 1 guest