Conky setup thread

Message
Author
User avatar
voorhees1979
Forum Regular
Forum Regular
Posts: 468
Age: 37
Joined: Wed Jul 01, 2009 6:46 pm

#91 Postby voorhees1979 » Tue May 04, 2010 3:56 am

Well this is how I get all my conkys to start at boot.

Code: Select all

#!/bin/bash
sleep 50 &&
conky -d -c /home/voorhees/conky/cpu &
sleep 50 &&
conky -d -c /home/voorhees/conky/time &
sleep 50 &&
conky -d -c /home/voorhees/conky/intel1 &
sleep 50 &&
conky -d -c /home/voorhees/conky/intel2 &
sleep 50 &&
conky -d -c /home/voorhees/conky/antix &
sleep 50 &&
conky -d -c /home/voorhees/conky/pid &
sleep 50 &&
conky -d -c /home/voorhees/conky/weather &
sleep 50 &&
conky -d -c /home/voorhees/conky/hdd &
sleep 50 &&
conky -d -c /home/voorhees/conky/music &
sleep 50 &&
conky -d -c /home/voorhees/conky/internet &
sleep 50 &&
conky -d -c /home/voorhees/conky/footballscores &
sleep 50 &&
conky -d -c /home/voorhees/conky/cal &
sleep 50 &&
conky -d -c /home/voorhees/conky/ram &
sleep 50 &&
conky -d -c /home/voorhees/conky/updates &


I have to set a sleep command otherwise it loads and clashs with other stuff loading. This way you get a little delay before they start upon boot, but they all start correct at the same time. You don't have to name the files rc or anything.
Image

User avatar
nats007
Forum Regular
Forum Regular
Posts: 294
Joined: Thu Jul 26, 2007 8:13 pm

#92 Postby nats007 » Tue May 04, 2010 1:29 pm

@ smiliken... yeah, I was trying to use the weather icons without a .template file, but I guess that is the route to go. I prefer just the .conkyrc. Here is my current conky setup to my liking.

V/R,
Nats
You do not have the required permissions to view the files attached to this post.
Nats007 ~ Linux User #458930
Desktop ~ sda1: SimplyMEPIS 11 64 BIT rel | AMD Athlon X2 4200+ 2.2GHz | 3GB DDR2-667 | WD 500 GB SATA | Biostar MCP6PB
Netbook ~ sda1: Windows XP SP3/sda2: antiX M8.5 KDE 4.6.3 | Asus Eee PC 1005HA | 2 GB DDR2 6400 | AGPtek 7200 mAh

User avatar
smilliken
Forum Guide
Forum Guide
Posts: 2020
Age: 57
Joined: Tue Feb 06, 2007 11:47 pm

#93 Postby smilliken » Tue May 04, 2010 9:10 pm

This is my start up script that I found on the net. I tried to place it in /.kde/Autostart but nothing happens. Only on .conkyrc file seems to start on boot.

#!/bin/sh
#start Conky with a 20 second delay
sleep 20
conky -c ~/Scott/.conkyrc &
conky -c ~/Scott/.conkyrc1
sleep 1
exit
Last edited by smilliken on Sat Jan 08, 2011 5:53 pm, edited 1 time in total.
There is no "Ctrl+Z" in life!
Acer 7551G MX-15
Dell 1525, MX15 XFCE4 & Win 10
HP DV4-1118 Mepis 12 4.14 & Win 10
HP CP1215/Brother DCP-7065DN
Linux User# 4523410

User avatar
richb
Administrator
Posts: 13091
Joined: Wed Jul 12, 2006 2:17 pm

#94 Postby richb » Tue May 04, 2010 9:18 pm

smilliken wrote:This is my start up script that I found on the net. I tried to place it in /,kde/Autostart but nothing happens. Only on .conkyrc file seems to start on boot.


Did you make it executable? Right click on file, choose properties and tick executable.
Forum Rules
Guide - How to Ask for Help

Rich

Laptop: Acer V5-572G: Intel i5, 12 GIG mem, Intel graphics, SanDisk SSD, 256GB
Virtualbox: Win 7
Desktop: MX-15- 64, AMD A8 7600 FM2+ CPU R7 Graphics, fglrx driver, 16 GIG Mem. Samsung EVO SSD 250 GB

User avatar
smilliken
Forum Guide
Forum Guide
Posts: 2020
Age: 57
Joined: Tue Feb 06, 2007 11:47 pm

#95 Postby smilliken » Tue May 04, 2010 9:20 pm

richb wrote:Did you make it executable? Right click on file, choose properties and tick executable.


Yup, I did all that.
There is no "Ctrl+Z" in life!
Acer 7551G MX-15
Dell 1525, MX15 XFCE4 & Win 10
HP DV4-1118 Mepis 12 4.14 & Win 10
HP CP1215/Brother DCP-7065DN
Linux User# 4523410

User avatar
voorhees1979
Forum Regular
Forum Regular
Posts: 468
Age: 37
Joined: Wed Jul 01, 2009 6:46 pm

#96 Postby voorhees1979 » Wed May 05, 2010 3:42 am

The only thing I see different from mine is you only have -c I have -d -c maybe thats it?

Code: Select all

conky -d -c


Other then that I have no idea. It's what works for me on kde4 and antiX with Gnome
Image

User avatar
cipolla
Forum Regular
Forum Regular
Posts: 197
Joined: Wed Jun 10, 2009 9:23 pm

#97 Postby cipolla » Wed May 05, 2010 6:56 am

smilliken wrote:This is my start up script that I found on the net. I tried to place it in /,kde/Autostart but nothing happens. Only on .conkyrc file seems to start on boot.


Its missing the & sign in the second conky line.

User avatar
voorhees1979
Forum Regular
Forum Regular
Posts: 468
Age: 37
Joined: Wed Jul 01, 2009 6:46 pm

#98 Postby voorhees1979 » Wed May 05, 2010 7:19 am

Ah well spotted
Image

User avatar
smilliken
Forum Guide
Forum Guide
Posts: 2020
Age: 57
Joined: Tue Feb 06, 2007 11:47 pm

#99 Postby smilliken » Wed May 05, 2010 9:29 am

I've started to have problems with "X". Everytime I start synaptic and then click on the search button, the desktop goes black. Now I'm not sure it has to do with conky or something else. I moved all of my .conkyrc files out of my home directory, but now some other conky desktop starts up, not any of mine. It could a problem with the combination of conky and the desktop effects, not sure. Will play and see what happens.
There is no "Ctrl+Z" in life!
Acer 7551G MX-15
Dell 1525, MX15 XFCE4 & Win 10
HP DV4-1118 Mepis 12 4.14 & Win 10
HP CP1215/Brother DCP-7065DN
Linux User# 4523410

User avatar
smilliken
Forum Guide
Forum Guide
Posts: 2020
Age: 57
Joined: Tue Feb 06, 2007 11:47 pm

#100 Postby smilliken » Wed May 05, 2010 9:31 am

cipolla wrote:Its missing the & sign in the second conky line.


OK, the way I read the instructions for the script was to leave the last & out of the script. I will place it in there and see what happens.

Thanks
There is no "Ctrl+Z" in life!
Acer 7551G MX-15
Dell 1525, MX15 XFCE4 & Win 10
HP DV4-1118 Mepis 12 4.14 & Win 10
HP CP1215/Brother DCP-7065DN
Linux User# 4523410


Return to “antiX”

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest