MEPIS Community Forum

A Linux operating system based on Debian Stable
View unanswered posts | View unsolved topics | View active topics |



Reply to topic  [ 9 posts ] 
Booting with keyb=non-us, without setting lang 
Author Message
User avatar

Joined: Sun Apr 18, 2010 4:55 am
Posts: 3
Has thanked: 0 time
Have thanks: 0 time
Post # 227163
Post Booting with keyb=non-us, without setting lang
Hello:smiley:!

I'm trying to get antiX-M8.5-486, run live, to start with the keyboard layout set to se|sv|se-latin1. I've tried all possible bootparams, like kmap|keyb|keymap|kbd|keyboard etc, that are used in some other distros, no cigar.

The only way I've found is to set lang=sv_SE, that sets the correct keyboard layout but, unfortunately, that also makes my computer start speaking Swedish to me, which I don't appreciate:confused:.

Grateful for any help on this:smiley:.

Cheers :smiley:/
MHHP


Sun Apr 18, 2010 5:13 am
Profile
Forum Guide
Forum Guide
User avatar

Joined: Sat Jul 15, 2006 10:40 am
Posts: 2895
Location: Greece
Has thanked: 381 times
Have thanks: 805 times
Post # 227172
Post 
Welcome to antiX.

Boot as normal, then at desktop open a terminal and type:

setxkbmap se

This will last until the session finishes.

_________________
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX "Luddite" - lean and mean.
http://antix.mepis.org


Sun Apr 18, 2010 7:07 am
Profile
User avatar

Joined: Sun Apr 18, 2010 4:55 am
Posts: 3
Has thanked: 0 time
Have thanks: 0 time
Post # 227372
Post 
Ok, thanks!

Guess I can put that in (rc.local or) .xinitrc to have the kbd-layout set on every GUI start.

Cheers:smiley:/
MHHP


Mon Apr 19, 2010 4:43 pm
Profile
Forum Regular
Forum Regular

Joined: Wed Jul 01, 2009 6:46 pm
Posts: 468
Location: Suffolk, UK
Has thanked: 0 time
Have thanks: 3 times
Post # 227457
Post 
or you could just add this to a file:

Code:
#!/bin/bash
setxkbmap se


Make it executable and make it boot with your other startup apps. Its what I did anyway

_________________
Image


Tue Apr 20, 2010 8:51 am
Profile
Forum Novice
Forum  Novice

Joined: Thu Apr 05, 2012 11:58 am
Posts: 4
Location: Dalarna, Sweden
Has thanked: 0 time
Have thanks: 0 time
Post # 298273
Post Re: Booting with keyb=non-us, without setting lang
As this is now very old I expect that you have found a solution. I was having the same trouble setting up a Swedish keyboard but I think that I have finally cracked it. You can set the keyboard layout so simply in system settings>hardware>input devices when you know it's there. I could find no sysconfig file at all in MEPIS 11 and got no joy following the manual which I have otherwise found excellent. I shall now try to work out how to update the manual!


Thu Apr 05, 2012 12:57 pm
Profile
Forum Guide
Forum Guide
User avatar

Joined: Sun Apr 29, 2007 11:53 am
Posts: 2782
Location: Stockholm, Sweden
Has thanked: 862 times
Have thanks: 676 times
Post # 298275
Post Re: Booting with keyb=non-us, without setting lang
If you're using M11 it's different from antix (not using kde), which this topic is about.
It's very easy to use a Swedish keyboard if it's supported by kde. Uncommon keyboards can be pretty difficult to configure.
Henry


Thu Apr 05, 2012 1:30 pm
Profile
Forum Novice
Forum  Novice

Joined: Thu Apr 05, 2012 11:58 am
Posts: 4
Location: Dalarna, Sweden
Has thanked: 0 time
Have thanks: 0 time
Post # 298277
Post Re: Booting with keyb=non-us, without setting lang
Thanks Henry. It is all quite easy when you know where to look. Unfortunately sections 5.9 and 10.3 of the manual that ships with M11 are simply wrong when it comes to the keyboard. Had it not been for those misdirections I probably would have looked at "hardware" sooner!

Never having heard of "antix" I have no idea of its relevance. It is obviously part of the linux labyrinth that is so discouraging to us refugees!


Thu Apr 05, 2012 2:04 pm
Profile
Forum Guide
Forum Guide
User avatar

Joined: Sun Apr 29, 2007 11:53 am
Posts: 2782
Location: Stockholm, Sweden
Has thanked: 862 times
Have thanks: 676 times
Post # 298280
Post Re: Booting with keyb=non-us, without setting lang
Swedish works pretty well in Mepis. Especially if it's enough for you to only configure kde. The drawback is that you have to avoid the last three letters in the Swedish alphabet in file names, when saving images in Gimp and some other apps.
It's possible to get the Swedish language throughout the whole system with dpkg-reconfigure locales if needed.
Antix is a Mepis spin-off for older computers, using a different desktop environment and configuration tools.
Henry


Thu Apr 05, 2012 3:21 pm
Profile
Forum Novice
Forum  Novice

Joined: Thu Apr 05, 2012 11:58 am
Posts: 4
Location: Dalarna, Sweden
Has thanked: 0 time
Have thanks: 0 time
Post # 298485
Post Re: Booting with keyb=non-us, without setting lang
Thanks for the file name tip, Henry. The Swedish letters work fine in Windows!


Tue Apr 10, 2012 3:09 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.