MEPIS Community Forum

A Linux operating system based on Debian Stable
View unanswered posts | View unsolved topics | View active topics |



Reply to topic  [ 3 posts ] 
Keyboard layout 
Author Message
Forum Regular
Forum Regular

Joined: Mon Sep 15, 2008 10:04 am
Posts: 261
Location: England
Has thanked: 105 times
Have thanks: 22 times
Post # 287522
Post Keyboard layout
Scenario:
AntiX X1 as a virtualbox guest on a Mepis 11 host.
KDE 4.6 installed and active in AntiX (installed by means of the AntiX command provided).
AntiX fully updated from the debian testing repository.

Problem:
I cannot get the keyboard in AntiX to adopt the uk layout.

I have set the locale and the language (having installed the kde gb addition). But I still get keys like "@#\
in the wrong place.

What am I doing wrong?

Otherwise AntiX is working well, and enabling me to explore kde 4.6.

Best wishes,
Peter Stone


Thu Nov 03, 2011 7:40 pm
Profile
Forum Regular
Forum Regular
User avatar

Joined: Sat Aug 22, 2009 11:36 pm
Posts: 892
Has thanked: 325 times
Have thanks: 482 times
Post # 287537
Post Re: Keyboard layout
There are three approaches. The first is to use the "lang=uk" boot options when you first boot the antiX LiveCD. Three other boot options are also available for fine tuning:
Code:
kbd= kbvar= kbopt=


If you don't want to go that route then you can trying editing /etc/default/keyboard and change KBLAYOUT. You will at least have to restart X and you may need to reboot for this to take effect.

Finally, you could edit your /etc/X11/xorg.conf directly and add a section like this:
Code:
Section "InputClass"
   Identifier "keyboard-all"
   Driver "evdev"
   Option "XkbLayout" "uk"
   #Option "XkbModel" "pc105"
   MatchIsKeyboard "on"
EndSection

You then have to restart X which you can do by logging out and then logging in again through the Slim login manager. I have not tested this. It may need some (hopefully) slight modification.


Thu Nov 03, 2011 9:47 pm

BitJam thanked by: pastone
Profile
Forum Regular
Forum Regular

Joined: Mon Sep 15, 2008 10:04 am
Posts: 261
Location: England
Has thanked: 105 times
Have thanks: 22 times
Post # 287616
Post Re: Keyboard layout
Thanks, BitJam.

Success was achieved by changing a line in /etc/default/keyboard to:

XKBLAYOUT="gb"

Best wishes,
Peter Stone


Fri Nov 04, 2011 8:28 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.