Unmet dependencies - broken pkgs

Message
Author
User avatar
slopoke
Forum Regular
Forum Regular
Posts: 119
Joined: Sun Jun 13, 2010 3:43 pm

Unmet dependencies - broken pkgs

#1 Postby slopoke » Sat Dec 31, 2011 1:41 pm

When I run "module-assistant" I get the following error:

Getting source for kernel version: 2.6.36-1-mepis-smp
Kernel headers available in /lib/modules/2.6.36-1-mepis-smp/build
apt-get install build-essential
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
build-essential : Depends: libc6-dev but it is not going to be installed or
libc-dev
Depends: g++ (>= 4:4.4.3) but it is not going to be installed
E: Broken packages

Done!


Following these Depends results in a vicious circle. Any advice on how to diagnose this?

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 4298
Age: 51
Joined: Sat Jul 15, 2006 10:40 am

Re: Unmet dependencies - broken pkgs

#2 Postby anticapitalista » Sat Dec 31, 2011 3:05 pm

Post your apt/sources.list

inxi -r

You may just need to add the MEPIS repo temporarily to get the needed files.
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-15 "Killah P!" - lean and mean.
http://antix.mepis.org

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 3377
Joined: Wed Jul 12, 2006 4:05 pm

Re: Unmet dependencies - broken pkgs

#3 Postby timkb4cq » Sat Dec 31, 2011 3:06 pm

When you Reload in Synaptic (or do an apt-get update) is the MEPIS repo loading?
That would be either
ftp://ftp.mepis.com
or
ftp://ftp.mirrorservice.org/sites/ftp.mepis.org/mepis/


If it is, you should be able to install g++ and libc6-dev
If it's not you might need to change your sources to list the other one
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 8987
Age: 58
Joined: Wed Jul 12, 2006 2:26 pm

Re: Unmet dependencies - broken pkgs

#4 Postby kmathern » Sat Dec 31, 2011 3:34 pm

The g++ package is built from the gcc-defaults source package which I don't see in the Mepis repos. You might need to add the Debian squeeze repo.

User avatar
slopoke
Forum Regular
Forum Regular
Posts: 119
Joined: Sun Jun 13, 2010 3:43 pm

Re: Unmet dependencies - broken pkgs

#5 Postby slopoke » Sat Dec 31, 2011 6:01 pm

Here is what anti wanted:

inxi -r
Repos: Active apt sources in file: /etc/apt/sources.list
deb ftp://ftp.mepis.com/mepis/ mepis-11.0 main
deb ftp://ftp.debian.org/debian/ squeeze main contrib non-free
deb http://security.debian.org/ squeeze/updates main contrib non-free
deb http://ftp.debian.org/debian/ squeeze-updates main
deb http://www.debian-multimedia.org/ squeeze main non-free
deb http://main.mepis-deb.org/mepiscr/repo/ mepis11cr main non-free
deb http://restricted.mepis-deb.org/mepiscr/repo/ mepis11cr restricted restricted-non-free


The mirrorservice repo doesn't work, it falls over dead.

If I enable the source repo, will apt/synaptic install a pkg I request (never tried it)?

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 8987
Age: 58
Joined: Wed Jul 12, 2006 2:26 pm

Re: Unmet dependencies - broken pkgs

#6 Postby kmathern » Sat Dec 31, 2011 6:27 pm

slopoke wrote:If I enable the source repo, will apt/synaptic install a pkg I request (never tried it)?

You don't need to enable the deb-src repo. It's just for downloading the source tarballs (.gz) and .dsc files if you are going to build packages from the Debianized source. You wouldn't be able to install anything from it using Synaptic or apt-get anyway.

The reason I mentioned the gcc-defaults source package is because that's the folder you would find the g++ package in if it was in Warren's repo. Look here in the browser, ftp://ftp.mepis.com/mepis/pool/main/g/, there's no gcc-defaults folder. And as a comparison look here: http://ftp.debian.org/debian/pool/main/g/

What does the output of the apt-cache policy libc6 command show? {I'm wondering if you might have the wheezy libc6 installed, because I thought AntiX was based on testing}

User avatar
slopoke
Forum Regular
Forum Regular
Posts: 119
Joined: Sun Jun 13, 2010 3:43 pm

Re: Unmet dependencies - broken pkgs

#7 Postby slopoke » Sat Dec 31, 2011 6:42 pm

Yes, it is normally. But I did a core install (same as Debian net-install) and selected Squeeze. Here is the output:

apt-cache policy libc6
libc6:
Installed: 2.13-21
Candidate: 2.13-21
Version table:
*** 2.13-21 0
100 /var/lib/dpkg/status
2.11.2-10 0
500 ftp://ftp.debian.org/debian/ squeeze/main i386 Packages

Somehow I think version differences are causing the problem, but I can't figure out how to fix it.

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 8987
Age: 58
Joined: Wed Jul 12, 2006 2:26 pm

Re: Unmet dependencies - broken pkgs

#8 Postby kmathern » Sat Dec 31, 2011 7:06 pm

slopoke wrote:Yes, it is normally. But I did a core install (same as Debian net-install) and selected Squeeze. Here is the output:

apt-cache policy libc6
libc6:
Installed: 2.13-21
Candidate: 2.13-21
Version table:
*** 2.13-21 0
100 /var/lib/dpkg/status
2.11.2-10 0
500 ftp://ftp.debian.org/debian/ squeeze/main i386 Packages

Somehow I think version differences are causing the problem, but I can't figure out how to fix it.

The libc6 you have installed was at one time the wheezy version. The libc6-dev package needs to be the same exact version as libc6, and that version isn't available in the squeeze repos. It's not available anymore in the wheezy repo either (in wheezy libc6 and libc6-dev are now at version 2.13-23 http://packages.debian.org/wheezy/libc6 ) .

You might add/enable the wheezy repo, reload and then do a apt-get install libc6 libc6-dev and then disable the wheezy repo and reload again. Don't do a general upgrade or dist-upgrade while wheezy is enabled. Then try module-assistant again.

User avatar
slopoke
Forum Regular
Forum Regular
Posts: 119
Joined: Sun Jun 13, 2010 3:43 pm

Re: Unmet dependencies - broken pkgs

#9 Postby slopoke » Sun Jan 01, 2012 3:41 pm

Followed your instructions. Both libc6-dev and libc6 pkgs now have the same version numbers (2.13-23). Along with libc6-i686 and libc-bin.

However.

When tried to install the build-essential pkg, I got this:

g++:
Depends: g++-4.4 but it is not going to be installed
(Current Squeeze version is: 4.4.5-8)


g++-4.4:
Depends: gcc-4.4-base (=4.4.5-8) but 4.4.6-11 is to be installed
Depends: gcc-4.4 (=4.4.5-8) but 4.4.6-11 is to be installed
Depends: libstdc++6-4.4-dev but it is not going to be installed
(Current Squeeze version is: 4.4.5-8)



Will going back to Wheezy get these versions in sync with each other?

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 4298
Age: 51
Joined: Sat Jul 15, 2006 10:40 am

Re: Unmet dependencies - broken pkgs

#10 Postby anticapitalista » Sun Jan 01, 2012 3:50 pm

Yes - probably.

BTW are you using antiX-M11-core released on 03 May 2011?
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-15 "Killah P!" - lean and mean.
http://antix.mepis.org


Return to “antiX”

Who is online

Users browsing this forum: No registered users and 3 guests