MEPIS Community Forum

A Linux operating system based on Debian Stable
View unanswered posts | View unsolved topics | View active topics |



Reply to topic  [ 25 posts ]  Go to page 1, 2, 3  Next
KDE 4.7.4 in M11 CR? Looking good! 
Author Message
Forum Veteran
Forum Veteran
User avatar

Joined: Fri Dec 15, 2006 8:07 pm
Posts: 8694
Location: Skullcrusher Mountain, Santee, CA USA
Has thanked: 582 times
Have thanks: 1953 times
Post # 294030
Post KDE 4.7.4 in M11 CR? Looking good!
I've already got the plasma-desktop up and running with backported packages from Debian Experimental on a 32-bit VM, and am now down to the smaller packages (they split out all the educational games into separate builds--argggh). It appears they have switched to the Ubuntu conventions for naming some of the workspace packages.

I notice that Debian has stuck with the same KDE PIM packages since 4.4, while the latest Ubuntus build and provide the 4.7.4 packages, such as the latest Kontact and Kmail. I have heard that Debian can't get a working Kmail since 4.4, hence the freeze. Is anyone using Kubuntu with Kontact, and is it broken?


Fri Jan 20, 2012 8:58 pm Profile
Online
Administrator
User avatar

Joined: Wed Jul 12, 2006 2:17 pm
Posts: 10681
Location: Rochester NY
Has thanked: 832 times
Have thanks: 1429 times
Post # 294031
Post Re: KDE 4.7.4 in M11 CR? Looking good!
There has been a number of posts regarding Kmail2 failures on the Kubuntu forum. I use neither Kmail2 nor kontact that much. But Kontact seems to load and work OK. Kmail synched with my Gmail account without issue.

_________________
Forum Rules
Guide - How to Ask for Help
Link to Wiki
Rich

Acer Laptop V5-572G: Intel i5, 12 GIG mem, nVidia GT720M/Intel integrated graphics
Mx-14 Symbiosis
Kubuntu 13.10, KDE 4.11.2


Fri Jan 20, 2012 10:12 pm
Profile
Forum Guide
Forum Guide
User avatar

Joined: Tue Feb 06, 2007 11:47 pm
Posts: 1810
Location: Cranbrook, BC
Has thanked: 231 times
Have thanks: 97 times
Post # 294032
Post Re: KDE 4.7.4 in M11 CR? Looking good!
Stevo wrote:
I've already got the plasma-desktop up and running with backported packages from Debian Experimental on a 32-bit VM, and am now down to the smaller packages (they split out all the educational games into separate builds--argggh). It appears they have switched to the Ubuntu conventions for naming some of the workspace packages.

I notice that Debian has stuck with the same KDE PIM packages since 4.4, while the latest Ubuntus build and provide the 4.7.4 packages, such as the latest Kontact and Kmail. I have heard that Debian can't get a working Kmail since 4.4, hence the freeze. Is anyone using Kubuntu with Kontact, and is it broken?


This nice to here!

I thought I read somewhere that the kmail would be held back til 4.8.

_________________
There is no "Ctrl+Z" in life!
Asus P8Z68-V Pro, Intel i5 2500 Quad, Intel, DWA-552, 2-640 GB, Mepis 11 4.8.4/Win 8.1
HP DV4-1118 Mepis 12 4.8.4 & Win 8.1/Dell 1525 MX14/Win 8.1
HP CP1215/Brother DCP-7065DN
Linux User# 4523410


Fri Jan 20, 2012 10:47 pm
Profile
Online
Administrator
User avatar

Joined: Wed Jul 12, 2006 2:17 pm
Posts: 10681
Location: Rochester NY
Has thanked: 832 times
Have thanks: 1429 times
Post # 294033
Post Re: KDE 4.7.4 in M11 CR? Looking good!
Correction. My kmail tests were in a VM with Kubuntu 11.10, KDE 4.7.1 and Kmail 1.13.7. No problems. I have not tried it on my KDE 4.8 RC2 install. But since you are talking about the 4.7 series, the tests in the VM are more relevant.

_________________
Forum Rules
Guide - How to Ask for Help
Link to Wiki
Rich

Acer Laptop V5-572G: Intel i5, 12 GIG mem, nVidia GT720M/Intel integrated graphics
Mx-14 Symbiosis
Kubuntu 13.10, KDE 4.11.2


Fri Jan 20, 2012 10:55 pm
Profile
Forum Veteran
Forum Veteran
User avatar

Joined: Fri Dec 15, 2006 8:07 pm
Posts: 8694
Location: Skullcrusher Mountain, Santee, CA USA
Has thanked: 582 times
Have thanks: 1953 times
Post # 294034
Post Re: KDE 4.7.4 in M11 CR? Looking good!
OK, I can try the newer ones after I get all these little leftover packages completed. I'm trying the latest digikam 2.5.0 from Experimental, too, but have to bring over a newer cmake from squeeze-backports first.


Fri Jan 20, 2012 11:26 pm
Profile
Forum Veteran
Forum Veteran
User avatar

Joined: Wed Jul 19, 2006 6:13 am
Posts: 10211
Location: Geneva NY
Has thanked: 2958 times
Have thanks: 1895 times
Post # 294041
Post Re: KDE 4.7.4 in M11 CR? Looking good!
Man, I don't know how you do this stuff...

This would be great, thanks for looking into the possibility!

_________________
Production: 32 bit, 3.14-0.bpo.1-686-pae. MX-14.2, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB DDR3, / and /home on Kingston SSD 120 GB, data on WesternDigital 1TB, Dell SP2309W monitor.


Sat Jan 21, 2012 10:13 am
Profile
Forum Veteran
Forum Veteran
User avatar

Joined: Fri Dec 15, 2006 8:07 pm
Posts: 8694
Location: Skullcrusher Mountain, Santee, CA USA
Has thanked: 582 times
Have thanks: 1953 times
Post # 294054
Post Re: KDE 4.7.4 in M11 CR? Looking good!
I built and ran Digikam 2.5.0, along with Showphoto and Kipi-plugins (all one build now). It conflicts with the older libkface1 and other packages I built for PPA version 2.0, since this build keeps them all internal. I'll add a Conflicts and Replaces for those, but they may still need to be removed manually.--What I have left to do are the accessories like kolourpaint, kalzium, kite, etc., which used to be one big build but are now split into separate packages. I did run into a few sticking points during the build of the base packages, but found solutions to them (such as bringing in a newer libmsn from Ubuntu, or not build-depending on the newer EGL for mobile devices found in the squeeze-backports xorg)

One good thing is that the upgrade did not change the desktop theme, at least on my standard desktop in the VM. Let's see what happens if you have a custom theme. And I get a new widget in the taskbar for Activities...


Sat Jan 21, 2012 2:26 pm

Stevo thanked by: lucky9
Profile
Forum Guide
Forum Guide
User avatar

Joined: Wed Jul 12, 2006 4:30 pm
Posts: 1458
Location: Flinthills of Kansas, USA
Has thanked: 254 times
Have thanks: 139 times
Post # 294096
Post Re: KDE 4.7.4 in M11 CR? Looking good!
Stevo wrote:
I built and ran Digikam 2.5.0, along with Showphoto and Kipi-plugins (all one build now). It conflicts with the older libkface1 and other packages I built for PPA version 2.0, since this build keeps them all internal. I'll add a Conflicts and Replaces for those, but they may still need to be removed manually.--What I have left to do are the accessories like kolourpaint, kalzium, kite, etc., which used to be one big build but are now split into separate packages. I did run into a few sticking points during the build of the base packages, but found solutions to them (such as bringing in a newer libmsn from Ubuntu, or not build-depending on the newer EGL for mobile devices found in the squeeze-backports xorg)

One good thing is that the upgrade did not change the desktop theme, at least on my standard desktop in the VM. Let's see what happens if you have a custom theme. And I get a new widget in the taskbar for Activities...


I would imagine custom themes won't be bothered at all; I have the steampunk themes installed and Danums build did not effect them at all so I bet your build won't effect them either. I plan to give it a spin when you get it completed... Great work Stevo! :cool:

_________________
http://patentabsurdity.com/
AMD 64x2 2.6GHz 4GB ram M-11.9.92 kernel 3.10-3-amd64 kde 4.11.5 mixed/unstable
"beware a frequent flirt with potential disaster"


Sat Jan 21, 2012 10:06 pm
Profile
Forum Veteran
Forum Veteran
User avatar

Joined: Fri Dec 15, 2006 8:07 pm
Posts: 8694
Location: Skullcrusher Mountain, Santee, CA USA
Has thanked: 582 times
Have thanks: 1953 times
Post # 294106
Post Re: KDE 4.7.4 in M11 CR? Looking good!
I actually meant the 4.6.5 upgrade changed the desktop (taskbar and such) theme to air-netbook or something with the white smudged behind the letters.

I just installed the update to the KDE splash screen Steampunk (Steam powered linux) in the system-settings "Get new Themes". This is the one that runs after one logs in. The new one runs slower, and parts don't stop moving after all the animations start running.

I also installed and tested another simpler animation: http://kde-look.org/content/show.php/Re ... ent=136351

It would have been great to have the tendrils sprouting from the sea floor in the Underwater M11 theme using the same technique, maybe we can look into it for 11.5.


Sat Jan 21, 2012 11:06 pm
Profile
Forum Guide
Forum Guide
User avatar

Joined: Wed Jul 12, 2006 4:30 pm
Posts: 1458
Location: Flinthills of Kansas, USA
Has thanked: 254 times
Have thanks: 139 times
Post # 294111
Post Re: KDE 4.7.4 in M11 CR? Looking good!
<QUOTE> "The new one runs slower, and parts don't stop moving after all the animations start running. "

ditto on Danums build with the steampunk splashy. I also have the login splash and nothing changes with it. :tumbleweed: Jerry

_________________
http://patentabsurdity.com/
AMD 64x2 2.6GHz 4GB ram M-11.9.92 kernel 3.10-3-amd64 kde 4.11.5 mixed/unstable
"beware a frequent flirt with potential disaster"


Sat Jan 21, 2012 11:13 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 25 posts ]  Go to page 1, 2, 3  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.