Trouble mounting NTFS usb drive

Feel free to talk about anything and everything in this board. Just don't post offensive topics that are meant to cause trouble with other members or are derogatory towards people of different genders, race, color, minors (this includes nudity and sex), politics or religion. Let's try to keep peace among the community and for visitors.

No spam on this or any other forums please! If you post advertisements on these forums, your account may be deleted.

Do not copy and paste entire or even up to half of someone else's words or articles into posts. Post only a few sentences or a paragraph and make sure to include a link back to original words or article. Otherwise it's copyright infringement.

You can talk about other distros here, but no MEPIS bashing. You can email the developer of MEPIS if you just want to say you dislike or hate MEPIS.
Message
Author
User avatar
cgriffin
Forum Regular
Forum Regular
Posts: 221
Age: 45
Joined: Sun Mar 27, 2011 9:59 pm

Trouble mounting NTFS usb drive

#1 Postby cgriffin » Tue Apr 24, 2012 10:16 pm

Hello all,

I have two usb drives that Mepis 11.0 are having trouble mounting.
One is a 500Gb seagate external drive, and the other is a new USB key. Both are formatted with NTFS.
The seagate worked on the machine just last week, I don't know why it would stop and what I can do to get these babies to mount.
Does anyone have a pointer for me on what to try?
THanks,
Chris
--
Chris Griffin

User avatar
moksha
Forum Regular
Forum Regular
Posts: 573
Joined: Sun Dec 09, 2007 4:19 am

Re: Trouble mounting NTFS usb drive

#2 Postby moksha » Tue Apr 24, 2012 10:57 pm

cgriffin wrote:Hello all,

I have two usb drives that Mepis 11.0 are having trouble mounting.ype
One is a 500Gb seagate external drive, and the other is a new USB key. Both are formatted with NTFS.
The seagate worked on the machine just last week, I don't know why it would stop and what I can do to get these babies to mount.
Does anyone have a pointer for me on what to try?
THanks,
Chris


Have you tried Kmenu > System > More Applications > kdiskfree

to see if they are there

or open konsole as superuser

then mount -t NTFS /path/to/directory

it will probably be something like mount -t NTFS /media/seagate

the -t option indicates it is an NTFS file system being mounted

User avatar
chippy52
Forum Regular
Forum Regular
Posts: 373
Joined: Wed Jul 29, 2009 6:05 pm

Re: Trouble mounting NTFS usb drive

#3 Postby chippy52 » Tue Apr 24, 2012 11:12 pm

Have you checked out >>system settings >> removable devices, see if your device is listed. If so tick the box in automount on login column.
Mepis 11 64bit Linux 3.2.0-0.bpo.4-amd64, KDE 4.5.1
Intel i5 2400, Asus P8H67-M-EVO, G-Skill Ripjaws 2x4GB DDR3-1333, nVidia GeForce GT430, Seagate 500GB sata3 HDD

User avatar
cgriffin
Forum Regular
Forum Regular
Posts: 221
Age: 45
Joined: Sun Mar 27, 2011 9:59 pm

Re: Trouble mounting NTFS usb drive

#4 Postby cgriffin » Tue Apr 24, 2012 11:13 pm

moksha wrote:
Have you tried Kmenu > System > More Applications > kdiskfree

to see if they are there

or open konsole as superuser

then mount -t NTFS /path/to/directory

it will probably be something like mount -t NTFS /media/seagate

the -t option indicates it is an NTFS file system being mounted



I was able to mount it using the command:
mount -t ntfs-3g /dev/sdb1 /media/myThumbDrive

I'm definitely wanting to be able to mount it from the KDE desktop USB notifier in the system tray, if there is a way to fix it so it just works there. In my googling I've found that it seems that folks have a lot of trouble with NTFS drives... if I didn't have windows in my life I just wouldn't care.
Chris
--
Chris Griffin

User avatar
moksha
Forum Regular
Forum Regular
Posts: 573
Joined: Sun Dec 09, 2007 4:19 am

Re: Trouble mounting NTFS usb drive

#5 Postby moksha » Tue Apr 24, 2012 11:23 pm

cgriffin wrote:
I was able to mount it using the command:
mount -t ntfs-3g /dev/sdb1 /media/myThumbDrive

I'm definitely wanting to be able to mount it from the KDE desktop USB notifier in the system tray, if there is a way to fix it so it just works there. In my googling I've found that it seems that folks have a lot of trouble with NTFS drives... if I didn't have windows in my life I just wouldn't care.
Chris

oops forgot the the "-3g" yes
try right clicking the usb icon in the kicker and selecting device notifier settings > automounting and tick the automount box. I dont know if it will work cause I am a linux purist, but I also don't have any probs mounting anything, I plug in and I haven't done any tweaking, only ocassional permission issues. which I get inordinate pleasure from overriding

User avatar
cgriffin
Forum Regular
Forum Regular
Posts: 221
Age: 45
Joined: Sun Mar 27, 2011 9:59 pm

Re: Trouble mounting NTFS usb drive

#6 Postby cgriffin » Tue Apr 24, 2012 11:28 pm

chippy52 wrote:Have you checked out >>system settings >> removable devices, see if your device is listed. If so tick the box in automount on login column.


Yes it shows up there. But the option to automatically mount didn't help it any ;-(
--
Chris Griffin

User avatar
cgriffin
Forum Regular
Forum Regular
Posts: 221
Age: 45
Joined: Sun Mar 27, 2011 9:59 pm

Re: Trouble mounting NTFS usb drive

#7 Postby cgriffin » Tue Apr 24, 2012 11:32 pm

moksha wrote:oops forgot the the "-3g" yes
try right clicking the usb icon in the kicker and selecting device notifier settings > automounting and tick the automount box. I dont know if it will work cause I am a linux purist, but I also don't have any probs mounting anything, I plug in and I haven't done any tweaking, only ocassional permission issues. which I get inordinate pleasure from overriding



THe problem is NTFS, which means the problem is Microsoft. I'm OK having to call mount, but I'll leave this topic open for a while to see if anyone knows how to massage it into working in the KDE interface
Thanks!
Chris
--
Chris Griffin

User avatar
qtech
Forum Regular
Forum Regular
Posts: 693
Joined: Wed Nov 28, 2007 12:21 pm

Re: Trouble mounting NTFS usb drive

#8 Postby qtech » Tue Apr 24, 2012 11:49 pm

Try running "chkdsk /f" in windows from a prompt on both drives.


Return to “General”

Who is online

Users browsing this forum: Majestic-12 [Bot] and 1 guest