Thesaurus

This forum is intended for the discussion around the use of MEPIS in an office setting as distinct from home or indivicual usage. Examples include mail merge, database construction, hardware sharing, advertising, etc..
Message
Author
User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 15131
Joined: Wed Jul 19, 2006 6:13 am

Thesaurus

#1 Postby Jerry3904 » Tue Jun 14, 2011 10:39 am

I am writing a book using LibreOffice ATM, and tried this morning to make the thesaurus work for the first time. No go, grayed out. Googled, found some solutions, but they did not work.

Finally searched in Synaptic, and found and installed mythes-en-us,and after restarting LO it worked: put the cursor on the word, hit Ctrl-F7 or click Tools > Language > Thesaurus, and there you are.

The mythes package has some other localizations, but not many: Catalan (but not any Spanish), Czech, French, Hungarian, Nepali, Romanian, Russian, and Slovak. There are more available in Wheezy, so the situation should get better over time.
You do not have the required permissions to view the files attached to this post.
Production: 4.2.0-0.bpo.1-amd64, MX-15 RC1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 3.16-0-4-686-pae. MX-15, AMD C-60 APU, 4 GB

chrispop99
Forum Guide
Forum Guide
Posts: 1433
Age: 70
Joined: Tue Jan 27, 2009 3:07 pm

Re: Thesaurus

#2 Postby chrispop99 » Tue Jun 14, 2011 11:18 am

mythes-en-us is already installed as standard in M11 here; the thesaurus in LO doesn't work for me however.

I wonder if that's because I remove all US dictionaries and replace with UK?

Chris
Test machines:
Gigabyte Z77P-D3, Intel i3-3220, GeForce 8400 GS, 4GB PC3-12800.
DELL Latitude D630 laptop, 2GHz Core 2 Duo, 2GB PC2-5300.
IBM Thinkpad T41 laptop, 1.6GHz Pentium M (Non-PAE), 1GB RAM, 30GB PATA SSD.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 15131
Joined: Wed Jul 19, 2006 6:13 am

Re: Thesaurus

#3 Postby Jerry3904 » Tue Jun 14, 2011 11:32 am

Interesting, thanks. Warren must have added that late, since I am using an RC1 I think that I then updated through to Final.
Production: 4.2.0-0.bpo.1-amd64, MX-15 RC1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 3.16-0-4-686-pae. MX-15, AMD C-60 APU, 4 GB

User avatar
Gaer Boy
Forum Guide
Forum Guide
Posts: 1957
Age: 80
Joined: Sat Jun 06, 2009 6:06 am

Re: Thesaurus

#4 Postby Gaer Boy » Tue Jun 14, 2011 11:35 am

I also have mythes-en-us installed, but the thesaurus doesn't work. I've tried switching to English(US) but it makes no difference.

AsRock FM2A88X-ITX+, A8-6500, 8GB, 120GB Samsung SSD (GPT), 1TB HDD (MBR), MX-15, MX-14.4
Acer Aspire One 150, Atom N270, 120GB HDD, MX-14.3

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 15131
Joined: Wed Jul 19, 2006 6:13 am

Re: Thesaurus

#5 Postby Jerry3904 » Tue Jun 14, 2011 11:40 am

Because of your localization choices...?
Production: 4.2.0-0.bpo.1-amd64, MX-15 RC1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 3.16-0-4-686-pae. MX-15, AMD C-60 APU, 4 GB

User avatar
Gaer Boy
Forum Guide
Forum Guide
Posts: 1957
Age: 80
Joined: Sat Jun 06, 2009 6:06 am

Re: Thesaurus

#6 Postby Gaer Boy » Tue Jun 14, 2011 12:03 pm

Jerry3904 wrote:Because of your localization choices...?

Quite possibly - in which case I'm not going to try to sort it. I have endless trouble with various apps setting US paper sizes, and I'm not switching a possible default setting that way.

AsRock FM2A88X-ITX+, A8-6500, 8GB, 120GB Samsung SSD (GPT), 1TB HDD (MBR), MX-15, MX-14.4
Acer Aspire One 150, Atom N270, 120GB HDD, MX-14.3

User avatar
DBeckett
Forum Veteran
Forum Veteran
Posts: 3065
Joined: Sat May 16, 2009 3:59 pm

Re: Thesaurus

#7 Postby DBeckett » Tue Jun 14, 2011 4:16 pm

.
FWIW, Thesaurus works fine here with no encouragement.

My locale is en_US.UTF-8
Gigabyte 990FXA-UD3, AMD FX-6100 hex-core, 3.3GHz, 8G, Radeon HD6570

User avatar
m_pav
Forum Guide
Forum Guide
Posts: 2519
Age: 49
Joined: Sun Aug 06, 2006 3:02 pm

Re: Thesaurus

#8 Postby m_pav » Wed Jun 15, 2011 5:11 am

My system is set to en-us, but the region is set to New Zealand with my default paper size set to A4 and units of measurement set to Metric, so I have no trouble with page sizes, and the thesaurus works just fine for me on my M8.5 upgraded to M11 production laptop.

Mike P
Mike P

Regd Linux User #472293
(Mine)Lenovo T550, i7-5600U, 16GB, 128GB SSD + 1.0TB HDD, MX15 64-bit
(Wifes) Asus M4A88TD-M, AMD Phenom II x4 955 CPU, nVidia GF610, 6Gb, 500GB+320GB, MX14 + KDE
(Kids) Intel NUC, J1900, 4GB, 64GB SSD, MX14 + KDE


Return to “Office”

Who is online

Users browsing this forum: No registered users and 1 guest