Problem installing VLC in 8.5 32 bit

Those new to MEPIS or not very experienced can post their questions here.
Message
Author
johnnyhop
Forum Novice
Forum  Novice
Posts: 22
Age: 64
Joined: Sun Jan 16, 2011 8:17 am

Problem installing VLC in 8.5 32 bit

#1 Postby johnnyhop » Wed Jan 26, 2011 8:37 am

:confused: Not able to install VLC media player in 8.5--dependency issues. Here's what Synaptic reported:
vlc:
Depends: vlc-nox but it is not going to be installed
vlc-nox:
Depends: libavcodec52 (>=5:0.5+svn20091129) but 4:0.5+svn20090706-2 is to be installed
Depends: libavformat52 (>=5:0.5+svn20091129) but 4:0.5+svn20090706-2 is to be installed
Depends: libavutil50 (>=5:0.5+svn20091129) but it is not installable

I've enabled all repositories except:
deb http://volatile.debian.org/debian-volatile/ lenny/volatile main contrib non-free
deb-src ftp://ftp.debian.org/debian/ lenny main contrib non-free

User avatar
joany
Forum Veteran
Forum Veteran
Posts: 6123
Joined: Mon Feb 12, 2007 1:45 pm

Re: Problem installing VLC in 8.5 32 bit

#2 Postby joany » Wed Jan 26, 2011 9:25 am

SM 8.5 has issues with the Lenny multimedia repository. I believe it's because Lenny supports KDE 3.5, whereas SM 8.5 is built on KDE 4.3.

At any rate, you want to disable the Lenny multimedia repository and enable the Community Repositorie. Then try installing VLC.

Your repository list in /etc/apt/sources.list should look something like this:

Code: Select all

# See sources.list(5) for more information

# This file should be edited through synaptic

# MEPIS improvements, overrides and updates--the MEPIS magic
deb ftp://ftp.mirrorservice.org/sites/ftp.mepis.org/mepis/ mepis-8.5 main
deb ftp://ftp.mirrorservice.org/sites/ftp.mepis.org/mepis/ mepis-8.0 main
# MEPIS master pools, please use only if mirror is slow or down
# deb ftp://ftp.mepis.com/mepis/ mepis-8.5 main
# deb ftp://ftp.mepis.com/mepis/ mepis-8.0 main

deb ftp://ftp.debian.org/debian/ lenny main contrib non-free
deb-src ftp://ftp.debian.org/debian/ lenny main contrib non-free
deb http://security.debian.org/ lenny/updates main contrib non-free
deb http://volatile.debian.org/debian-volatile/ lenny/volatile main contrib non-free

# Some Debian Multimedia software might be illegal in some jurisdictions
# deb http://www.debian-multimedia.org/ lenny main non-free

# Community Repositories
deb http://main.mepis-deb.org/mepiscr/repo/ mepis85cr main non-free
deb http://restricted.mepis-deb.org/mepiscr/repo/ mepis85cr restricted restricted-non-free
# deb http://main.mepis-deb.org/mepiscr/testrepo/ mepis85cr test 
# deb http://restricted.mepis-deb.org/mepiscr/testrepo/ mepis85cr test-restricted 


Then make sure your /etc/apt/preferences file is set up like this:

Code: Select all

Package: fglrx-driver
Pin: release o=MEPIS
Pin-Priority: 990

Package: nvidia-glx
Pin: release o=MEPIS
Pin-Priority: 990

Package: *
Pin: release o=MEPIS
Pin-Priority: 901

Package: *
Pin: release a=mepis
Pin-Priority: 901

Package: *
Pin: release o=Debian
Pin-Priority: 800

Package: *
Pin: release o=volatile.debian.org
Pin-Priority: 800

Package: *
Pin: release o=Ubuntu
Pin-Priority: 400


After I installed SM 8.5 and attempted to install multimedia packages from Lenny, I made a complete mess of things and had to go back, uninstall all the multimedia stuff, and reinstall those packages from the Community Repositories. I believe VLC was one of those "bad actors."

BTW, you posted this thread under "Success Stories". I would ask one of the Moderators to move the thread to General Help. You'll get more of a response from there. :wink:
MX-14; 3.12-0.bpo.1-686-pae kernel using 4GB RAM
2.4GHz AMD Athlon 4600+
NVidia GeForce 6150 LE; 304.121 Display Driver
You didn't slow down because you're old; you're old because you slowed down.

User avatar
lucky9
Forum Veteran
Forum Veteran
Posts: 12373
Joined: Wed Jul 12, 2006 5:54 am

Re: Problem installing VLC in 8.5 32 bit

#3 Postby lucky9 » Wed Jan 26, 2011 4:49 pm

moved
Yes, even I am dishonest. Not in many ways, but in some. Forty-one, I think it is.
--Mark Twain

User avatar
eppoh
Forum Regular
Forum Regular
Posts: 353
Joined: Sat Apr 07, 2007 5:32 pm

Re: Problem installing VLC in 8.5 32 bit Depends hell

#4 Postby eppoh » Mon Feb 07, 2011 10:12 pm

Also trying to install VLC, now caught in dependency hell.

Got as far as needing vlc-nox, but it will not install. I get ;
vlc-nox:
Depends: libavformat52 but it is not going to be installed or
libavformat-unstripped-52 (>=0.svn20080206-8) but it is not installable


but libavformat52, is already installed.

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9178
Age: 58
Joined: Wed Jul 12, 2006 2:26 pm

Re: Problem installing VLC in 8.5 32 bit

#5 Postby kmathern » Mon Feb 07, 2011 11:08 pm

@eppoh,

I'm in a LiveISO session of Mepis 8.5 and VLC (version 1.0.6-1mlrepo1) installs just fine if the sources.list and the preferences are correct.

Post your sources.list and /etc/apt/preferences file.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11519
Age: 58
Joined: Fri Dec 15, 2006 8:07 pm

Re: Problem installing VLC in 8.5 32 bit Depends hell

#6 Postby Stevo » Tue Feb 08, 2011 12:48 am

eppoh wrote:Also trying to install VLC, now caught in dependency hell.

Got as far as needing vlc-nox, but it will not install. I get ;
vlc-nox:
Depends: libavformat52 but it is not going to be installed or
libavformat-unstripped-52 (>=0.svn20080206-8) but it is not installable


but libavformat52, is already installed.


See joany's post above--this is a known issue in 8.5, but solved by installing the community repo version. (Which is better than the ancient 0.8.6 version anyway, IMHO)

User avatar
eppoh
Forum Regular
Forum Regular
Posts: 353
Joined: Sat Apr 07, 2007 5:32 pm

Re: Problem installing VLC in 8.5 32 bit

#7 Postby eppoh » Tue Feb 08, 2011 9:34 am

yep, that did it. I thought I had the same repo's but there were a couple small differences .
thanks


Return to “Newbies”

Who is online

Users browsing this forum: No registered users and 2 guests