MEPIS Community Forum

A Linux operating system based on Debian Stable
View unanswered posts | View unsolved topics | View active topics |



Reply to topic  [ 10 posts ] 
[Solved] pidgin will not run 
Author Message
User avatar

Joined: Thu Jul 13, 2006 7:13 pm
Posts: 109
Has thanked: 0 time
Have thanks: 0 time
Post # 295760
Post [Solved] pidgin will not run
New install of Mepis 11, 32 bit.
Removed kopete, installed Pidgin, but pidgin will not run.
Uninstalled, then reinstalled, still won't run.

Is this a known problem?


Thanks,
Lance


Last edited by LanceHaverkamp on Tue Feb 14, 2012 3:43 am, edited 1 time in total.



Tue Feb 14, 2012 12:41 am
Profile WWW
MEPIS Enthusiast
MEPIS Enthusiast
User avatar

Joined: Wed Jul 12, 2006 2:10 am
Posts: 3367
Location: The Netherlands
Has thanked: 285 times
Have thanks: 321 times
Post # 295762
Post Re: pidgin will not run
Open the konsole, enter kopete, see what the output is that it gives you.

Also.. what else got removed along with Kopete?

_________________
MX-14.2 (upgraded from 14.1.1) ext4 Xfce4.10 * AMD Asus M4A785TD-V EVO AM3 * ASUS GeForce GT640-1GD5-L * AMD Processor Athlon II X4 635, sAM3 * HDA ATI SB (VT1708S Analog) * 2x4Gb DDR3 1600 Kingston * 22" Samsung SyncMaster P2250 * HP DeskJet F2280


Tue Feb 14, 2012 1:31 am
Profile
User avatar

Joined: Thu Jul 13, 2006 7:13 pm
Posts: 109
Has thanked: 0 time
Have thanks: 0 time
Post # 295763
Post Re: pidgin will not run
$ pidgin

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/gstreamer-0.10/libgstlv2.so

Please either:
- remove it and restart.
- run with --gst-disable-segtrap and debug.
Segmentation fault


Doesn't mean much to me.....

Don't think anything was removed with kopete.


Tue Feb 14, 2012 2:19 am
Profile WWW
MEPIS Enthusiast
MEPIS Enthusiast
User avatar

Joined: Wed Jul 12, 2006 2:10 am
Posts: 3367
Location: The Netherlands
Has thanked: 285 times
Have thanks: 321 times
Post # 295764
Post Re: pidgin will not run
Here is what I found googling your konsole message:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=573269

Quote:
A workaround is to remove the file in question.
$ ln -sf /dev/null /usr/lib/gstreamer-0.10/libgstlv2.so



Personally I'd rename the file first (that way it isn't gone) and see if pidgin starts.

_________________
MX-14.2 (upgraded from 14.1.1) ext4 Xfce4.10 * AMD Asus M4A785TD-V EVO AM3 * ASUS GeForce GT640-1GD5-L * AMD Processor Athlon II X4 635, sAM3 * HDA ATI SB (VT1708S Analog) * 2x4Gb DDR3 1600 Kingston * 22" Samsung SyncMaster P2250 * HP DeskJet F2280


Tue Feb 14, 2012 2:25 am

Eadwine Rose thanked by: lucky9
Profile
MEPIS Guide
MEPIS Guide
User avatar

Joined: Wed Jul 12, 2006 4:05 pm
Posts: 2717
Location: Pinellas Park, FL
Has thanked: 95 times
Have thanks: 1647 times
Post # 295786
Post Re: [Solved] pidgin will not run
A better way to fix this issue is to Install gnome-media, then run gstreamer-properties in a terminal as your normal user (once only).
This will configure gstreamer to avoid the problem.

It isn't just a pidgin problem. Several other applications assume that any system using gstreamer will have had it set up with this command and have similar crashes if it hasn't been.

_________________
XFX Nforce 750 (built in GeForce 8300), Athlon X2 5000
Lenovo G550 , Intel T4400 , Intel Mobile 4 graphics


Tue Feb 14, 2012 3:47 pm

timkb4cq thanked by: Jerry3904
Profile
MEPIS Enthusiast
MEPIS Enthusiast
User avatar

Joined: Wed Jul 12, 2006 2:10 am
Posts: 3367
Location: The Netherlands
Has thanked: 285 times
Have thanks: 321 times
Post # 295788
Post Re: [Solved] pidgin will not run
Subtitleeditor has this issue of gstreamer plugins missing (decoders, xvis mpeg-4 and mpeg-1 layer 3 (mp3) in this case).

Could that be the same solution then? I have googled myself crazy for that and all tips that I found did not help.

_________________
MX-14.2 (upgraded from 14.1.1) ext4 Xfce4.10 * AMD Asus M4A785TD-V EVO AM3 * ASUS GeForce GT640-1GD5-L * AMD Processor Athlon II X4 635, sAM3 * HDA ATI SB (VT1708S Analog) * 2x4Gb DDR3 1600 Kingston * 22" Samsung SyncMaster P2250 * HP DeskJet F2280


Tue Feb 14, 2012 3:54 pm
Profile
MEPIS Enthusiast
MEPIS Enthusiast
User avatar

Joined: Wed Jul 19, 2006 6:13 am
Posts: 9666
Location: Geneva NY
Has thanked: 2712 times
Have thanks: 1756 times
Post # 295791
Post Re: [Solved] pidgin will not run
Quote:
A better way to fix this issue is to Install gnome-media, then run gstreamer-properties in a terminal as your normal user (once only). This will configure gstreamer to avoid the problem.

Is this what you expected to see?
Code:
jb@BondDesktop:~$ gstreamer-properties
gstreamer-properties-Message: Skipping unavailable plugin 'alsasink'
gstreamer-properties-Message: Skipping unavailable plugin 'artsdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'esdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'pulsesink'
gstreamer-properties-Message: Skipping unavailable plugin 'glimagesink'
gstreamer-properties-Message: Skipping unavailable plugin 'sdlvideosink'
gstreamer-properties-Message: Skipping unavailable plugin 'ximagesink'
gstreamer-properties-Message: Skipping unavailable plugin 'xvimagesink'
gstreamer-properties-Message: Skipping unavailable plugin 'v4lmjpegsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'qcamsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'alsasrc'
gstreamer-properties-Message: Skipping unavailable plugin 'esdmon'
gstreamer-properties-Message: Skipping unavailable plugin 'pulsesrc'
jb@BondDesktop:~$
Then it spit up a little GUI that I did not know what to do with...

_________________
A Wiki only works when many eyes are on it.

32bit, 3.12-0.bpo.1-686-pae, MX-14, AMD Phenom 9650 Quad-Core, Dell SP2309W with integrated webcam, Nvidia GeForce 6150SE, 4 GB DDR2


Tue Feb 14, 2012 4:31 pm
Profile
MEPIS Guide
MEPIS Guide
User avatar

Joined: Wed Jul 12, 2006 4:05 pm
Posts: 2717
Location: Pinellas Park, FL
Has thanked: 95 times
Have thanks: 1647 times
Post # 295803
Post Re: [Solved] pidgin will not run
Yup! That's what you see. You needn't do anything in the GUI although you can test audio inputs & outputs if you like.
The command creates folders & xml files in ~/.gconf to configure how gstreamer connects to the sound system. I don't know the rest of the details - only that it works.

_________________
XFX Nforce 750 (built in GeForce 8300), Athlon X2 5000
Lenovo G550 , Intel T4400 , Intel Mobile 4 graphics


Tue Feb 14, 2012 8:08 pm

timkb4cq thanked by: Jerry3904, lucky9
Profile
MEPIS Guide
MEPIS Guide
User avatar

Joined: Wed Jul 12, 2006 4:05 pm
Posts: 2717
Location: Pinellas Park, FL
Has thanked: 95 times
Have thanks: 1647 times
Post # 295805
Post Re: [Solved] pidgin will not run
Eadwine Rose wrote:
Subtitleeditor has this issue of gstreamer plugins missing (decoders, xvis mpeg-4 and mpeg-1 layer 3 (mp3) in this case).

Could that be the same solution then? I have googled myself crazy for that and all tips that I found did not help.


I installed Subtitleeditor and it appears to work. I don't know the program or work with subtitles at all so I may be missing something.
You might need gstreamer0.10-plugins-ugly & gstreamer0.10-ffmpeg from the CR. I had them installed already & had run gstreamer-properties

_________________
XFX Nforce 750 (built in GeForce 8300), Athlon X2 5000
Lenovo G550 , Intel T4400 , Intel Mobile 4 graphics


Tue Feb 14, 2012 8:29 pm
Profile
MEPIS Enthusiast
MEPIS Enthusiast
User avatar

Joined: Wed Jul 12, 2006 2:10 am
Posts: 3367
Location: The Netherlands
Has thanked: 285 times
Have thanks: 321 times
Post # 295819
Post Re: [Solved] pidgin will not run
It works like a peach as long as I use an external player. As soon as I use the internal one it spits out about the missing things. No biggie really for me, as it does work after all, just in mplayer, instead of internally in that screen. Ah.. if that is all.. *shrug* you know :smile:

_________________
MX-14.2 (upgraded from 14.1.1) ext4 Xfce4.10 * AMD Asus M4A785TD-V EVO AM3 * ASUS GeForce GT640-1GD5-L * AMD Processor Athlon II X4 635, sAM3 * HDA ATI SB (VT1708S Analog) * 2x4Gb DDR3 1600 Kingston * 22" Samsung SyncMaster P2250 * HP DeskJet F2280


Wed Feb 15, 2012 4:29 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.