Instructions to Upgrade M11 to KDE 4.6.5

Message
Author
User avatar
richb
Administrator
Posts: 12925
Age: 71
Joined: Wed Jul 12, 2006 2:17 pm

Instructions to Upgrade M11 to KDE 4.6.5

#1 Postby richb » Fri Nov 11, 2011 12:43 pm

This is put up for correction and comment. Not a final draft.

KDE 4.6.5 is now aavailable as a community update to Mepis 11. The following steps will effect the upgrade on a fresh install.

1. With the default repositories (see figure), and preferred distribution as set, Start Synaptic, reload, mark all upgrades and apply them.
2.. Add the Experimental KDE repository to /etc/apt/sources.list deb http://main.mepis-deb.org/mepiscr/kde/ experimental test and enable it.
3. Leave the default repository settings as is and change the preferred distribution to mepis.
4. In Synaptic reload and mark all upgrades. Apply the upgrades.

That is it. The recommendation is to use a fresh install although some have reported success on "mature" installs. This is a major upgrade to KDE. Many have reported success but there may be interactions that have not as yet been reported. So implementing this is at your own risk.

Default repositories.
You do not have the required permissions to view the files attached to this post.
Forum Rules
Guide - How to Ask for Help

Rich

Laptop: Acer V5-572G: Intel i5, 12 GIG mem, Intel graphics, SanDisk SSD, 256GB
Virtualbox: Win 7
Desktop: MX-15- 64, AMD A8 7600 FM2+ CPU R7 Graphics, fglrx driver, 16 GIG Mem. Samsung EVO SSD 250 GB

User avatar
uncle mark
Forum Veteran
Forum Veteran
Posts: 5354
Age: 2015
Joined: Sat Nov 11, 2006 10:42 pm

Re: Instructions to Upgrade M11 to KDE 4.6.5

#2 Postby uncle mark » Fri Nov 11, 2011 12:47 pm

richb wrote:This is put up for correction and comment. Not a final draft.

KDE 4.6.5 is now aavailable as a community update to Mepis 11. The following steps will effect the upgrade on a fresh install.

1. With the default repositories and preferred distribution as set, Start Synaptic, reload, mark all upgrades and apply them.
2.. Add the Experimental KDE repository to /etc/apt/sources.list deb http://main.mepis-deb.org/mepiscr/kde/ experimental test and enable it.
3. Leave the default repository settings as is as well as the default preferred distro.
4. In Synaptic reload and mark all upgrades. Apply the upgrades.

That is it. The recommendation is to use a fresh install although some have reported success on "mature" installs. This is a major upgrade to KDE. Many have reported success but there may be interactions that have not as yet been reported. So implementing this is at your own risk.


I would spell out exactly what the defaults are. Assume the user has been mucking.
Desktop: Custom build Asus/AMD/nVidia -- MX-15 KDE, MEPIS 11
Laptop: Acer Aspire 5250 -- MX-15

User avatar
richb
Administrator
Posts: 12925
Age: 71
Joined: Wed Jul 12, 2006 2:17 pm

Re: Instructions to Upgrade M11 to KDE 4.6.5

#3 Postby richb » Fri Nov 11, 2011 12:56 pm

Good idea Uncle Mark. i also discovered that prefer distribution needs to be Mepis. I will make the running changes in the first post.
Forum Rules
Guide - How to Ask for Help

Rich

Laptop: Acer V5-572G: Intel i5, 12 GIG mem, Intel graphics, SanDisk SSD, 256GB
Virtualbox: Win 7
Desktop: MX-15- 64, AMD A8 7600 FM2+ CPU R7 Graphics, fglrx driver, 16 GIG Mem. Samsung EVO SSD 250 GB

User avatar
richb
Administrator
Posts: 12925
Age: 71
Joined: Wed Jul 12, 2006 2:17 pm

Re: Instructions to Upgrade M11 to KDE 4.6.5

#4 Postby richb » Fri Nov 11, 2011 1:06 pm

Probably reported before but when I try this procedure, I get this error. Of course I violated the procedure by running sgfxi for my intel graphics. Is that the issue.

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
Forum Rules
Guide - How to Ask for Help

Rich

Laptop: Acer V5-572G: Intel i5, 12 GIG mem, Intel graphics, SanDisk SSD, 256GB
Virtualbox: Win 7
Desktop: MX-15- 64, AMD A8 7600 FM2+ CPU R7 Graphics, fglrx driver, 16 GIG Mem. Samsung EVO SSD 250 GB

User avatar
Zevon
Forum Regular
Forum Regular
Posts: 549
Joined: Sat Dec 13, 2008 11:23 am

Re: Instructions to Upgrade M11 to KDE 4.6.5

#5 Postby Zevon » Fri Nov 11, 2011 1:12 pm

Suggestion;
Add a screenie of the "Preferences as set"

and
"Sources and Preferences recommended", post-upgrade.

User avatar
richb
Administrator
Posts: 12925
Age: 71
Joined: Wed Jul 12, 2006 2:17 pm

Re: Instructions to Upgrade M11 to KDE 4.6.5

#6 Postby richb » Fri Nov 11, 2011 1:15 pm

I would like someone else who has successfully made this upgrade take this over. It does not work for me so I should not be the one writing the procedure.
Forum Rules
Guide - How to Ask for Help

Rich

Laptop: Acer V5-572G: Intel i5, 12 GIG mem, Intel graphics, SanDisk SSD, 256GB
Virtualbox: Win 7
Desktop: MX-15- 64, AMD A8 7600 FM2+ CPU R7 Graphics, fglrx driver, 16 GIG Mem. Samsung EVO SSD 250 GB

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 8911
Age: 57
Joined: Wed Jul 12, 2006 2:26 pm

Re: Instructions to Upgrade M11 to KDE 4.6.5

#7 Postby kmathern » Fri Nov 11, 2011 1:21 pm

richb wrote:Probably reported before but when I try this procedure, I get this error. Of course I violated the procedure by running sgfxi for my intel graphics. Is that the issue.

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

It's not caused by sgfxi. It's something to do with packages in Warren's repo having a higher priority in /etc/apt/preferences than those in the community repos. That's reason I originally came up with the "two step" upgrade here: viewtopic.php?p=287447#p287447

Danum has an upgrade method here: viewtopic.php?p=287828#p287828 where you first do an upgrade without the kde repo (test repo in his post -- he made his post before the kde repo was created). You then disable Warren's repo, add the kde repo, set 'mepis' as the preferred distro, and then upgrade again. You won't get the error mesage using that method.

User avatar
richb
Administrator
Posts: 12925
Age: 71
Joined: Wed Jul 12, 2006 2:17 pm

Re: Instructions to Upgrade M11 to KDE 4.6.5

#8 Postby richb » Fri Nov 11, 2011 1:30 pm

kmathern wrote:
richb wrote:Probably reported before but when I try this procedure, I get this error. Of course I violated the procedure by running sgfxi for my intel graphics. Is that the issue.

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

It's not caused by sgfxi. It's something to do with packages in Warren's repo having a higher priority in /etc/apt/preferences than those in the community repos. That's reason I originally came up with the "two step" upgrade here: viewtopic.php?p=287447#p287447

Danum has an upgrade method here: viewtopic.php?p=287828#p287828 where you first do an upgrade without the kde repo (test repo in his post -- he made his post before the kde repo was created). You then disable Warren's repo, add the kde repo, set 'mepis' as the preferred distro, and then upgrade again. You won't get the error mesage using that method.

When I do that, Danum's method, a large number of KDE packages get removed and not replaced, dolphin for instance.
Forum Rules
Guide - How to Ask for Help

Rich

Laptop: Acer V5-572G: Intel i5, 12 GIG mem, Intel graphics, SanDisk SSD, 256GB
Virtualbox: Win 7
Desktop: MX-15- 64, AMD A8 7600 FM2+ CPU R7 Graphics, fglrx driver, 16 GIG Mem. Samsung EVO SSD 250 GB

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 8911
Age: 57
Joined: Wed Jul 12, 2006 2:26 pm

Re: Instructions to Upgrade M11 to KDE 4.6.5

#9 Postby kmathern » Fri Nov 11, 2011 1:42 pm

richb wrote:When I do that, Danum's method, a large number of KDE packages get removed and not replaced, dolphin for instance.

During the first upgrade step or the 2nd?


I tried Danum's method on a clean install and didn't have any problems with it. It might be different on a 'mature' M11 install.

The only thing I would change was where he added the Debian Multimedia repo. No packages were installed from it in the 1st upgrade and just one package (libmlt-data) was installed during the 2nd upgrade.

User avatar
richb
Administrator
Posts: 12925
Age: 71
Joined: Wed Jul 12, 2006 2:17 pm

Re: Instructions to Upgrade M11 to KDE 4.6.5

#10 Postby richb » Fri Nov 11, 2011 1:51 pm

kmathern wrote:
richb wrote:When I do that, Danum's method, a large number of KDE packages get removed and not replaced, dolphin for instance.

During the first upgrade step or the 2nd?


I tried Danum's method on a clean install and didn't have any problems with it. It might be different on a 'mature' M11 install.

The only thing I would change was where he added the Debian Multimedia repo. No packages were installed from it in the 1st upgrade and just one package (libmlt-data) was installed during the 2nd upgrade.

2nd step. but mepis is not a choice of preferred distro. Only stable is. Closed Synaptic, reopened it and tried again. This time it appears to be working as advertised. I will reboot to verify..
Verify that no changes come in with multimedia repo enabled.

EDIT: OK got it to upgrade. But again the steps I took were tortuous, do not coincide exactly with what others have done, and I cannot write a clear instruction set. So a plea once more for someone to take up this task with all the nitty gritty details included.
Forum Rules
Guide - How to Ask for Help

Rich

Laptop: Acer V5-572G: Intel i5, 12 GIG mem, Intel graphics, SanDisk SSD, 256GB
Virtualbox: Win 7
Desktop: MX-15- 64, AMD A8 7600 FM2+ CPU R7 Graphics, fglrx driver, 16 GIG Mem. Samsung EVO SSD 250 GB


Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest