Announcing a repository for the M11 KDE 4.6.5 upgrade

Message
Author
User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 3492
Joined: Wed Jul 12, 2006 4:05 pm

Announcing a repository for the M11 KDE 4.6.5 upgrade

#1 Postby timkb4cq » Sun Nov 06, 2011 8:49 pm

There is now a KDE 4.6.5 repository. Here it is as you would enter it in Synaptic.

Code: Select all

http://main.mepis-deb.org/mepiscr/kde/
experimental
test
Please use this instead of the testing repository for KDE upgrade. The KDE packages will be removed from the testing repository soon. The new KDE localization files are in this repository and are not going into the testing repo.
The new Qt4 packages are also here to enable the kmathern standard 2 part upgrade to work properly with this new repository enabled instead of the testing repository. The Qt4 packages will also stay in testing for now.
Packages that need updating to work properly with KDE 4.6.5 will be placed in this repository as they are discovered & built, so if you have upgraded your KDE you might want to keep this repo enabled - just pay attention when you do upgrades to make sure nothing is being removed that you don't wish removed..
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
JBoman
Forum Guide
Forum Guide
Posts: 1483
Age: 58
Joined: Wed Jul 12, 2006 4:30 pm

Re: Announcing a repository for the M11 KDE 4.6.5 upgrade

#2 Postby JBoman » Sun Nov 06, 2011 9:46 pm

I think this will create unneeded complications trying to remember which packages are where for updates and the like. I'll just be frank.... I don't like it. It takes the simplicity away from the repo setup. Please reconsider. :exclamation: Jerry
http://patentabsurdity.com/
AMD 64x2 2.6GHz 4GB ram MX-15 regular updates
"beware a frequent flirt with potential disaster"

User avatar
richb
Administrator
Posts: 13112
Joined: Wed Jul 12, 2006 2:17 pm

Re: Announcing a repository for the M11 KDE 4.6.5 upgrade

#3 Postby richb » Sun Nov 06, 2011 10:00 pm

I think it is an excellent idea and not a complication. A KDE upgrade is not a normal testing activity, in itself is more complicated and risky and should be given its own repo.
Forum Rules
Guide - How to Ask for Help

Rich

Laptop: Acer V5-572G: Intel i5, 12 GIG mem, Intel graphics, SanDisk SSD, 256GB
Virtualbox: Win 7
Desktop: MX-15- 64, AMD A8 7600 FM2+ CPU R7 Graphics, fglrx driver, 16 GIG Mem. Samsung EVO SSD 250 GB

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 3492
Joined: Wed Jul 12, 2006 4:05 pm

Re: Announcing a repository for the M11 KDE 4.6.5 upgrade

#4 Postby timkb4cq » Sun Nov 06, 2011 10:01 pm

The problem is that M11 upgraded to KDE 4.6.5 breaks some packages.
Some of the rebuilt versions of those packages to allow them to work on KDE 4.6.5 won't work with the default KDE so they can't ever go to the main CR.
Leaving them in testing prevents us from building the newer version of those packages for normal MEPIS 11 users.

This doesn't prevent KDE 4.6.5 users from using the testing CR if they like. Most of those packages will work on either KDE version. It's just the KDE upgrade & the packages that won't work on a stock M11 that will occupy the new repository.

Essentially M11 upgraded to KDE 4.6.5 isn't quite MEPIS 11 anymore - it's 11.1 and it needs its own repo.
And it will make the testing CR somewhat safer for normal users again. Blind upgrades from testing are still not recommended but once those KDE upgrade packages are removed from it a mistaken upgrade will be far less likely to bork a system.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
JBoman
Forum Guide
Forum Guide
Posts: 1483
Age: 58
Joined: Wed Jul 12, 2006 4:30 pm

Re: Announcing a repository for the M11 KDE 4.6.5 upgrade

#5 Postby JBoman » Sun Nov 06, 2011 10:04 pm

Amazing what a good explanation can do for reasoning. That does make sense; Thanks Tim. Jerry :p
http://patentabsurdity.com/
AMD 64x2 2.6GHz 4GB ram MX-15 regular updates
"beware a frequent flirt with potential disaster"

User avatar
JBoman
Forum Guide
Forum Guide
Posts: 1483
Age: 58
Joined: Wed Jul 12, 2006 4:30 pm

Re: Announcing a repository for the M11 KDE 4.6.5 upgrade

#6 Postby JBoman » Sun Nov 06, 2011 10:42 pm

Added to repos but get this error when I try to open Synaptic >> E: Type 'http://main.mepis-deb.org/mepiscr/kde/' is not known on line 35 in source list /etc/apt/sources.list
E: The list of sources could not be read.
Go to the repository dialog to correct the problem.
E: _cache->open() failed, please report.
http://patentabsurdity.com/
AMD 64x2 2.6GHz 4GB ram MX-15 regular updates
"beware a frequent flirt with potential disaster"

User avatar
richb
Administrator
Posts: 13112
Joined: Wed Jul 12, 2006 2:17 pm

Re: Announcing a repository for the M11 KDE 4.6.5 upgrade

#7 Postby richb » Sun Nov 06, 2011 10:45 pm

JBoman wrote:Added to repos but get this error when I try to open Synaptic >> E: Type 'http://main.mepis-deb.org/mepiscr/kde/' is not known on line 35 in source list /etc/apt/sources.list
E: The list of sources could not be read.
Go to the repository dialog to correct the problem.
E: _cache->open() failed, please report.


The line should look like this. with deb in front of it.

deb http://main.mepis-deb.org/mepiscr/kde/ experimental test
Forum Rules
Guide - How to Ask for Help

Rich

Laptop: Acer V5-572G: Intel i5, 12 GIG mem, Intel graphics, SanDisk SSD, 256GB
Virtualbox: Win 7
Desktop: MX-15- 64, AMD A8 7600 FM2+ CPU R7 Graphics, fglrx driver, 16 GIG Mem. Samsung EVO SSD 250 GB

User avatar
JBoman
Forum Guide
Forum Guide
Posts: 1483
Age: 58
Joined: Wed Jul 12, 2006 4:30 pm

Re: Announcing a repository for the M11 KDE 4.6.5 upgrade

#8 Postby JBoman » Sun Nov 06, 2011 10:52 pm

richb wrote:
JBoman wrote:Added to repos but get this error when I try to open Synaptic >> E: Type 'http://main.mepis-deb.org/mepiscr/kde/' is not known on line 35 in source list /etc/apt/sources.list
E: The list of sources could not be read.
Go to the repository dialog to correct the problem.
E: _cache->open() failed, please report.


The line should look like this. with deb in front of it.

deb http://main.mepis-deb.org/mepiscr/kde/ experimental test


Thanks Rich that fixed it. :happy: Jerry
http://patentabsurdity.com/
AMD 64x2 2.6GHz 4GB ram MX-15 regular updates
"beware a frequent flirt with potential disaster"

johnnyhop
Forum Novice
Forum  Novice
Posts: 22
Age: 64
Joined: Sun Jan 16, 2011 8:17 am

Re: Announcing a repository for the M11 KDE 4.6.5 upgrade

#9 Postby johnnyhop » Thu Mar 06, 2014 11:41 pm

Before trying the KDE 4.6.5 upgrade I'd like to identify which version of KDE 4 I'm currently running. How is KDE version identified?

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11484
Age: 58
Joined: Fri Dec 15, 2006 8:07 pm

Re: Announcing a repository for the M11 KDE 4.6.5 upgrade

#10 Postby Stevo » Fri Mar 07, 2014 12:55 am

Try running kinfocenter.


Return to “Community Repository (CR)”

Who is online

Users browsing this forum: No registered users and 1 guest