File Permissions Changed

Here is where users who have been using MEPIS awhile and know the basics of linux and MEPIS can ask questions.
Message
Author
User avatar
joany
Forum Veteran
Forum Veteran
Posts: 6112
Joined: Mon Feb 12, 2007 1:45 pm

File Permissions Changed

#1 Postby joany » Tue Apr 03, 2012 9:15 am

When copying files to a backup directory on a partition that's formatted NTFS, executable files are rendered non-executable. (I found this out when I restored a shell script from the backup location. The script is set to autoexecute on startup, and I was getting errors. When I checked the file's permissions, it was set to non-executable.)

This isn't a major problem because file permissions can be restored manually; however, is there a way to copy files to an NTFS backup location and keep the permissions intact? BTW, I use the backup partition for Windows too, which is why it's formatted NTFS.
MX-14; 3.12-0.bpo.1-686-pae kernel using 4GB RAM
2.4GHz AMD Athlon 4600+
NVidia GeForce 6150 LE; 304.121 Display Driver
You didn't slow down because you're old; you're old because you slowed down.

User avatar
Adrian
Forum Veteran
Forum Veteran
Posts: 6174
Age: 41
Joined: Wed Jul 12, 2006 1:42 am

Re: File Permissions Changed

#2 Postby Adrian » Tue Apr 03, 2012 9:31 am

This seems like an informative article about permissions under NTFS: http://b.andre.pagesperso-orange.fr/permissions.html

fbt
Forum Regular
Forum Regular
Posts: 799
Joined: Fri Jul 14, 2006 6:09 pm

Re: File Permissions Changed

#3 Postby fbt » Tue Apr 03, 2012 2:02 pm

Might explain why my USB drives, one formatted NTFS the othe ext3 have different permissions.

User avatar
joany
Forum Veteran
Forum Veteran
Posts: 6112
Joined: Mon Feb 12, 2007 1:45 pm

Re: File Permissions Changed

#4 Postby joany » Tue Apr 03, 2012 2:26 pm

So I guess there's no way to get around losing Linux file permissions, since they are not compatible with NTFS. I don't know if this is common knowledge, but it fooled me.

I noticed another thing: In LuckyBackup, if you check the box labeled "Destination is FAT/NTFS" under Advanced > Command Options, the options labeled "Preserve ownership, times" and "Preserve permissions" are grayed out. I guess this is the reason for that.
MX-14; 3.12-0.bpo.1-686-pae kernel using 4GB RAM
2.4GHz AMD Athlon 4600+
NVidia GeForce 6150 LE; 304.121 Display Driver
You didn't slow down because you're old; you're old because you slowed down.

User avatar
GoManutd
Forum Guide
Forum Guide
Posts: 2952
Joined: Mon Jun 30, 2008 8:06 pm

Re: File Permissions Changed

#5 Postby GoManutd » Tue Apr 03, 2012 3:28 pm

hmm... joany, i wonder if using tar to backup your files to the ntfs partition might not take care of that?

tar has a preserve permissions option. in theory, it should be preserving the permissions of the original files. you could also use the owner and group options to set these to something else...

you might not have hot access to the files, but you wouldn't have to worry about the permissions issue...

User avatar
joany
Forum Veteran
Forum Veteran
Posts: 6112
Joined: Mon Feb 12, 2007 1:45 pm

Re: File Permissions Changed

#6 Postby joany » Tue Apr 03, 2012 6:21 pm

GoManutd wrote:hmm... joany, i wonder if using tar to backup your files to the ntfs partition might not take care of that?

tar has a preserve permissions option. in theory, it should be preserving the permissions of the original files. you could also use the owner and group options to set these to something else...

you might not have hot access to the files, but you wouldn't have to worry about the permissions issue...

Your suggestion is certainly worth looking into.
MX-14; 3.12-0.bpo.1-686-pae kernel using 4GB RAM
2.4GHz AMD Athlon 4600+
NVidia GeForce 6150 LE; 304.121 Display Driver
You didn't slow down because you're old; you're old because you slowed down.


Return to “Regulars”

Who is online

Users browsing this forum: No registered users and 2 guests