MEPIS 11 Community Repo: The VLC Thread

News about updates on package status for CR packages compiled for MEPIS 11.0
Message
Author
User avatar
GregB
Forum Novice
Forum  Novice
Posts: 76
Joined: Mon Mar 02, 2009 9:58 pm

Re: MEPIS 11 Community Repo: The VLC Thread

#61 Postby GregB » Sat Mar 03, 2012 10:09 pm

When a search for qt is done in Synaptic, a large number of installed packages show that 4:4.7.3-8mcr110+1 is the installed version. There are also many other QT4 related packages that are not installed.

User avatar
GregB
Forum Novice
Forum  Novice
Posts: 76
Joined: Mon Mar 02, 2009 9:58 pm

Re: MEPIS 11 Community Repo: The VLC Thread

#62 Postby GregB » Sun Mar 04, 2012 7:45 pm

Follow up:

I did some checking to see if there are any differences between the 32-bit install and the 64-bit install. Both PCs have NVIDIA graphics chipsets. the 32-bit PC had several more NVIDIA packages installed than does the 64-bit install. The 32-bit version is also running an earlier version of the NVIDIA driver. The last time I tried using sgfxi to install a newer NVIDIA driver on the 32-bit install it had some severe errors and left me with a broken GUI, which I was able to fix. That was the first time sgfxi ever failed on me.

In further checking, it looks like something messed with OpenGL. The system can't provide OpenGL information and both Google Earth and Celestia are non-functional. Google Earth and Celestia had been working. I'm not sure what could have changed to damage OpenGL.

User avatar
chatan
Forum Regular
Forum Regular
Posts: 798
Joined: Fri Oct 17, 2008 8:19 pm

Re: MEPIS 11 Community Repo: The VLC Thread

#63 Postby chatan » Tue Mar 13, 2012 5:18 am

My upgrade to "VLC media player 2.0.0 Twoflower: went OK on M11 64-bit
Had to have debian multimedia repo enabled to get something.

Cheers

User avatar
GregB
Forum Novice
Forum  Novice
Posts: 76
Joined: Mon Mar 02, 2009 9:58 pm

Re: MEPIS 11 Community Repo: The VLC Thread

#64 Postby GregB » Mon Mar 19, 2012 1:54 pm

While upgrading to version 11 of Firefox and Thunderbird I noticed that there was an upgrade available for Flight Gear. Some of its dependencies were some Mesa glx related packages. I had installed Flight Gear a while back, but it never worked. I wonder if Flight Gear might be the package that damaged OpenGL? If I have anything further relating to Flight Gear I'll post in either a new thread or in an existing Flight Gear thread.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11349
Age: 58
Joined: Fri Dec 15, 2006 8:07 pm

Re: MEPIS 11 Community Repo: The VLC Thread

#65 Postby Stevo » Mon Mar 19, 2012 11:45 pm

There's a newer build of VLC 2.0 in the test repo that should not require any debian-multimedia package (I think that was libfaac0, the AAC encoder that's not quite free...)

As far as I can tell, the new Flightgear doesn't need an upgrade of xorg, but usually that upgrade results in better performance witht the open xorg drivers.

Also upgraded was 0 AD to alpha 0.9 "The Ides of March". As far as I know, we don't have to beware this release. In the spirit of equal opportunity, in my Egyptian oasis practice session, I had the male warriors pick berries and the women try to bring down an elephant for food...It went rather poorly.
The optimist proclaims that we live in the best of all possible worlds, and the pessimist fears this is true.

James Branch Cabell

User avatar
chatan
Forum Regular
Forum Regular
Posts: 798
Joined: Fri Oct 17, 2008 8:19 pm

Re: MEPIS 11 Community Repo: The VLC Thread

#66 Postby chatan » Sun Jul 22, 2012 4:02 am

On M11 64bit, I tried to upgrade vlc from 2.0.2 to 2.0.3-0mcr110+1

Gives this error:

vlc:
Depends: vlc-nox (=2.0.3-0mcr110+1) but 2.0.2-1mcr110+1 is to be installed
Depends: libavcodec54 (>=6:0.11.1) but it is not installable
Depends: libavutil51 (>=6:0.11.1) but 6:0.8-2mcr110+1 is to be installed


I tried to upgrade just vlc-nox, but it says that will remove vlc. I tried anyway and it says:

vlc-nox:
Depends: libavcodec54 (>=6:0.11.1) but it is not installable
Depends: libavformat54 (>=6:0.11.1) but it is not installable
Depends: libavutil51 (>=6:0.11.1) but 6:0.8-2mcr110+1 is to be installed
Depends: libpostproc52 (>=6:0.11.1) but 6:0.8-2mcr110+1 is to be installed
Depends: libswscale2 (>=6:0.11.1) but 6:0.8-2mcr110+1 is to be installed

Synaptic doesn’t list the lib...54, only 53.
Cheers!

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11349
Age: 58
Joined: Fri Dec 15, 2006 8:07 pm

Re: MEPIS 11 Community Repo: The VLC Thread

#67 Postby Stevo » Sun Jul 22, 2012 2:48 pm

That's my mistake, I built the 64-bit VLC against a version of ffmpeg (the latest, in fact) that's not yet in the CR, since I still have to build a version of the older 0.8.1 that will let us keep libavcodec53 installed, since many things depend on it. I have fixed the issue with these builds of VLC:

http://ubuntuone.com/75inCVsROWMDvVlT3CYkOf

and will send them to the CR. You can also pick out the debs of the packages that are giving the error and install them with "dpkg -i packagename" as root, which should fix the apt system. Don't do any vlc upgrades from online over these packages until we get them in tonight.
The optimist proclaims that we live in the best of all possible worlds, and the pessimist fears this is true.

James Branch Cabell

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11349
Age: 58
Joined: Fri Dec 15, 2006 8:07 pm

Re: MEPIS 11 Community Repo: The VLC Thread

#68 Postby Stevo » Sun Jul 22, 2012 9:09 pm

The corrected VLC 2.0.3 files should be in testing CR shortly.
The optimist proclaims that we live in the best of all possible worlds, and the pessimist fears this is true.

James Branch Cabell

User avatar
chatan
Forum Regular
Forum Regular
Posts: 798
Joined: Fri Oct 17, 2008 8:19 pm

Re: MEPIS 11 Community Repo: The VLC Thread

#69 Postby chatan » Mon Jul 23, 2012 7:01 am

Stevo wrote:The corrected VLC 2.0.3 files should be in testing CR shortly.

That did the trick. installed and runs OK.
Glad you know what you are doing ;)
Cheers!

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11349
Age: 58
Joined: Fri Dec 15, 2006 8:07 pm

Re: MEPIS 11 Community Repo: The VLC Thread

#70 Postby Stevo » Thu Oct 18, 2012 10:29 pm

VLC 2.0.4 is now available in the testing main CR. It needs the latest libav libraries also in the testing CR. I had to remove the terminal-based ncurses interface, which I bet sees little use, since it only looked for a newer version of ncursesw than Squeeze offers.

Also of note is new support of Opus audio, which is a new, free, high performance audio codec with a lot of industry backing.
The optimist proclaims that we live in the best of all possible worlds, and the pessimist fears this is true.

James Branch Cabell


Return to “Package Status - 11.0”

Who is online

Users browsing this forum: No registered users and 1 guest