MEPIS 11 Community Repo: The Clementine Thread

News about updates on package status for CR packages compiled for MEPIS 11.0
Message
Author
User avatar
GoManutd
Forum Guide
Forum Guide
Posts: 2952
Joined: Mon Jun 30, 2008 8:06 pm

Re: MEPIS 11 Community Repo: The Clementine Thread

#11 Postby GoManutd » Wed Jun 01, 2011 11:49 am

tried this on m11 32 bit because the new amarok is proving hard to get use to. despite trying all the different devices, clementine will not play. i either get internal data flow error, or could not open resource for writing.

i have sound in everything else, and can play recordings with amarok, just not clementine.

chrispop99
Forum Guide
Forum Guide
Posts: 1433
Age: 70
Joined: Tue Jan 27, 2009 3:07 pm

Re: MEPIS 11 Community Repo: The Clementine Thread

#12 Postby chrispop99 » Wed Jun 01, 2011 1:32 pm

Sorry I can't help, other than to say that 0.7.1 is working faultlessly on M11 final here.

Chris
Test machines:
Gigabyte Z77P-D3, Intel i3-3220, GeForce 8400 GS, 4GB PC3-12800.
DELL Latitude D630 laptop, 2GHz Core 2 Duo, 2GB PC2-5300.
IBM Thinkpad T41 laptop, 1.6GHz Pentium M (Non-PAE), 1GB RAM, 30GB PATA SSD.

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 3376
Joined: Wed Jul 12, 2006 4:05 pm

Re: MEPIS 11 Community Repo: The Clementine Thread

#13 Postby timkb4cq » Wed Jun 01, 2011 1:53 pm

GoManutd wrote:tried this on m11 32 bit because the new amarok is proving hard to get use to. despite trying all the different devices, clementine will not play. i either get internal data flow error, or could not open resource for writing.

It works here on M11 32bit also. The "Could not open resource for writing" error makes me wonder whether you have switched to Jack, ESD or PulseAudio for your sound system. I've found that just installing pulseaudio will prevent some apps from playing sound. If you do not have pulseaudio installed (just look in Synaptic), check the Tools -> Preferences -> Playback -> Gstreamer audio engine pulldown in Clementine and set it to the proper setting for your sound system. It works on the default setting here...
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
GoManutd
Forum Guide
Forum Guide
Posts: 2952
Joined: Mon Jun 30, 2008 8:06 pm

Re: MEPIS 11 Community Repo: The Clementine Thread

#14 Postby GoManutd » Wed Jun 01, 2011 5:25 pm

thanks, but i tried each setting and ended up with one of the two errors. there are two libraries that are pulseaudio related installed, but pulseaudio itself isn't.

here's what i get on the command line whenever i try to play something:

Code: Select all

"gstjackaudiosink.c(355): gst_jack_ring_buffer_open_device (): /GstPipeline:pipeline/GstBin:audiobin/GstJackAudioSink:jackaudiosink-112:
Jack client open error (status 1)"
Gstreamer error: "Could not open resource for writing."
QTimeLine::start: already running


the above is repeated for however many songs are currently in the playlist.

lsmod | grep snd produces

Code: Select all

snd_seq_midi            3392  0
snd_rawmidi            12396  1 snd_seq_midi
snd_seq_midi_event      3604  1 snd_seq_midi
snd_seq                34132  2 snd_seq_midi,snd_seq_midi_event
snd_seq_device          3635  3 snd_seq_midi,snd_rawmidi,snd_seq
snd_pcm_oss            27084  0
snd_mixer_oss          10105  1 snd_pcm_oss
snd_hda_codec_realtek   177694  1
snd_hda_intel          16601  6
snd_hda_codec          55663  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               3906  1 snd_hda_codec
snd_pcm                46446  4 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer              12287  3 snd_seq,snd_pcm
snd                    33144  21 snd_rawmidi,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore               3263  1 snd
snd_page_alloc          4857  2 snd_hda_intel,snd_pcm

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 3376
Joined: Wed Jul 12, 2006 4:05 pm

Re: MEPIS 11 Community Repo: The Clementine Thread

#15 Postby timkb4cq » Wed Jun 01, 2011 6:17 pm

Do you have the hidden file ~/.asoundrc ?
If so, delete it. It's been a problem on Ubuntu.

If not, try installing gnome-media, then from a Konsole run gstreamer-properties

Clementine uses the gstreamer backend and gstreamer-properties does some setup for it. It isn't always necessary but might be on your hardware.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
GoManutd
Forum Guide
Forum Guide
Posts: 2952
Joined: Mon Jun 30, 2008 8:06 pm

Re: MEPIS 11 Community Repo: The Clementine Thread

#16 Postby GoManutd » Wed Jun 01, 2011 9:57 pm

so it turns out to be a known problem with gstreamer.

https://bugzilla.redhat.com/show_bug.cgi?id=575903

installed gnome-media and ran gstreamer-properties, but was still getting the same errors - even tried running it as root when i noticed this error (honestly, it was probably there when i ran it with my own creds)

Code: Select all

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/gstreamer-0.10/libgstlv2.so


according to the bug report this has been fixed in gstreamer-0.10.28-2. however, for ha-has i installed gstreamer-0.10-alsa and then tried running gstreamer-properties. this time i got sound using autodetect.

i tried running clementine again, but was getting the same errors AND all sorts of new errors and when i tried to enter prefs it just done blowed up. doing a complete removal via synaptic, deleting the ~/.config/Clementine directory, and reinstalling the latest version and i'm listening to ABBA via clemetine.

thanks.

User avatar
uncle mark
Forum Veteran
Forum Veteran
Posts: 5360
Age: 2015
Joined: Sat Nov 11, 2006 10:42 pm

Re: MEPIS 11 Community Repo: The Clementine Thread

#17 Postby uncle mark » Wed Jun 01, 2011 10:02 pm

GoManutd wrote:...doing a complete removal via synaptic, deleting the ~/.config/Clementine directory, and reinstalling the latest version and i'm listening to ABBA via clemetine.


ABBA???

<shudder>
Desktop: Custom build Asus/AMD/nVidia -- MX-15 KDE, MEPIS 11
Laptop: Acer Aspire 5250 -- MX-15

User avatar
GoManutd
Forum Guide
Forum Guide
Posts: 2952
Joined: Mon Jun 30, 2008 8:06 pm

Re: MEPIS 11 Community Repo: The Clementine Thread

#18 Postby GoManutd » Wed Jun 01, 2011 10:04 pm

don't diss ABBA ;-)

i have very eclectic taste in music. i assure you there is led zep, and other rock in my library

User avatar
lucky9
Forum Veteran
Forum Veteran
Posts: 12333
Age: 70
Joined: Wed Jul 12, 2006 5:54 am

Re: MEPIS 11 Community Repo: The Clementine Thread

#19 Postby lucky9 » Wed Jun 01, 2011 11:05 pm

Offhand I can't think of a genre that I don't like something in. Broaden your horizons and listen to Ricochet (rap song) sometime.
Yes, even I am dishonest. Not in many ways, but in some. Forty-one, I think it is.
--Mark Twain

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11130
Age: 57
Joined: Fri Dec 15, 2006 8:07 pm

Re: MEPIS 11 Community Repo: The Clementine Thread

#20 Postby Stevo » Wed Jun 01, 2011 11:11 pm

uncle mark wrote:
GoManutd wrote:...doing a complete removal via synaptic, deleting the ~/.config/Clementine directory, and reinstalling the latest version and i'm listening to ABBA via clemetine.


ABBA???

<shudder>


Where's that secret negative 1000 rep points button gone to? This will be your Waterloo!

Anyway, I don't think Warren will include Clementine instead of Amarok until it makes it into upstream Debian. There may some Debian Free Software Guideline license issue that keeps it in debian-multimedia. I know Deadbeef 0.5.0 dropped some plugins for this reason, so should appear in Debian sometime.

Edit: looks like it's getting close: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=579859
Last edited by Stevo on Wed Jun 01, 2011 11:21 pm, edited 2 times in total.
The optimist proclaims that we live in the best of all possible worlds, and the pessimist fears this is true.

James Branch Cabell


Return to “Package Status - 11.0”

Who is online

Users browsing this forum: Exabot [Bot] and 1 guest