Update to ffmpeg to 0.8!

News about updates on package status for CR packages compiled for MEPIS 11.0
Message
Author
User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11353
Age: 58
Joined: Fri Dec 15, 2006 8:07 pm

Update to ffmpeg to 0.8!

#1 Postby Stevo » Thu Mar 29, 2012 1:28 am

Now in the testing repo is an update from squeeze-backports to ffmpeg 0.8. Actually, the new source package is a branch of ffmpeg known as libav, and ffmpeg is just now a symlink to the actual avconv binary.

The newest release of VLC required this as needed to build against. We have seen in the past how updates to the ffmpeg libavcodec library have broken multimedia playback, but Tim & I have tested playback and some transcoding with Miro, Kdenlive, and Openshot, and they still seem to work. Recommended for transcoding is the restricted version with libfaac support, as most transcoding applications seem to use this for AAC audio encoding.( "-acodec libfaac") However, the built-in AAC encoder is much improved, but requires an addition on the command line: (-strict experimental -acodec aac")

If Miro is used for converting media, you'll have to edit as su the three files in /usr/share/miro/resources/conversions/ to use either libfaac, or aac as you see above.
The optimist proclaims that we live in the best of all possible worlds, and the pessimist fears this is true.

James Branch Cabell

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11353
Age: 58
Joined: Fri Dec 15, 2006 8:07 pm

Re: Update to ffmpeg to 0.8!

#2 Postby Stevo » Sat Apr 14, 2012 10:16 pm

There's now an update to 0.8.1 from Wheezy in the main testing CR, as well as a restricted version that uses libfaac. This update hopefully closes a lot of security issues.
The optimist proclaims that we live in the best of all possible worlds, and the pessimist fears this is true.

James Branch Cabell

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 11353
Age: 58
Joined: Fri Dec 15, 2006 8:07 pm

Re: Update to ffmpeg to 0.8!

#3 Postby Stevo » Mon Aug 27, 2012 8:33 pm

Bump: another update to libav/ffmpeg to 0.8.3 in the main testing repos fixes more security problems, and adds support for some more odd codecs. The dependencies were modified to allow it's libavcodec53 to coexist with even newer versions of ffmpeg/libav.

Though Debian upstream has only the libav branch up to 0.8.3, deb-multimedia has the ffmpeg branch version up to 0.11.1. I was able to build and install those packages, but only after messing with the 0.8 versions dependencies to let libavcodec53 coexist with libavcodec54. However, I found that some packages that build against the ffmpeg headers, such as libavcodec-dev, failed to build against the 0.11.1 headers....so will hold off on that upgrade. Ffmpeg 0.11.1 by itself works great as a convertor and playback library, though.
The optimist proclaims that we live in the best of all possible worlds, and the pessimist fears this is true.

James Branch Cabell


Return to “Package Status - 11.0”

Who is online

Users browsing this forum: No registered users and 1 guest