MEPIS Community Forum

A Linux operating system based on Debian Stable
View unanswered posts | View unsolved topics | View active topics |



Reply to topic  [ 31 posts ]  Go to page Previous  1, 2, 3, 4
Really slow boot up 
Author Message
Forum Novice
Forum  Novice

Joined: Fri Oct 15, 2010 12:15 pm
Posts: 44
Location: Washington State
Has thanked: 10 times
Have thanks: 2 times
Post # 298616
Post Re: Really slow boot up
lucky9 wrote:
Perhaps timkb4cq will give an explanation to us. But at the very least we'll know what to try next time!


timkb4cq wrote:
It's just a logical presumption.
Since the delay didn't show in the kernel log it had to occur before kernel logging started - and that starts very early in the process. The only big thing between grub and the run time kernel is the initrd so the problem almost had to be there.

Initrd is an initial ramdisk that allows drivers for devices not rolled into the kernel to load. A lot of linux drivers are built by default as modules including a lot of networking drivers. Without an initrd a network boot wouldn't work. But if there's a module set to load in the initrd that won't load for some reason you can have a problem and I think that's what has happened here. A driver is trying to load, not finding the expected hardware and finally timing out. It's almost certainly related to your usb cooler/hub which is being recognized as something it's not.


Your right that a driver was not finding the expected hardware, but it was not the cooler. The cooler receives it's power from the USB and provides a 3 port hub. Also the cooler was NOT connect until after the last install of Mepis/64. I just planned on using it and if I had to, live with the slow boot up. The reason I went with 64 was my brother says that the memory has really fast timings for a laptop, and would be fast timings for a desktop. With all the hardware tests that I did he rule out it being hardware and to try 64 as 32 may have an issue with the memory timings.

timkb4cq wrote:
I would try running dmeg in a Konsole terminal immediately before & immediately after plugging the cooler in to see how it's being recognized and what's trying to load. If you can isolate a driver and rebuild the initrd without that module the problem will go away.

Alternatively, it could be an IRQ collision with your usb controller and another device preventing devices from being properly recognized while building /dev
If your usb driver is in a kernel module, this would always happen with an initrd line present but without it the kernel wouldn't see the usb until later in the boot process.

Without more testing I couldn't say exactly what the issue is - but you can see the logic that led me to initrd.


I have the Repositories set as the default install but Prefer versions from: mepis. Some times I enable others, install what I want and then put it back to the default. Well, one of cr's had an xserver-xorg-video-nv update so I updated it and it added more than just the Nvida but I did it anyway.

When I edited the message.lst I just copied the first menu idem and added it and then deleted the initrd line, so my second menu has the initrd line there when I want it. The first boot using the initrd was still slow after the update, but the second time I tried it, it was like Normal boot up.

So the slow boot up is really fixed, not just a work around.

One last Idem. This laptop has 3 USB connections, 2 on the left side and one on the right side. I can connect the cooler or an USB mouse on the right side connection and the boot up is normal. Connect anything to either connection on the left side and the slow boot up is back. Don't know what the the difference between the connections are, just something to remember.
Thank all of you for the help.


Fri Apr 13, 2012 3:10 pm

towwire thanked by: lucky9
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 31 posts ]  Go to page Previous  1, 2, 3, 4

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.