MEPIS Community Forum

A Linux operating system based on Debian Stable
View unanswered posts | View unsolved topics | View active topics |



Reply to topic  [ 8 posts ] 
Mepis 11: Zim suddenly won't open, errors out 
Author Message
MEPIS Novice
MEPIS  Novice

Joined: Thu Dec 18, 2008 10:49 pm
Posts: 23
Location: Central Texas
Has thanked: 0 time
Have thanks: 0 time
Post # 298778
Post Mepis 11: Zim suddenly won't open, errors out
OS: Mepis 11 installed on a laptop. This error began yesterday on an existing long-time installation of Mepis 11 on this laptop, and has reappeared immediately after Mepis was reinstalled and re-updated today, including Zim.

The wiki editor Zim has been installed on Mepis 11 in my laptop for quite a while and never gave problems. Suddenly, yesterday, it would not open; trying in a terminal using $ zim yields this error message:
Code:
File system set to ASCII or Latin1, using UTF-8 instead.

The error appeared yesterday for the first time, and has reappeared today after a complete re-install/re-update of Mepis 11.

The following may or may not be relevant: Two months ago I installed PCLOS 2012.02 in another partition of this laptop. In previous times several other distros were installed in that partition. All my data files, including the ~/Notes file used by Zim, had been moved to a separate partition several years ago and linked back to the Mepis (or PCLOS or whatever), and this arrangement has worked without error until now. Zim appears to be the only application affected; Kmail, VirtualBox, Knotes, and xpad, have continued working correctly.

Also perhaps not relevant: The error does NOT affect Zim in Mepis 11 on my desktop machine; Zim on that machine is shared between Mepis 11 and Mint 12 KDE and works fine in both.

Is there any way I can get Zim working correctly again in Mepis on my laptop?

In faith, Dave
Viva Texas


Tue Apr 17, 2012 5:26 pm
Profile
MEPIS Novice
MEPIS  Novice

Joined: Tue Mar 23, 2010 1:04 pm
Posts: 69
Location: Utrecht, The Netherlands
Has thanked: 16 times
Have thanks: 13 times
Post # 298846
Post Re: Mepis 11: Zim suddenly won't open, errors out
When I start Zim (0.55) from the command line, I also get that error/warning:

Code:
WARNING: Filesystem encoding is set to ASCII or Latin1, using UTF-8 instead


...and Zim works fine for me. So the question seems to be what the real cause is that Zim doesn't work for you. Are you using the (older) version from the Squeeze repositories (0.48-1) or a newer one downloaded from zim-wiki.org? In the latter case, are all dependencies still met?

_________________
HP Probook 4310s - Intel Core2 Duo T6670, 3GB memory, Intel GMA 4500MHD grapics, Intel wifi - MEPIS 11 (32 bits), kernel 2.6.36-1-mepis-smp, KDE 4.7.4


Thu Apr 19, 2012 8:04 pm
Profile
MEPIS Novice
MEPIS  Novice

Joined: Thu Dec 18, 2008 10:49 pm
Posts: 23
Location: Central Texas
Has thanked: 0 time
Have thanks: 0 time
Post # 298878
Post Re: Mepis 11: Zim suddenly won't open, errors out
That's what puzzles me - Zim has worked fine for me in Mepis all this time. Now it quits.

I didn't mention that I'm using the 32-bit version of Mepis 11. Zim's version in Mepis is 0.48. It must be the squeeze version (my repos are mepis 11, squeeze, squeeze-updates, mepis11cr, and opera-stable). I've used these repos for all the length of time I've used Mepis and Zim.

I deleted and then re-installed Zim using Synaptic, and there was no mention of any dependencies.

When I try and run Zim from command line, it gives me that error message but then does NOT run. From the menu launcher, I only get a bouncing Zim icon which then goes dead.

I would suspect the fact that I am running Zim through a link to its data files on the separate partition - except it has been working fine that way for a long time.

In faith, Dave
Viva Texas

Take the Pepsi challenge -- choose Linux.


Fri Apr 20, 2012 4:13 pm
Profile
MEPIS Novice
MEPIS  Novice

Joined: Tue Mar 23, 2010 1:04 pm
Posts: 69
Location: Utrecht, The Netherlands
Has thanked: 16 times
Have thanks: 13 times
Post # 298942
Post Re: Mepis 11: Zim suddenly won't open, errors out
You could try "verbose":

zim -V

or debug mode:

zim -D

Hopefully that will reveal more about the problem.

All options can be shown with:

zim --help

_________________
HP Probook 4310s - Intel Core2 Duo T6670, 3GB memory, Intel GMA 4500MHD grapics, Intel wifi - MEPIS 11 (32 bits), kernel 2.6.36-1-mepis-smp, KDE 4.7.4


Sun Apr 22, 2012 3:55 pm
Profile
MEPIS Novice
MEPIS  Novice

Joined: Thu Dec 18, 2008 10:49 pm
Posts: 23
Location: Central Texas
Has thanked: 0 time
Have thanks: 0 time
Post # 299086
Post Re: Mepis 11: Zim suddenly won't open, errors out
Arjen: I've tried to run Zim using the -V and -D operators. Here are the results:

Zim -V:
Code:
dave@laptop-host-mepis:~$ zim -V
WARNING: Filesystem encoding is set to ASCII or Latin1, using UTF-8 instead
INFO: This is zim 0.48
INFO: Opening default notebook
INFO: Starting UnixSocketDaemon
dave@laptop-host-mepis:~$ ERROR: Failed to load plugin versioncontrol
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/zim/__init__.py", line 377, in load_plugin
    raise AssertionError, 'Dependencies failed for plugin %s' % name
AssertionError: Dependencies failed for plugin versioncontrol
INFO: Starting background index update
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/zim/gui/__init__.py", line 1900, in do_open_notebook
    self.set_toolbar_style(self.uistate['toolbar_style'])
  File "/usr/lib/pymodules/python2.6/zim/gui/__init__.py", line 1813, in set_toolbar_style
    assert style in ('icons_and_text', 'icons_only', 'text_only'), style
AssertionError
ERROR: Error in child main:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/zim/daemon.py", line 541, in spawn
    self._main()
  File "/usr/lib/pymodules/python2.6/zim/daemon.py", line 585, in _main
    obj.main()
  File "/usr/lib/pymodules/python2.6/zim/gui/__init__.py", line 470, in main
    path = self.history.get_current()
  File "/usr/lib/pymodules/python2.6/zim/history.py", line 129, in get_current
    return HistoryRecord(self, self.current)
  File "/usr/lib/pymodules/python2.6/zim/history.py", line 34, in __init__
    Path.__init__(self, history.history[i])
IndexError: list index out of range
INFO: Last instance quit - exiting daemon
INFO: Stopped UnixSocketDaemon

Zim -D:
Code:
dave@laptop-host-mepis:~$ zim -D
WARNING: Filesystem encoding is set to ASCII or Latin1, using UTF-8 instead
INFO: This is zim 0.48
DEBUG: Python version is (2, 6, 6, 'final', 0)
DEBUG: Platform is posix
DEBUG: Zim revision is:
        branch: pyzim-trunk
        revision: 290 pardus@cpan.org-20100722213310-1qj38a5ozyxy06ya
        date: 2010-07-22 23:33:10 +0200

DEBUG: Not running from a source dir
DEBUG: Set XDG_DATA_HOME to /home/dave/.local/share
DEBUG: Set XDG_DATA_DIRS to [<Dir: /usr/share>, <Dir: /usr/share>, <Dir: /usr/local/share>]
DEBUG: Set XDG_CONFIG_HOME to /home/dave/.config
DEBUG: Set XDG_CONFIG_DIRS to [<Dir: /etc/xdg>]
DEBUG: Set XDG_CACHE_HOME to /home/dave/.cache
DEBUG: Running command: gui
DEBUG: Cache dir: /home/dave/Notes/.zim
DEBUG: Loading /home/dave/Notes/notebook.zim
DEBUG: Index database file: /home/dave/Notes/.zim/index.db
INFO: Opening default notebook
INFO: Starting UnixSocketDaemon
DEBUG: Socket address: /tmp/zim-dave/daemon-socket
DEBUG: Wrote /tmp/zim-dave/daemon.pid
DEBUG: Sending to daemon: ["ping",[],{}]

DEBUG: Daemon replied: "Ack"
DEBUG: Sending to daemon: ["vivicate",["zim.gui.GtkInterface","file:///home/dave/Notes"],{"usedaemon":true,"notebook":"file:///home/dave/Notes"}]

DEBUG: Child spawned 2314 (u'zim.gui.GtkInterface', u'file:///home/dave/Notes')
DEBUG: No such signal: notebook-list-changed
DEBUG: Daemon replied: true
DEBUG: Sending to daemon: ["relay",[["zim.gui.GtkInterface","file:///home/dave/Notes"],"present",null],{"geometry":null,"fullscreen":null}]

DEBUG: Sending to child 2314: ["present",[null],{"geometry":null,"fullscreen":null}]

DEBUG: Daemon replied: true
dave@laptop-host-mepis:~$ DEBUG: Loading /home/dave/.config/zim/preferences.conf
DEBUG: Gtk version is (2, 20, 1)
DEBUG: Pygtk version is (2, 17, 0)
DEBUG: Loading /usr/share/zim/applications/firefox.desktop
DEBUG: Loading /usr/share/zim/applications/thunderbird.desktop
DEBUG: Loading /usr/share/zim/applications/xdg-email.desktop
DEBUG: Loading /usr/share/zim/applications/xdg-open.desktop
DEBUG: Loading /usr/share/zim/applications/firefox.desktop
DEBUG: Loading /usr/share/zim/applications/thunderbird.desktop
DEBUG: Loading /usr/share/zim/applications/xdg-email.desktop
DEBUG: Loading /usr/share/zim/applications/xdg-open.desktop
DEBUG: Loading /usr/share/zim/applications/firefox.desktop
DEBUG: Loading /usr/share/zim/applications/thunderbird.desktop
DEBUG: Loading /usr/share/zim/applications/xdg-email.desktop
DEBUG: Loading /usr/share/zim/applications/xdg-open.desktop
DEBUG: Loading /home/dave/.config/zim/style.conf
DEBUG: File not found, loading /usr/share/zim/style.conf
DEBUG: Loaded plugin calendar (<CalendarPlugin object at 0x9c0e39c (zim+plugins+PluginClass at 0x9c65ea0)>)
DEBUG: Loaded plugin insertsymbol (<CalendarPlugin object at 0x9c12194 (zim+plugins+PluginClass at 0x9c60400)>)
DEBUG: Loaded plugin printtobrowser (<PrintToBrowserPlugin object at 0x9c127d4 (zim+plugins+PluginClass at 0x9c60690)>)
ERROR: Failed to load plugin versioncontrol
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/zim/__init__.py", line 377, in load_plugin
    raise AssertionError, 'Dependencies failed for plugin %s' % name
AssertionError: Dependencies failed for plugin versioncontrol
DEBUG: Accelmap: /home/dave/.config/zim/accelmap
DEBUG: Opening notebook: file:///home/dave/Notes
DEBUG: Cache dir: /home/dave/Notes/.zim
DEBUG: Loading /home/dave/Notes/notebook.zim
DEBUG: Index database file: /home/dave/Notes/.zim/index.db
DEBUG: Loading /home/dave/Notes/.zim/state.conf
INFO: Starting background index update
DEBUG: Action: toggle_sidepane
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/zim/gui/__init__.py", line 1900, in do_open_notebook
    self.set_toolbar_style(self.uistate['toolbar_style'])
  File "/usr/lib/pymodules/python2.6/zim/gui/__init__.py", line 1813, in set_toolbar_style
    assert style in ('icons_and_text', 'icons_only', 'text_only'), style
AssertionError
ERROR: Error in child main:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/zim/daemon.py", line 541, in spawn
    self._main()
  File "/usr/lib/pymodules/python2.6/zim/daemon.py", line 585, in _main
    obj.main()
  File "/usr/lib/pymodules/python2.6/zim/gui/__init__.py", line 470, in main
    path = self.history.get_current()
  File "/usr/lib/pymodules/python2.6/zim/history.py", line 129, in get_current
    return HistoryRecord(self, self.current)
  File "/usr/lib/pymodules/python2.6/zim/history.py", line 34, in __init__
    Path.__init__(self, history.history[i])
IndexError: list index out of range
DEBUG: Child exited 2314 (u'zim.gui.GtkInterface', u'file:///home/dave/Notes')
INFO: Last instance quit - exiting daemon
INFO: Stopped UnixSocketDaemon

I didn't see anything having to do with the text coding, but I don't know what I'm looking at anyway. I hope this will give you a clue.

In faith, Dave
Viva Texas


Wed Apr 25, 2012 7:10 pm
Profile
MEPIS Novice
MEPIS  Novice

Joined: Tue Mar 23, 2010 1:04 pm
Posts: 69
Location: Utrecht, The Netherlands
Has thanked: 16 times
Have thanks: 13 times
Post # 299090
Post Re: Mepis 11: Zim suddenly won't open, errors out
Hi Dave,

The error:
Code:
Dependencies failed for plugin versioncontrol

means that the version control plugin cannot find the program it depends on, which is bzr (Bazaar version control).

So you need to either install bzr through Synaptic (if you want to use version control) or disable the plugin (menu Edit > Preferences > Plugins and uncheck Version Control).

Still it would have been much politer if Zim had detected the missing dependency without crashing... :-)

Hope this helps!

PS: there is another error ("ERROR: Error in child main") but I assume/hope this is related to the dependency error.

_________________
HP Probook 4310s - Intel Core2 Duo T6670, 3GB memory, Intel GMA 4500MHD grapics, Intel wifi - MEPIS 11 (32 bits), kernel 2.6.36-1-mepis-smp, KDE 4.7.4


Wed Apr 25, 2012 8:11 pm
Profile
MEPIS Novice
MEPIS  Novice

Joined: Thu Dec 18, 2008 10:49 pm
Posts: 23
Location: Central Texas
Has thanked: 0 time
Have thanks: 0 time
Post # 299199
Post Re: Mepis 11: Zim suddenly won't open, errors out
Hi Arjen. I installed bzr, but Zim won't open while linked to the Notes directory in my data partition. I unchecked 'Version Control' and Zim still won't open (I had to let it make its own Notes directory, open Zim, and uncheck Version Control, then re-establish the linked Notes directory, restart Zim, and then it wouldn't open).

One consistent thing in this, is that Zim in Mepis will run if it is connected to its own Notes directory, but not if it's linked to the Notes directory in my data partition. It used to run fine linked, but stopped suddenly at an upgrade of Mepis. All my other distros run Zim fine linked to the data partition. Was there something in a recent upgrade that has bollixed Zim?

In faith, Dave
Viva Texas


Fri Apr 27, 2012 2:55 pm
Profile
MEPIS Novice
MEPIS  Novice

Joined: Tue Mar 23, 2010 1:04 pm
Posts: 69
Location: Utrecht, The Netherlands
Has thanked: 16 times
Have thanks: 13 times
Post # 299273
Post Re: Mepis 11: Zim suddenly won't open, errors out
OK... Are you sure you're using the same version of Zim on all distros? Could it be that the version on Mepis is older? In that case it could be that it doesn't recognize its settings from a newer version. (Just a guess.)

_________________
HP Probook 4310s - Intel Core2 Duo T6670, 3GB memory, Intel GMA 4500MHD grapics, Intel wifi - MEPIS 11 (32 bits), kernel 2.6.36-1-mepis-smp, KDE 4.7.4


Sun Apr 29, 2012 7:04 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.