Funky Firefox Fonts

Help for Mepis 11
Message
Author
User avatar
uncle mark
Forum Veteran
Forum Veteran
Posts: 5360
Age: 2015
Joined: Sat Nov 11, 2006 10:42 pm

Re: Funky Firefox Fonts

#11 Postby uncle mark » Mon May 14, 2012 6:05 pm

freetype 2.4.2-2.1+squeeze4 is installed, which is the same as what is listed in your link. I can only assume that if it was updated recently I got it. I normally hold off for a few days to see if anyone posts about a problem. I did the last round of updates a couple days ago. I'm embarrassed to admit I don't know how to determine when it was installed, nor do I know how to roll it back.

And another borken Vi$ta machine is head my way. When it rains, it pours.
Desktop: Custom build Asus/AMD/nVidia -- MX-15 KDE, MEPIS 11
Laptop: Acer Aspire 5250 -- MX-15

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 15202
Joined: Wed Jul 19, 2006 6:13 am

Re: Funky Firefox Fonts

#12 Postby Jerry3904 » Mon May 14, 2012 6:08 pm

I'm embarrassed to admit 1) I don't know how to determine when it was installed, nor do I know 2) how to roll it back.
First: open Synaptic, File > History. Second, highlight the file, then Package > Force Version.
Production: 4.2.0-0.bpo.1-amd64, MX-15 RC1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 3.16-0-4-686-pae. MX-15, AMD C-60 APU, 4 GB

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9016
Age: 58
Joined: Wed Jul 12, 2006 2:26 pm

Re: Funky Firefox Fonts

#13 Postby kmathern » Mon May 14, 2012 6:17 pm

uncle mark wrote:freetype 2.4.2-2.1+squeeze4 is installed, which is the same as what is listed in your link. I can only assume that if it was updated recently I got it. I normally hold off for a few days to see if anyone posts about a problem. I did the last round of updates a couple days ago. I'm embarrassed to admit I don't know how to determine when it was installed, nor do I know how to roll it back.

And another borken Vi$ta machine is head my way. When it rains, it pours.

I use the command below to check my history of package installs, upgrades, removals, etc. You can remove the 'less' at the end and add a 'grep freetype' {without quotes} if you just want freetype related changes.

I prefer my command to check the history with instead of Synaptic's because I use other package management tools than just Synaptic (apt-get, aptitude, gdebi and dpkg) and their changes aren't included in Synaptic's history.

Code: Select all

zgrep -H ' install \| upgrade \| remove \| purge ' /var/log/dpkg*|cut -f2- -d:|sort -r|sed 's/remove/remove / ; s/purge/purge  /'|less
Editted 2012-05-19, added -H zgrep option so the command will work correctly with newer installs {those less than a month old}
Last edited by kmathern on Sat May 19, 2012 10:03 pm, edited 2 times in total.

User avatar
uncle mark
Forum Veteran
Forum Veteran
Posts: 5360
Age: 2015
Joined: Sat Nov 11, 2006 10:42 pm

Re: Funky Firefox Fonts

#14 Postby uncle mark » Mon May 14, 2012 7:55 pm

libfreetype6 updated to current version on 3-9-12. This cropped up more recently than that.
Desktop: Custom build Asus/AMD/nVidia -- MX-15 KDE, MEPIS 11
Laptop: Acer Aspire 5250 -- MX-15

User avatar
uncle mark
Forum Veteran
Forum Veteran
Posts: 5360
Age: 2015
Joined: Sat Nov 11, 2006 10:42 pm

Re: Funky Firefox Fonts

#15 Postby uncle mark » Tue May 15, 2012 12:08 pm

Home for lunch, and am not seeing the anomaly now.

I'm thinking I may have different issues unrelated to software. Thinking maybe heat on the graphics card. Need to crack the case and do a little cleaning anyway... Or maybe a monitor that's going south. The two 19" Dell LCDs I'm using are several years old, and they were hand-me-downs when I got them. There's been a time or two before when I got some odd behavior out of them, but they had a miraculous spontaneous recovery. <shrug>
Desktop: Custom build Asus/AMD/nVidia -- MX-15 KDE, MEPIS 11
Laptop: Acer Aspire 5250 -- MX-15

User avatar
uncle mark
Forum Veteran
Forum Veteran
Posts: 5360
Age: 2015
Joined: Sat Nov 11, 2006 10:42 pm

Re: Funky Firefox Fonts

#16 Postby uncle mark » Wed May 16, 2012 6:09 pm

I've marked this as solved, although I didn't really do anything. I do have an idea now of what was going on. I think. Not sure. But it's all I can come up with.

One of my home tabs in Firefox is APOD:

http://apod.nasa.gov/apod/

The other day, instead of a picture, it had an embedded video. On occasion, I've run into situations where an embedded video on a web page will cause a variety of weirdness, with artifacts and ghosts and just plain goofy stuff going on. Always before, exiting the page or closing and restarting Firefox or restarting X or rebooting fixed the weirdness and it didn't reoccur -- but then again I didn't go back to that same web page, either. In this case, every time I reopened Firefox, that page was opening again. Even though it was in the background, I think it was the root of the trouble. The next day, when the APOD page changed, the funky fonts went away.

Just posting this as a data point.
Desktop: Custom build Asus/AMD/nVidia -- MX-15 KDE, MEPIS 11
Laptop: Acer Aspire 5250 -- MX-15

User avatar
Gaer Boy
Forum Guide
Forum Guide
Posts: 1962
Age: 80
Joined: Sat Jun 06, 2009 6:06 am

Re: Funky Firefox Fonts

#17 Postby Gaer Boy » Thu May 17, 2012 9:44 am

I also have APOD as a home page. There have been a couple of videos recently, but none of them have caused me any problem with Firefox. I am running Nightly (15.0a1 today)

Phil

AsRock FM2A88X-ITX+, A8-6500, 8GB, 120GB Samsung SSD (GPT), 1TB HDD (MBR), MX-15, MX-14.4
Acer Aspire One 150, Atom N270, 120GB HDD, MX-14.3

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 15202
Joined: Wed Jul 19, 2006 6:13 am

Re: Funky Firefox Fonts

#18 Postby Jerry3904 » Thu May 17, 2012 9:59 am

Causes me no trouble either--beautiful image today!--but I am on the Beta channel so am running the current Firefox 12.
Production: 4.2.0-0.bpo.1-amd64, MX-15 RC1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 3.16-0-4-686-pae. MX-15, AMD C-60 APU, 4 GB


Return to “Mepis 11”

Who is online

Users browsing this forum: No registered users and 2 guests