MEPIS Community Forum

A Linux operating system based on Debian Stable
View unanswered posts | View unsolved topics | View active topics |



Reply to topic  [ 35 posts ]  Go to page Previous  1, 2, 3, 4  Next
LiveDVD + first install black screen on ATI HD 4200 
Author Message
Forum Guide
Forum Guide

Joined: Tue Jul 25, 2006 12:47 pm
Posts: 1451
Location: Savannah, GA
Has thanked: 85 times
Have thanks: 287 times
Post # 300536
Post Re: LiveDVD + first install black screen on ATI HD 4200
Paul771:

You may want to try using these cheatcodes at the Grub Boot Prompt:

nouveau.modeset=0 xdrvr=intel confx

If that doesn't work, try this instead and see what happens:

nvidia-modeset=0 xdrvr=intel confx

You've got a laptop model using what's referred to as Optimus, where the graphics switches between Intel and Nvidia depending on what you're doing.

But, Mepis 11 doesn't support that configuration yet with the stock kernel and drivers. So, that work around should force it to use the Intel graphics driver only (hopefully, anyway).

See this thread for an example of issues some users have with that type of setup (and there may be some newer threads with better solutions around).

viewtopic.php?f=84&t=31982

Note, that you may want to start a new thread asking about your issues, so that we're not discussing more than one problem in this thread (which was started by someone needing help getting integrated Radeon HD 4200 graphics to work).

Then, perhaps some of our members using laptops with Optimus technology will see it and chime in with solutions they've found works better with Optimus (as updating to a newer kernel and drivers may help out with the issues)


Wed May 30, 2012 1:40 pm
Profile
Forum Novice
Forum  Novice
User avatar

Joined: Wed May 30, 2012 10:46 am
Posts: 8
Has thanked: 0 time
Have thanks: 0 time
Post # 300538
Post Re: LiveDVD + first install black screen on ATI HD 4200
JimC wrote:
Paul771: ...

Then, perhaps some of our members using laptops with Optimus technology will see it and chime in with solutions they've found works better with Optimus (as updating to a newer kernel and drivers may help out with the issues)
Thks, you are perfectly right and I continue here


Wed May 30, 2012 1:57 pm
Profile
Forum Novice
Forum  Novice

Joined: Mon May 28, 2012 9:35 pm
Posts: 14
Has thanked: 6 times
Have thanks: 2 times
Post # 300539
Post Re: LiveDVD + first install black screen on ATI HD 4200  [Solved]
I think everyone would need to know if you're using that intel card to boot or you are trying to boot with the NVIDIA GEForce GT 540M. Each solution is a little different.
unless this is a laptop with Optimus mode. in which case the following setting on the command line should do the trick

nouveau.modeset=0 xdrvr=intel confx


Oh, and in regards to my issue, problem solved. thanks for all your help.
installation complete, drivers are in and working. I am a happy camper.
Thanks again for all your support.


Wed May 30, 2012 2:24 pm
Profile
Administrator
User avatar

Joined: Wed Jul 12, 2006 2:17 pm
Posts: 10690
Location: Rochester NY
Has thanked: 835 times
Have thanks: 1433 times
Post # 300540
Post Re: LiveDVD + first install black screen on ATI HD 4200
This is what I did for an Nvidia Optimus Laptop: Acer 5750-G
1. Disabled the Nvidia board in the BIOS
2. Added xdrvr=intel confx to the boot menu on the LiveDVD.
3. Booted and installed
4. Installed the latest xorg from Squeeze backports
5. Upgraded the kernel to a 3 series.
6.Ran sgfxi.

Compositing works fine with the Intel graphics, very fast and no errors.

_________________
Forum Rules
Guide - How to Ask for Help
Link to Wiki
Rich

Acer Laptop V5-572G: Intel i5, 12 GIG mem, nVidia GT720M/Intel integrated graphics
Mx-14 Symbiosis
Kubuntu 13.10, KDE 4.11.2


Wed May 30, 2012 2:25 pm
Profile
Forum Novice
Forum  Novice
User avatar

Joined: Wed May 30, 2012 10:46 am
Posts: 8
Has thanked: 0 time
Have thanks: 0 time
Post # 300542
Post Re: LiveDVD + first install black screen on ATI HD 4200
richb wrote:
This is what I did for an Nvidia Optimus Laptop: Acer 5750-G
1. Disabled the Nvidia board in the BIOS
2. Added xdrvr=intel confx to the boot menu on the LiveDVD.
3. Booted and installed
4. Installed the latest xorg from Squeeze backports
5. Upgraded the kernel to a 3 series.
6.Ran sgfxi.

Compositing works fine with the Intel graphics, very fast and no errors.
Unfortunately my BIOS doesn't allow this manip. (it nearly allows nothing)


Wed May 30, 2012 2:36 pm
Profile
Forum Regular
Forum Regular
User avatar

Joined: Sat Jul 15, 2006 4:47 am
Posts: 298
Has thanked: 47 times
Have thanks: 20 times
Post # 300543
Post Re: LiveDVD + first install black screen on ATI HD 4200
My BIOS is effectively the same (Intel + ATI Radeon). The options are 'switchable graphics' or 'UMA'.

Haven't fathomed out UMA yet.

_________________
Asus K55A i7 laptop 6GB RAM, 500GB SATA HDD, turbo-boost 3.1Ghz::
Win7 64 bit - eek!::
Intel graphics, UEFI and GPT::
HP Deskjet 3050 wireless::
Image


Wed May 30, 2012 2:45 pm
Profile
Administrator
User avatar

Joined: Wed Jul 12, 2006 2:17 pm
Posts: 10690
Location: Rochester NY
Has thanked: 835 times
Have thanks: 1433 times
Post # 300544
Post Re: LiveDVD + first install black screen on ATI HD 4200
matelot wrote:
My BIOS is effectively the same (Intel + ATI Radeon). The options are 'switchable graphics' or 'UMA'.

Haven't fathomed out UMA yet.

Unified Memory Architecture,

http://uk.answers.yahoo.com/question/in ... 035AA1DRs2

Basically an integrated card sharing system memory.

_________________
Forum Rules
Guide - How to Ask for Help
Link to Wiki
Rich

Acer Laptop V5-572G: Intel i5, 12 GIG mem, nVidia GT720M/Intel integrated graphics
Mx-14 Symbiosis
Kubuntu 13.10, KDE 4.11.2


Wed May 30, 2012 2:59 pm
Profile
Forum Veteran
Forum Veteran
User avatar

Joined: Sat Nov 11, 2006 10:42 pm
Posts: 4445
Has thanked: 123 times
Have thanks: 910 times
Post # 300550
Post Re: LiveDVD + first install black screen on ATI HD 4200
MikeyD wrote:
Oh, and in regards to my issue, problem solved. thanks for all your help.
installation complete, drivers are in and working. I am a happy camper.
Thanks again for all your support.


Was running sgfxi the second time what did the trick?

_________________
Desktop: Custom build Asus/AMD/nVidia -- MEPIS 11
Netbook: Fujitsu Lifebook Pentium M -- MX-14
Laptop: Acer Aspire 5250 AMD Dual -- SolydK 64


Wed May 30, 2012 4:09 pm

uncle mark thanked by: MikeyD
Profile
Forum Novice
Forum  Novice

Joined: Mon May 28, 2012 9:35 pm
Posts: 14
Has thanked: 6 times
Have thanks: 2 times
Post # 300559
Post Re: LiveDVD + first install black screen on ATI HD 4200
uncle mark wrote:
Was running sgfxi the second time what did the trick?


no not exatly.

since I learned what I needed to do and messed things up by using smxi I decided to start over and do it right. It is a fresh install after all.

Booted the LiveDVD by changing vga=788 to vga-873 in GRUB
installed then booted the installation by adding radeon.modeset=0 in GRUB
Ran synaptic to update everything then downloaded and ran flgrx to install video drivers correctly. (I should have done that the first time)
Then tested and saw a problem with synaptic and anything requiring root.
Rebooted from cold boot and confirmed everything is working now.

I did notice a few problems with this edition, but nothing that I didn't notice on the liveCD.
I'll save up those notes and make it another post on another day.

I'm just glad to have my taskcoach installed and I can start working on my task list for my new project.
The purpose of setting up this laptop in the first place.

Thanks again for all the help


Thu May 31, 2012 12:08 am
Profile
Forum Novice
Forum  Novice
User avatar

Joined: Wed May 30, 2012 10:46 am
Posts: 8
Has thanked: 0 time
Have thanks: 0 time
Post # 300561
Post Re: LiveDVD + first install black screen on ATI HD 4200
matelot wrote:
My BIOS is effectively the same (Intel + ATI Radeon). The options are 'switchable graphics' or 'UMA'.

Haven't fathomed out UMA yet.
Hello

This option is not available in my BIOS (Asus X73S).

Thks.


Thu May 31, 2012 1:14 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 35 posts ]  Go to page Previous  1, 2, 3, 4  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.