MX & MEPIS Community Forum

Linux operating systems based on Debian Stable
View unanswered posts | View unsolved topics | View active topics |



Reply to topic  [ 18 posts ]  Go to page 1, 2  Next
M!! Time Problem 
Author Message
Forum Regular
Forum Regular
User avatar

Joined: Sun Feb 10, 2008 5:37 pm
Posts: 754
Location: Arab, Alabama
Has thanked: 109 times
Have thanks: 37 times
Post # 301076
Post M!! Time Problem  [Solved]
I have a time problem that has me stumped. In our community lab we have dual boot Win7 & Mepis PC's. Our MOBO's are Asus F1A75-V Pro with the new UEFI bios and we are running Mepis11. When we log out of Mepis the BIOS time gets set 5 hours later. Mepis doesn't have a problem with that and I didn't notice that as it gets the correct time from the internet as soon as we logon. But Windows doesn't change the time and shows the wrong time. When we reset the time correctly it stays OK until the next time we run Mepis. When I installed Mepis I am pretty sure I picked the Chicago, central time zone. And when I checked, the correct time zone is shown, Chicago (central time), but upon shutdown the time in the BIOS is reset 5 hours ahead. That five hour difference is the difference between US Central time zone and GMT. Is there some other setting I should look at? Or is there some setting in the BIOS that I seem to be overlooking? The only thing I can remember seeing in the BIOS is the time itself. TIA

_________________
Mepis11 & MX14 MoBo ASUS M4A88TD-V EVO/USB3 CPU AMD Phenom II X4 945 PSU CORSAIR CX500 (CMPSU-500CX) RAM Crucial CT2KIT25664BA1339 HD WD5000AAKX Wireless EDIMAX EW 7128g


Fri Jun 08, 2012 12:53 pm
Profile
Forum Guide
Forum Guide
User avatar

Joined: Sat Jun 06, 2009 6:06 am
Posts: 1520
Location: Bristol, UK
Has thanked: 442 times
Have thanks: 326 times
Post # 301077
Post Re: M!! Time Problem
I was going to respond by saying that I run dual boot WinXP and Mepis, and have not had a problem with the time since I started. I know I had to set things up on Mepis installation, but I can't remember the critical step.

Then I noticed that my system clock and Mepis time were way out - I expect an hour, because my time setting on the forum is UTC and we have summer time at present. But the forum is running 10 mins behind that. Just to check, I will post this at 18:17 BST (17:17 UTC) precisely.

Phil

_________________

AsRock FM2A88X-ITX+, A8-6500, 8GB, 120GB Samsung SSD, 1TB HDD, MX-14.
Asus M4A88TD-V EVO/USB3, Phenom II X2 550 BE (now X3), 8GB.
120GB Corsair SSD, 500+250GB HDD, MX-14, Mepis 11.9.92-64.
Acer Aspire One 150, Atom N270, 120GB HDD, MX-14 / WinXP


Fri Jun 08, 2012 1:05 pm
Profile
Forum Guide
Forum Guide
User avatar

Joined: Mon Jun 30, 2008 8:06 pm
Posts: 2952
Has thanked: 52 times
Have thanks: 376 times
Post # 301078
Post Re: M!! Time Problem
bios battery is likely dying. you can also install ntp to auto adjust the clocks. i found i had to also installed ntpdate. this combo will go out to an atomic clock and grab the current time.


Fri Jun 08, 2012 1:20 pm
Profile
Forum Veteran
Forum Veteran
User avatar

Joined: Wed Jul 12, 2006 2:26 pm
Posts: 7208
Has thanked: 399 times
Have thanks: 2359 times
Post # 301079
Post Re: M!! Time Problem
In the /etc/default/rcS file check that it's set to 'UTC=no' {without the quotes}

You can edit /etc/default/rcS by simultaneously pressing Alt+F2, then type in: kdesu kwrite /etc/default/rcS (enter root password when requested)



{In M12 it would be nice to have a UTC checkbox in the MEPIS System Assistant}


Fri Jun 08, 2012 1:32 pm

kmathern thanked by: kumar, Topher
Profile
Forum Guide
Forum Guide
User avatar

Joined: Sat Jun 06, 2009 6:06 am
Posts: 1520
Location: Bristol, UK
Has thanked: 442 times
Have thanks: 326 times
Post # 301081
Post Re: M!! Time Problem
kmathern wrote:
In the /etc/default/rcS file check that it's set to 'UTC=no' {without the quotes}
I seem to remember that there's a question that implies that alternative during installation.

Meanwhile, the Mepis forum time continues 12 minutes behind real time.

Phil

_________________

AsRock FM2A88X-ITX+, A8-6500, 8GB, 120GB Samsung SSD, 1TB HDD, MX-14.
Asus M4A88TD-V EVO/USB3, Phenom II X2 550 BE (now X3), 8GB.
120GB Corsair SSD, 500+250GB HDD, MX-14, Mepis 11.9.92-64.
Acer Aspire One 150, Atom N270, 120GB HDD, MX-14 / WinXP


Fri Jun 08, 2012 1:44 pm
Profile
Forum Regular
Forum Regular
User avatar

Joined: Sun Feb 10, 2008 5:37 pm
Posts: 754
Location: Arab, Alabama
Has thanked: 109 times
Have thanks: 37 times
Post # 301084
Post Re: M!! Time Problem
Quote:
In the /etc/default/rcS file check that it's set to 'UTC=no' {without the quotes}

I'll check that file Monday when I go in - thanks.

_________________
Mepis11 & MX14 MoBo ASUS M4A88TD-V EVO/USB3 CPU AMD Phenom II X4 945 PSU CORSAIR CX500 (CMPSU-500CX) RAM Crucial CT2KIT25664BA1339 HD WD5000AAKX Wireless EDIMAX EW 7128g


Fri Jun 08, 2012 1:59 pm
Profile
Forum Veteran
Forum Veteran
User avatar

Joined: Wed Jul 12, 2006 2:26 pm
Posts: 7208
Has thanked: 399 times
Have thanks: 2359 times
Post # 301086
Post Re: M!! Time Problem
Gaer Boy wrote:
kmathern wrote:
In the /etc/default/rcS file check that it's set to 'UTC=no' {without the quotes}
I seem to remember that there's a question that implies that alternative during installation.

Meanwhile, the Mepis forum time continues 12 minutes behind real time.

Phil

There is a question about it while running the installer, I forget what it defaults to if you just press 'Enter' .



Btw, the UTC setting has been removed from the /etc/default/rcS file in sid {and probably wheezy as well}.
Quote:

snippet from man:rcS

... The UTC setting is replaced by the UTC or LOCAL setting in /etc/adjtime, and should have been migrated automatically.
See hwclock(5) and hwclock(8) for further details on configuring the system clock.

fine print: this doesn't apply to Mepis 11.0 but will when Mepis 12 comes out


Fri Jun 08, 2012 2:03 pm
Profile
Forum Veteran
Forum Veteran
User avatar

Joined: Sat Nov 11, 2006 10:42 pm
Posts: 4479
Has thanked: 128 times
Have thanks: 918 times
Post # 301097
Post Re: M!! Time Problem
I believe the key is to have the bios set to local time. I've never had that issue when the bios is set to local time, then re-setting the time and time zone settings in both Win and Lin. In MEPIS, you'll need to do it through the System Settings dialog as root, and the first time you change it it might not stick. I've had to fight it on occasion.

The problem seems to be that Win assumes that the machine bios is set to local time, while unless told otherwise, Lin thinks it's set to UTC.

_________________
Desktop: Custom build Asus/AMD/nVidia -- MEPIS 11
Netbook: Fujitsu Lifebook Pentium M -- MX-14
Laptop: Acer Aspire 5250 AMD Dual -- SolydK 64


Fri Jun 08, 2012 3:14 pm
Profile
Forum Guide
Forum Guide
User avatar

Joined: Sat May 16, 2009 3:59 pm
Posts: 2902
Has thanked: 421 times
Have thanks: 446 times
Post # 301099
Post Re: M!! Time Problem
kmathern wrote:
snippet from man:rcS

... The UTC setting is replaced by the UTC or LOCAL setting in /etc/adjtime, and should have been migrated automatically.
See hwclock(5) and hwclock(8) for further details on configuring the system clock.

From Wheezy's /etc/default/rcS:

Quote:
# assume that the BIOS clock is set to UTC time (recommended)
#UTC=no # OBSOLETE; see /etc/adjtime and hwclock(8).

_________________
Gigabyte 990FXA-UD3, AMD FX-6100 hex-core, 3.3GHz, Radeon HD6570
Gigabyte A55M-DS2, AMD A4-3400 dual-core APU (llano), 2.7 GHz, Radeon HD graphics
IBM ThinkPad T43, Intel Pentium M, 1.73GHz, Intel chipset


Fri Jun 08, 2012 3:20 pm
Profile
Forum Veteran
Forum Veteran
User avatar

Joined: Wed Jul 12, 2006 2:26 pm
Posts: 7208
Has thanked: 399 times
Have thanks: 2359 times
Post # 301100
Post Re: M!! Time Problem
DBeckett wrote:
kmathern wrote:
snippet from man:rcS

... The UTC setting is replaced by the UTC or LOCAL setting in /etc/adjtime, and should have been migrated automatically.
See hwclock(5) and hwclock(8) for further details on configuring the system clock.

From Wheezy's /etc/default/rcS:

Quote:
# assume that the BIOS clock is set to UTC time (recommended)
#UTC=no # OBSOLETE; see /etc/adjtime and hwclock(8).

Those comment lines mentioning 'BIOS clock' and 'UTC' have been removed from sid's /etc/default/rcS file. It just changed yesterday, it hasn't made it to Wheezy yet. You'll probably see it in the next week or so in Wheezy.

It's an update of the initscripts package 2.88dsf-22.1 --> 2.88dsf-26.


Last edited by kmathern on Fri Jun 08, 2012 3:42 pm, edited 1 time in total.



Fri Jun 08, 2012 3:30 pm

kmathern thanked by: DBeckett
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 18 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.