MEPIS Community Forum

A Linux operating system based on Debian Stable
View unanswered posts | View unsolved topics | View active topics |



Reply to topic  [ 9 posts ] 
USB NIC problem. 
Author Message
MEPIS Guide
MEPIS Guide
User avatar

Joined: Sun Dec 16, 2007 6:29 pm
Posts: 1011
Location: UK
Has thanked: 785 times
Have thanks: 87 times
Post # 301269
Post USB NIC problem.
I have a USB NIC which lsusb identifies as
Quote:
Kontron (Industrial Computer Source / ICS Advent) DM9601 Fast Ethernet Adapter
Can anybody tell me how to get it working in Mepis?
It is working with W2k so it is not faulty, but I cannot find a linux driver for it in the repos.


Tue Jun 12, 2012 5:39 pm
Profile
MEPIS Enthusiast
MEPIS Enthusiast
User avatar

Joined: Sat Nov 11, 2006 10:42 pm
Posts: 4289
Has thanked: 114 times
Have thanks: 853 times
Post # 301270
Post Re: USB NIC problem.
A quick Google left me with the impression it should be supported OOTB with Squeeze.

http://preview.tinyurl.com/d4a8lbb

Are you running M8 or M8.5?

_________________
Desktop: Custom build Asus/AMD/nVidia -- MEPIS 11
Netbook: Fujitsu Lifebook Pentium M -- MX-14
Laptop: Acer Aspire 5250 AMD Dual -- SolydK 64


Tue Jun 12, 2012 5:45 pm
Profile
MEPIS Guide
MEPIS Guide
User avatar

Joined: Sun Dec 16, 2007 6:29 pm
Posts: 1011
Location: UK
Has thanked: 785 times
Have thanks: 87 times
Post # 301271
Post Re: USB NIC problem.
uncle mark wrote:
A quick Google left me with the impression it should be supported OOTB with Squeeze.

http://preview.tinyurl.com/d4a8lbb

Are you running M8 or M8.5?

No, plain old M11.


Tue Jun 12, 2012 5:55 pm
Profile
MEPIS Guide
MEPIS Guide
User avatar

Joined: Sat May 16, 2009 3:59 pm
Posts: 2896
Has thanked: 414 times
Have thanks: 444 times
Post # 301272
Post Re: USB NIC problem.
Should be supported by the kernel.

Is it being detected?

_________________
Gigabyte 990FXA-UD3, AMD FX-6100 hex-core, 3.3GHz, Radeon HD6570
Gigabyte A55M-DS2, AMD A4-3400 dual-core APU (llano), 2.7 GHz, Radeon HD graphics
IBM ThinkPad T43, Intel Pentium M, 1.73GHz, Intel chipset


Tue Jun 12, 2012 5:58 pm
Profile
MEPIS Guide
MEPIS Guide
User avatar

Joined: Sun Dec 16, 2007 6:29 pm
Posts: 1011
Location: UK
Has thanked: 785 times
Have thanks: 87 times
Post # 301274
Post Re: USB NIC problem.
DBeckett wrote:
Should be supported by the kernel.

Is it being detected?

Yes, by lsusb, but not by Mepis Network Assistant.


Tue Jun 12, 2012 6:07 pm
Profile
MEPIS Enthusiast
MEPIS Enthusiast
User avatar

Joined: Wed Jul 12, 2006 2:26 pm
Posts: 6797
Has thanked: 369 times
Have thanks: 2154 times
Post # 301275
Post Re: USB NIC problem.
Does the last part of a dmesg report show anything after plugging it in? If not run 'modprobe dm9601' and see if dmesg and/or lsmod shows anything afterwards.


Tue Jun 12, 2012 6:07 pm
Profile
MEPIS Guide
MEPIS Guide
User avatar

Joined: Sun Dec 16, 2007 6:29 pm
Posts: 1011
Location: UK
Has thanked: 785 times
Have thanks: 87 times
Post # 301276
Post Re: USB NIC problem.
kmathern wrote:
Does the last part of a dmesg report show anything after plugging it in?...........

Yes, it says "usb 2-2: Product: USB 2.0 10/100M Ethernet Adaptor".

Sorry for the slowness of my responses.

Edit: After "modeprobe dm9601" (as root), dmesg says "usbcore: registered new interface driver dm9601".


Last edited by GuiGuy on Tue Jun 12, 2012 6:40 pm, edited 1 time in total.



Tue Jun 12, 2012 6:18 pm
Profile
MEPIS Enthusiast
MEPIS Enthusiast
User avatar

Joined: Wed Jul 12, 2006 2:26 pm
Posts: 6797
Has thanked: 369 times
Have thanks: 2154 times
Post # 301277
Post Re: USB NIC problem.
I was hoping there would be additional information in the dmesg report (like perhaps a eth* interface number associated with it).

What does 'ifconfig -a' show with and without the USB NIC plugged in? (i.e. is there an additional eth* interface available when it's plugged in)


Tue Jun 12, 2012 6:31 pm
Profile
MEPIS Guide
MEPIS Guide
User avatar

Joined: Sun Dec 16, 2007 6:29 pm
Posts: 1011
Location: UK
Has thanked: 785 times
Have thanks: 87 times
Post # 301279
Post Re: USB NIC problem.
kmathern wrote:
I was hoping there would be additional information in the dmesg report (like perhaps a eth* interface number associated with it).

What does 'ifconfig -a' show with and without the USB NIC plugged in? (i.e. is there an additional eth* interface available when it's plugged in)

No, just "Local Loopback" whether plugged in or not.

Edit: Tried rebooting, but no difference.
Past my bedtime now, so thanks for your help Guys. I will come back tomorrow.

Edit2: In case anyone is confused, I am posting from a different M11 machine with a proper lan connection!
Gnite.


Tue Jun 12, 2012 6:50 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.