Error Upgrading Samba

Help for Mepis 11 modified with a non-Mepis kernel, upgraded KDE. or base repositories other than Debian squeeze
Message
Author
User avatar
smilliken
Forum Guide
Forum Guide
Posts: 1987
Age: 57
Joined: Tue Feb 06, 2007 11:47 pm

Error Upgrading Samba

#1 Postby smilliken » Thu Dec 01, 2011 1:31 am

Error received while performing an upgrade. error is in regards to samba.

Code: Select all

Errors were encountered while processing:
 samba
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up samba (2:3.6.1-2) ...
Starting Samba daemons: nmbd/usr/sbin/nmbd: relocation error: /usr/sbin/nmbd: symbol krb5_locate_kdc, version krb5_3_MIT not defined in file libkrb5.so.3 with link time reference
 failed!
invoke-rc.d: initscript samba, action "start" failed.
dpkg: error processing samba (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 samba
There is no "Ctrl+Z" in life!
Acer 7551G MX-15
Dell 1525, MX15 XFCE4 & Win 10
HP DV4-1118 Mepis 12 4.14 & Win 10
HP CP1215/Brother DCP-7065DN
Linux User# 4523410

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 8944
Age: 57
Joined: Wed Jul 12, 2006 2:26 pm

Re: Error Upgrading Samba

#2 Postby kmathern » Thu Dec 01, 2011 1:12 pm

Is this on a M11 install that's been upgraded to sid? If so, see this: http://aptosid.com/index.php?name=PNphp ... pic&t=1962

I currently have the same problem on my M11/sid install. It seems to be affecting smplayer (though I'm not sure of the connection between samba and smplayer)



edit:
I downgraded the krb5 packages that were in todays upgrades back to the wheezy version and that seems to have fixed the problem that I was having.

I did the krb5 downgrade with the command below { enable the Debian wheezy repos and reload first }

Code: Select all

apt-get install `dpkg -l|grep '1.10+dfsg~alpha1-5'|cut -f3 -d' '|sed ':a;N;$!ba;s/\n/=1.9.1+dfsg-3 /g'`=1.9.1+dfsg-3


Here's the actual konsole output:

Code: Select all

[root@mepis1 kent]# apt-get install `dpkg -l|grep '1.10+dfsg~alpha1-5'|cut -f3 -d' '|sed ':a;N;$!ba;s/\n/=1.9.1+dfsg-3 /g'`=1.9.1+dfsg-3
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  krb5-doc krb5-user
The following packages will be DOWNGRADED:
  libgssapi-krb5-2 libk5crypto3 libkrb5-3 libkrb5support0
0 upgraded, 0 newly installed, 4 downgraded, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 695 kB of archives.
After this operation, 108 kB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 ftp://ftp.debian.org/debian/ wheezy/main libk5crypto3 i386 1.9.1+dfsg-3 [108 kB]
Get:2 ftp://ftp.debian.org/debian/ wheezy/main libgssapi-krb5-2 i386 1.9.1+dfsg-3 [148 kB]
Get:3 ftp://ftp.debian.org/debian/ wheezy/main libkrb5-3 i386 1.9.1+dfsg-3 [392 kB]
Get:4 ftp://ftp.debian.org/debian/ wheezy/main libkrb5support0 i386 1.9.1+dfsg-3 [47.3 kB]
Fetched 695 kB in 6s (102 kB/s)                                                                                               
dpkg: warning: downgrading libk5crypto3 from 1.10+dfsg~alpha1-5 to 1.9.1+dfsg-3.
(Reading database ... 125189 files and directories currently installed.)
Preparing to replace libk5crypto3 1.10+dfsg~alpha1-5 (using .../libk5crypto3_1.9.1+dfsg-3_i386.deb) ...
Unpacking replacement libk5crypto3 ...
dpkg: warning: downgrading libgssapi-krb5-2 from 1.10+dfsg~alpha1-5 to 1.9.1+dfsg-3.
Preparing to replace libgssapi-krb5-2 1.10+dfsg~alpha1-5 (using .../libgssapi-krb5-2_1.9.1+dfsg-3_i386.deb) ...
Unpacking replacement libgssapi-krb5-2 ...
dpkg: warning: downgrading libkrb5-3 from 1.10+dfsg~alpha1-5 to 1.9.1+dfsg-3.
Preparing to replace libkrb5-3 1.10+dfsg~alpha1-5 (using .../libkrb5-3_1.9.1+dfsg-3_i386.deb) ...
Unpacking replacement libkrb5-3 ...
dpkg: warning: downgrading libkrb5support0 from 1.10+dfsg~alpha1-5 to 1.9.1+dfsg-3.
Preparing to replace libkrb5support0 1.10+dfsg~alpha1-5 (using .../libkrb5support0_1.9.1+dfsg-3_i386.deb) ...
Unpacking replacement libkrb5support0 ...
Setting up libkrb5support0 (1.9.1+dfsg-3) ...
Setting up libk5crypto3 (1.9.1+dfsg-3) ...
Setting up libkrb5-3 (1.9.1+dfsg-3) ...
Setting up libgssapi-krb5-2 (1.9.1+dfsg-3) ...
Setting up samba (2:3.6.1-2) ...
Starting Samba daemons: nmbd smbd.
[root@mepis1 kent]#

User avatar
smilliken
Forum Guide
Forum Guide
Posts: 1987
Age: 57
Joined: Tue Feb 06, 2007 11:47 pm

Re: Error Upgrading Samba

#3 Postby smilliken » Thu Dec 01, 2011 8:49 pm

Thanks, seemed to work. Does one disable the wheezy repo afterward, or does start me living on the edge?
There is no "Ctrl+Z" in life!
Acer 7551G MX-15
Dell 1525, MX15 XFCE4 & Win 10
HP DV4-1118 Mepis 12 4.14 & Win 10
HP CP1215/Brother DCP-7065DN
Linux User# 4523410

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 8944
Age: 57
Joined: Wed Jul 12, 2006 2:26 pm

Re: Error Upgrading Samba

#4 Postby kmathern » Thu Dec 01, 2011 8:59 pm

smilliken wrote:Thanks, seemed to work. Does one disable the wheezy repo afterward, or does start me living on the edge?

You can disable the wheezy repo.

If you're using sid, hold back the krb5 related updates {libgssapi-krb5-2, libk5crypto3, libkrb5-3 & libkrb5support0 on my system}, until an updated samba shows up. I've been checking the bugreport http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=650541 and it looks like they're working on it.

User avatar
smilliken
Forum Guide
Forum Guide
Posts: 1987
Age: 57
Joined: Tue Feb 06, 2007 11:47 pm

Re: Error Upgrading Samba

#5 Postby smilliken » Fri Dec 02, 2011 12:59 am

kmathern wrote:If you're using sid, hold back the krb5 related updates {libgssapi-krb5-2, libk5crypto3, libkrb5-3 & libkrb5support0 on my system}, until an updated samba shows up. I've been checking the bugreport http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=650541 and it looks like they're working on it.


Thanks. I have the same packages wanting upgrading. Would this be a 32 bit vs a 64 bit thing? I'm running a 32 bit that upgraded just fine, but not sure if smplayer is installed on it. No smplayer installed on the 64 bit.
There is no "Ctrl+Z" in life!
Acer 7551G MX-15
Dell 1525, MX15 XFCE4 & Win 10
HP DV4-1118 Mepis 12 4.14 & Win 10
HP CP1215/Brother DCP-7065DN
Linux User# 4523410

User avatar
GoManutd
Forum Guide
Forum Guide
Posts: 2952
Joined: Mon Jun 30, 2008 8:06 pm

Re: Error Upgrading Samba

#6 Postby GoManutd » Fri Dec 02, 2011 10:28 am

please evaluate how exposed your system is to a potential hack... kerberos was updated because there was a MAJOR flaw in the previous version, hence the update.

if you have to have samba installed on sid, requiring this downgrade take a look at the permissivity of firewalls and adjust accordingly.

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 8944
Age: 57
Joined: Wed Jul 12, 2006 2:26 pm

Re: Error Upgrading Samba

#7 Postby kmathern » Fri Dec 02, 2011 11:08 am

There's a samba update (2:3.6.1-2 -> 2:3.6.1-2+b1) in http://incoming.debian.org/ that will probably make it into the sid repo sometime today or tomorrow.

I think that samba update will allow you to upgrade the krb5 packages back to the newest version (1.10+dfsg~alpha1-5).

edit: I also see some krb5 updates (1.10+dfsg~alpha1-5 -> 1.10+dfsg~alpha1-6) in http://incoming.debian.org/

edit #2: Now, about 45 minutes after my last edit, the updates (samba & krb5) are in sid and they install without any problem.

User avatar
smilliken
Forum Guide
Forum Guide
Posts: 1987
Age: 57
Joined: Tue Feb 06, 2007 11:47 pm

Re: Error Upgrading Samba

#8 Postby smilliken » Fri Dec 02, 2011 10:11 pm

Unpinned, reloaded and all installed fine. Thanks for the help.
There is no "Ctrl+Z" in life!
Acer 7551G MX-15
Dell 1525, MX15 XFCE4 & Win 10
HP DV4-1118 Mepis 12 4.14 & Win 10
HP CP1215/Brother DCP-7065DN
Linux User# 4523410


Return to “Mepis 11 Modified”

Who is online

Users browsing this forum: No registered users and 1 guest