MEPIS Community Forum

A Linux operating system based on Debian Stable
View unanswered posts | View unsolved topics | View active topics |



Reply to topic  [ 28 posts ]  Go to page Previous  1, 2, 3
compiz: window titlebar missing after monitor replacement 
Author Message
MEPIS Rules!
MEPIS Rules!
User avatar

Joined: Fri Jul 14, 2006 7:49 pm
Posts: 488
Has thanked: 2 times
Have thanks: 4 times
Post # 192892
Post 
Robert1,
Are you using emerald or kde for you window decor themes? Could there be a setting in ccsm to toggle the decoration on and off? I really don't know the answer to your problem they are just questions that come to mind.

_________________
I think I have lost my mind which is making it extremely difficult to remember where I was when I used it last.....:hmm:


Tue Sep 01, 2009 3:48 pm
Profile
MEPIS Rules!
MEPIS Rules!

Joined: Thu Jul 12, 2007 11:19 pm
Posts: 169
Has thanked: 13 times
Have thanks: 14 times
Post # 192920
Post 
nlyric wrote:
Robert1,
Are you using emerald or kde for you window decor themes? Could there be a setting in ccsm to toggle the decoration on and off? I really don't know the answer to your problem they are just questions that come to mind.


apparently it is KDE. Emerald is not available in the Debian repositories.
in regards to the CompizConfig Settings Manager, none of the settings have changed to the enabled plug-ins as far as i can tell.


Tue Sep 01, 2009 8:49 pm
Profile
MEPIS Rules!
MEPIS Rules!
User avatar

Joined: Fri Apr 10, 2009 5:30 pm
Posts: 196
Location: New Zealand
Has thanked: 2 times
Have thanks: 0 time
Post # 193047
Post 
I've used both versions of Compiz and Shames repo is better. Think I've said it before but the other version did tend to lose the Borders a bit but a "Reload window manager" via the icon normally solved it. Plainly that ain't happening in your case. I suggest you get rid of that version of Compiz and do whats stated in the url I've posted below for Mepis 8.0. I'm using Emerald as theme manager and apart from a bit of flickering when I engage the cube with Firefox open it works fine. Still looking for the answer to the flicker problem. No doubt some weird setting in ccsm will fix it if I ever luck upon it.

http://www.mepis.org/docs/en/index.php/Compiz[/url]

Use the "ALTERNATIVE METHOD"..not the standard Mep 8 way which I guess would entail your going into the Synaptic Package Manager and getting rid of whatever you have in the Compiz department first..Reboot when thats done then follow the method outlined in the url. Painful having to change something that was previously working fine I know, but the quickest way out in my opinion.


Wed Sep 02, 2009 4:42 pm
Profile
MEPIS Rules!
MEPIS Rules!

Joined: Thu Jul 12, 2007 11:19 pm
Posts: 169
Has thanked: 13 times
Have thanks: 14 times
Post # 193454
Post 
Buildereen wrote:
I've used both versions of Compiz and Shames repo is better. Think I've said it before but the other version did tend to lose the Borders a bit but a "Reload window manager" via the icon normally solved it. Plainly that ain't happening in your case. I suggest you get rid of that version of Compiz and do whats stated in the url I've posted below for Mepis 8.0. I'm using Emerald as theme manager and apart from a bit of flickering when I engage the cube with Firefox open it works fine. Still looking for the answer to the flicker problem. No doubt some weird setting in ccsm will fix it if I ever luck upon it.


i guess that is about the only choice i would have left.

i know that this is not Warrens or Mepis's fault, this kind of thing has been a problem with Debian & their stable packages for a long time. instead of pulling defective or buggy packages out of their "stable" repositories, they leave them in.
this kind of "problem" gives a bad reputation which hinders Linux adoption.

Buildereen wrote:
Use the "ALTERNATIVE METHOD"..not the standard Mep 8 way which I guess would entail your going into the Synaptic Package Manager and getting rid of whatever you have in the Compiz department first..Reboot when thats done then follow the method outlined in the url. Painful having to change something that was previously working fine I know, but the quickest way out in my opinion.


i not going to bother with that for now as compiz is not really that important to me. also, this is my main PC & i regard it as my production machine.

it would be nice if someone from the Mepis community who is familiar with packaging would take time to include the packages in shames repo into the Mepis community repos with the proper versioning so that way compiz & all of it's required packages can be updated / replaced with synaptic without having to add shanes repository to sources.lst.


Sat Sep 05, 2009 4:53 pm
Profile
MEPIS Guide
MEPIS Guide
User avatar

Joined: Thu Jul 26, 2007 2:40 am
Posts: 2037
Location: Bakersfield, CA
Has thanked: 25 times
Have thanks: 78 times
Post # 193460
Post 
robert1 wrote:
...i no longer had the window titlebars...i had to right click on the button in the titlebar & choose "minimize" that way.


Your post is confusing, but if the "Title Bar" is missing you need to re/install "kwin".

_________________
Registered Linux User #380263
Registered Linux Computer #279395
Linux, working hard to save you $$$ - Get a clue, get Linux!
Intel Pentium D 2.80GHz
Intel Desktop Board D945GTP
Intel ICH7 Ethernet Controller
Intel ICH7 Audio
nVidia GeForce 6200 Video


Sat Sep 05, 2009 6:15 pm
Profile WWW
MEPIS Rules!
MEPIS Rules!

Joined: Thu Jul 12, 2007 11:19 pm
Posts: 169
Has thanked: 13 times
Have thanks: 14 times
Post # 193493
Post 
Jimmy Johnson wrote:
Your post is confusing, but if the "Title Bar" is missing you need to re/install "kwin".


i goofed on that post, i meant "when i right clicked on the button on the panel (kicker)" was the only way i could minimize or close the window.

the titlebar (the bar at the top of each window with the title, close, minumize/maximise buttons on the top right would be completely missing.

this is only when compiz is used as the WM. when i click on Kwin, everything is back to normal

i guess that you would also call them "window decorations".


Sat Sep 05, 2009 8:48 pm
Profile
MEPIS Guide
MEPIS Guide
User avatar

Joined: Thu Jul 26, 2007 2:40 am
Posts: 2037
Location: Bakersfield, CA
Has thanked: 25 times
Have thanks: 78 times
Post # 193544
Post 
Maybe some version mismatch not working well together!?!

I'm not a compiz user so I'll bug out. :biggrin:

_________________
Registered Linux User #380263
Registered Linux Computer #279395
Linux, working hard to save you $$$ - Get a clue, get Linux!
Intel Pentium D 2.80GHz
Intel Desktop Board D945GTP
Intel ICH7 Ethernet Controller
Intel ICH7 Audio
nVidia GeForce 6200 Video


Sun Sep 06, 2009 10:47 am
Profile WWW
MEPIS Guide
MEPIS Guide
User avatar

Joined: Wed Jul 12, 2006 1:31 am
Posts: 1457
Has thanked: 45 times
Have thanks: 78 times
Post # 242035
Post 
From my early experiments with Compiz, I seem to remember it was necessary to put an '& replace' or similar to the command used to switch window decorators (the correct term) or the sort of issue outlined here occurs, but equally, and erroneous/missing line in xorg.conf will also cause problems. I would certainly recommend creating a fresh xorg.conf file http://www.mepis.org/docs/en/index.php/Xorg_-configure but make sure you add the small section "composite" you see at the end of your current xorg.conf.
Alternatively you could rip out all Nvidia.deb packages you have installed, then use sgfxi to install the latest available for your card, and create an xorg.conf file, be sure to ask it to enable composite at time of execution:

sgfxi -cz

would do it...
http://www.mepis.org/docs/en/index.php/Sgfxi#sgfxi

_________________

::AMD Phenom II X2 550 BE 3.1GHz::Gigabyte GA-MA785GMT-UD2H::Crucial 2gig DDR3 1333MHz/PC3-10600::Hitachi DeskStar 1TB Hard Drive SATAII 7200rpm 16MB Cache::
::O² Joggler::


Tue Aug 17, 2010 6:45 am
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 28 posts ]  Go to page Previous  1, 2, 3

Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.