MEPIS Community Forum

A Linux operating system based on Debian Stable
View unanswered posts | View unsolved topics | View active topics |



Reply to topic  [ 46 posts ]  Go to page 1, 2, 3, 4, 5  Next
Not getting correct resolution 
Author Message
MEPIS Novice
MEPIS  Novice

Joined: Tue Feb 21, 2012 12:32 am
Posts: 18
Has thanked: 19 times
Have thanks: 0 time
Post # 296133
Post Not getting correct resolution
When i boot in to the Live dvd of Mepis 11 the highest resolution I can get is 800x600 when it should be 1920x1080

The system I am running is a couple of years old now so i would have thought it would be able to get that right.

here are the specs of my PC

CPU
Intel Core i3 530 @ 2.93GHz 42 °C
Clarkdale 32nm Technology
RAM
4.0GB Dual-Channel DDR3 @ 666MHz (9-9-9-24)
Motherboard
Gigabyte Technology Co., Ltd. H55M-S2H (Socket 1156)
Graphics
Generic Non-PnP Monitor @ 1920x1080
NVIDIA GeForce GT 220

Yes i tried all the tips and read the manuals and all that! it has been a couple years since I used Mepis or even Linux for that matter so i have probably overlooked something

TIA


Tue Feb 21, 2012 12:47 am
Profile
MEPIS is cool!
MEPIS is cool!
User avatar

Joined: Sat Jul 15, 2006 10:57 am
Posts: 797
Has thanked: 22 times
Have thanks: 115 times
Post # 296134
Post Re: Not getting correct resolution
the default Mepis 11 disc only includes the Nouveau driver, and a really old one at that.

you won't get your proper resolution until you install the Nvidia-Glx driver.

_________________
Slow, lazy, but still around: Call me if ya need help
http://zerias.blogspot.com
http://www.mepisguides.com
Biting the Bullet: Help
Want to buy Mepis Based Computer? Ask me!
http://bit.ly/fbs47I


Tue Feb 21, 2012 12:56 am

Saist thanked by: Timbo75
Profile WWW
MEPIS Guide
MEPIS Guide
User avatar

Joined: Wed Jul 12, 2006 4:30 pm
Posts: 1447
Location: Flinthills of Kansas, USA
Has thanked: 253 times
Have thanks: 139 times
Post # 296135
Post Re: Not getting correct resolution
Maybe check through the "View Active Topics" from the top of forum pages as I recall this being brought up from another poster in the last week or so and I believe a resolve was found. I think it was that you have to first install and then add missing drivers but don't quote me on that. :cool: Jerry
As Saist said

_________________
http://patentabsurdity.com/
AMD 64x2 2.6GHz 4GB ram M-11.9.92 kernel 3.10-3-amd64 kde 4.11.5 mixed/unstable
"beware a frequent flirt with potential disaster"


Tue Feb 21, 2012 12:56 am

JBoman thanked by: Timbo75
Profile
MEPIS Novice
MEPIS  Novice

Joined: Tue Feb 21, 2012 12:32 am
Posts: 18
Has thanked: 19 times
Have thanks: 0 time
Post # 296136
Post Re: Not getting correct resolution
Saist wrote:
the default Mepis 11 disc only includes the Nouveau driver, and a really old one at that.

you won't get your proper resolution until you install the Nvidia-Glx driver.



Only including an old driver seems stupid to me

If i boot into it aufs (I think it is called) will i be able to install that driver through synaptic to test it out? Ugh I was away too long and have forgotten so much, sorry.


Tue Feb 21, 2012 1:07 am
Profile
MEPIS Guide
MEPIS Guide
User avatar

Joined: Wed Jul 12, 2006 4:30 pm
Posts: 1447
Location: Flinthills of Kansas, USA
Has thanked: 253 times
Have thanks: 139 times
Post # 296137
Post Re: Not getting correct resolution
don't think you can add it to the live disc... think you have to do an install first. :needcoffee: Jerry

_________________
http://patentabsurdity.com/
AMD 64x2 2.6GHz 4GB ram M-11.9.92 kernel 3.10-3-amd64 kde 4.11.5 mixed/unstable
"beware a frequent flirt with potential disaster"


Tue Feb 21, 2012 1:16 am

JBoman thanked by: Timbo75
Profile
MEPIS Guide
MEPIS Guide

Joined: Tue Jul 25, 2006 12:47 pm
Posts: 1405
Location: Savannah, GA
Has thanked: 82 times
Have thanks: 265 times
Post # 296139
Post Re: Not getting correct resolution
You may want to try adding this "cheat code" to the end of the GRUB boot line at the boot menu prompt before pressing enter and see if that gives you the correct resolution with your display:

nvidia.modeset=0

If you decide install Mepis to your hard drive, I'd just install the proprietary Nvidia driver. That way, you'll have the Nvidia Control panel with more features.

The easiest way to do that is by using the sgfxi script. See this page about it:

http://www.mepis.org/docs/en/index.php? ... 28sgfxi.29

Basically, you just install the script, then follow the instructions on that page to run it (press CTRL+ALT+F1 to exit to a login prompt, then login in using user name root and type sgfxi and use the defaults). That script will download and install the latest stable driver for you by default (295.20 right this minute). Then, after it runs, you'll see a choice to exit (which shuts down mepis) or start desktop (I'd try that first).

I don't know if you could use it from a Live DVD with aufs or not. If you try it, make sure to use the Start Desktop versus Exit option after the sgfxi script finishes installing the driver (otherwise, you'll reboot and be right back where you were to begin with).

Just note that sometimes you may need to run the script more than once. For example, when I upgraded from Nvidia 285.05.09 to 290.10, I had to run the sgfxi script again. More recently, I upgraded from 290.10 to 295.20 and it only took one run, with the desktop starting fine using the newer driver without a reboot when using the Start Desktop option after running sgfxi. That's just a "quirk" with the way it works (sometimes needs running more than once to remove the old driver and installing a newer one).

If you install Mepis 11 to a hard drive, I don't think you'd have any issues once you install the Nvidia proprietary driver using the sgfxi script.

But, from a Live DVD, I'd try using the cheat code nvidia.modeset=0 (just add it to the end of the grub boot line) and see if that helps anything. If not, see if you can download and run the sgfxi script from a Live session after choosing the aufs option (and again, I don't know if that would work from a Live session or not).


Last edited by JimC on Tue Feb 21, 2012 1:30 am, edited 1 time in total.



Tue Feb 21, 2012 1:24 am

JimC thanked by: Timbo75
Profile
MEPIS Novice
MEPIS  Novice

Joined: Tue Feb 21, 2012 12:32 am
Posts: 18
Has thanked: 19 times
Have thanks: 0 time
Post # 296140
Post Re: Not getting correct resolution
Sorry guys but if that is how Mepis is now then it really has followed the herd of all linux and no longer stands out especially if it can't correctly identify an older graphics card with no simple fix that is obvious! mepis 8.5 i think it was could run it in vesa mode on the live CD or DVD 2 years ago so I see no reason why 11 shouldn't! massive step backwards!

I think the developers need to take a step back and have a serious think about what they are doing from a new Linux users POV as right now from the quick read i have had around the forum Mepis is heading well and truly towards the seasoned users and not the newbie friendly distro it once was!


Tue Feb 21, 2012 1:28 am
Profile
MEPIS Guide
MEPIS Guide
User avatar

Joined: Wed Jul 12, 2006 4:30 pm
Posts: 1447
Location: Flinthills of Kansas, USA
Has thanked: 253 times
Have thanks: 139 times
Post # 296142
Post Re: Not getting correct resolution
Timbo75 wrote:
Sorry guys but if that is how Mepis is now then it really has followed the herd of all linux and no longer stands out especially if it can't correctly identify an older graphics card with no simple fix that is obvious! mepis 8.5 i think it was could run it in vesa mode on the live CD or DVD 2 years ago so I see no reason why 11 shouldn't! massive step backwards!

I think the developers need to take a step back and have a serious think about what they are doing from a new Linux users POV as right now from the quick read i have had around the forum Mepis is heading well and truly towards the seasoned users and not the newbie friendly distro it once was!


Only problem is that the developer is a one man band who is only recently accepting more input from the community developers who are crying for just such things. Adding drivers is not that complicated and many Linux distros still have the need. M-11 is worth the effort and the community has provided easy means to update kde to 4.7.4 and the latest linux kernel is easy addition with synaptic. :popcorn: Jerry

_________________
http://patentabsurdity.com/
AMD 64x2 2.6GHz 4GB ram M-11.9.92 kernel 3.10-3-amd64 kde 4.11.5 mixed/unstable
"beware a frequent flirt with potential disaster"


Tue Feb 21, 2012 1:40 am

JBoman thanked by: Timbo75
Profile
MEPIS Novice
MEPIS  Novice

Joined: Tue Feb 21, 2012 12:32 am
Posts: 18
Has thanked: 19 times
Have thanks: 0 time
Post # 296143
Post Re: Not getting correct resolution
Don't get me wrong Mepis was and is my favourite distro. I am aware it is a one man band and that the community has just started to input their ideas.

The point is that adding drivers through the command line is NOT newbie friendly and NEVER will be! The ability to correctly identify such an old card should not be a problem in the first place anyway! Where are the easy solutions Mepis built its base on? Why could 8.5 get it right and 11 can't?


Tue Feb 21, 2012 1:50 am
Profile
MEPIS Guide
MEPIS Guide

Joined: Tue Jul 25, 2006 12:47 pm
Posts: 1405
Location: Savannah, GA
Has thanked: 82 times
Have thanks: 265 times
Post # 296145
Post Re: Not getting correct resolution
I just booted into a live Mepis 11 session (I've got Mepis 11 on a USB Flash Drive I made with unetbootin a while back), and noticed that a proprietary Nvidia driver was already there and being used, and it recognized my GT 440 just fine and set the correct resolution for my display. Nvidia 260.19.21 was loaded, and I even have the Nvidia Control Panel. I'm typing this post from a Live session of Mepis 11 now using a GT 440 with the correct resolution set automatically.

I didn't realize the Live DVD was using the proprietary driver by default.

My guess is that your H55 chipset is probably confusing it and it's just not loading the Nvidia driver for some reason (perhaps assuming the Intel video is being used instead), since your GT 220 is a supported card: See the list of cards supported by the included Nvidia 260.19.21 driver in Mepis 11 here:

ftp://download.nvidia.com/XFree86/Linux ... chips.html

So, you can probably get it working with a cheat code at the GRUB boot prompt so that it knows to load the nvidia driver. Press TAB at the Live DVD boot prompt and add this to the end of the GRUB boot line and see if that solves it for you (all lower case as below).

xdrvr=nvidia confx

I didn't need to do that with my system. But, my guess is that something about your H55 chipset may be confusing Mepis 11.. You should find the Nvidia Control Panel under KMenu>Settings>More Applications>Nvidia X Server Settings so you can check to make sure it sees your card OK with settings you can change after the nvidia driver is loaded.


Tue Feb 21, 2012 2:13 am

JimC thanked by: Timbo75
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 46 posts ]  Go to page 1, 2, 3, 4, 5  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.