Alsa - set default sample rate?

Problems with your sound card are to be posted here, as well as tutorials to share with others.
Message
Author
User avatar
whell
Forum Regular
Forum Regular
Posts: 235
Joined: Sat Sep 26, 2009 1:03 pm

Alsa - set default sample rate?

#1 Postby whell » Mon Nov 21, 2011 4:34 pm

I'd like to try Mepis 11 for playback of audio files. I have an Acer Aspire laptop with external USB DAC / "soundcard". All is set up and running, but I've noticed that all the files that I'm playing seem to be down-sampled to 16 bit / 44.1 Khz. I have a number of files recorded in 24/96 that I'd like to play back at 24/96. Is there a way to adjust the defaults in the ALSA sound system to allow for playback of 24/96 files?

User avatar
qtech
Forum Regular
Forum Regular
Posts: 693
Joined: Wed Nov 28, 2007 12:21 pm

Re: Alsa - set default sample rate?

#2 Postby qtech » Mon Nov 21, 2011 10:40 pm

whell wrote:I'd like to try Mepis 11 for playback of audio files. I have an Acer Aspire laptop with external USB DAC / "soundcard". All is set up and running, but I've noticed that all the files that I'm playing seem to be down-sampled to 16 bit / 44.1 Khz. I have a number of files recorded in 24/96 that I'd like to play back at 24/96. Is there a way to adjust the defaults in the ALSA sound system to allow for playback of 24/96 files?


It depends on your sound card. Does your USB DAC support 24bit playback?

User avatar
whell
Forum Regular
Forum Regular
Posts: 235
Joined: Sat Sep 26, 2009 1:03 pm

Re: Alsa - set default sample rate?

#3 Postby whell » Tue Feb 21, 2012 10:48 pm

I actually stumbled on the answer almost by accident. The key is installing the gstreamer-alsa package. Then go to the preferences section of media player - VLC for instance - and modify the settings for audio to output direct to ALSA. it will also be necessary to specify the hardware - soundcard or external DAC - to be used in the audio preferences settings.


Return to “Sound”

Who is online

Users browsing this forum: No registered users and 0 guests