M!! Time Problem

Help for Mepis 11
Message
Author
User avatar
Topher
Forum Regular
Forum Regular
Posts: 875
Joined: Sun Feb 10, 2008 5:37 pm

M!! Time Problem

#1 Postby Topher » Fri Jun 08, 2012 12:53 pm

I have a time problem that has me stumped. In our community lab we have dual boot Win7 & Mepis PC's. Our MOBO's are Asus F1A75-V Pro with the new UEFI bios and we are running Mepis11. When we log out of Mepis the BIOS time gets set 5 hours later. Mepis doesn't have a problem with that and I didn't notice that as it gets the correct time from the internet as soon as we logon. But Windows doesn't change the time and shows the wrong time. When we reset the time correctly it stays OK until the next time we run Mepis. When I installed Mepis I am pretty sure I picked the Chicago, central time zone. And when I checked, the correct time zone is shown, Chicago (central time), but upon shutdown the time in the BIOS is reset 5 hours ahead. That five hour difference is the difference between US Central time zone and GMT. Is there some other setting I should look at? Or is there some setting in the BIOS that I seem to be overlooking? The only thing I can remember seeing in the BIOS is the time itself. TIA
MX15 MoBo ASUS M4A88TD-V EVO/USB3 CPU AMD Phenom II X4 945 PSU CORSAIR CX500 (CMPSU-500CX) RAM Crucial CT2KIT25664BA1339 HD WD5000AAKX Wireless EDIMAX EW 7128g

User avatar
Gaer Boy
Forum Guide
Forum Guide
Posts: 1962
Age: 80
Joined: Sat Jun 06, 2009 6:06 am

Re: M!! Time Problem

#2 Postby Gaer Boy » Fri Jun 08, 2012 1:05 pm

I was going to respond by saying that I run dual boot WinXP and Mepis, and have not had a problem with the time since I started. I know I had to set things up on Mepis installation, but I can't remember the critical step.

Then I noticed that my system clock and Mepis time were way out - I expect an hour, because my time setting on the forum is UTC and we have summer time at present. But the forum is running 10 mins behind that. Just to check, I will post this at 18:17 BST (17:17 UTC) precisely.

Phil

AsRock FM2A88X-ITX+, A8-6500, 8GB, 120GB Samsung SSD (GPT), 1TB HDD (MBR), MX-15, MX-14.4
Acer Aspire One 150, Atom N270, 120GB HDD, MX-14.3

User avatar
GoManutd
Forum Guide
Forum Guide
Posts: 2952
Joined: Mon Jun 30, 2008 8:06 pm

Re: M!! Time Problem

#3 Postby GoManutd » Fri Jun 08, 2012 1:20 pm

bios battery is likely dying. you can also install ntp to auto adjust the clocks. i found i had to also installed ntpdate. this combo will go out to an atomic clock and grab the current time.

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9013
Age: 58
Joined: Wed Jul 12, 2006 2:26 pm

Re: M!! Time Problem

#4 Postby kmathern » Fri Jun 08, 2012 1:32 pm

In the /etc/default/rcS file check that it's set to 'UTC=no' {without the quotes}

You can edit /etc/default/rcS by simultaneously pressing Alt+F2, then type in: kdesu kwrite /etc/default/rcS (enter root password when requested)



{In M12 it would be nice to have a UTC checkbox in the MEPIS System Assistant}

User avatar
Gaer Boy
Forum Guide
Forum Guide
Posts: 1962
Age: 80
Joined: Sat Jun 06, 2009 6:06 am

Re: M!! Time Problem

#5 Postby Gaer Boy » Fri Jun 08, 2012 1:44 pm

kmathern wrote:In the /etc/default/rcS file check that it's set to 'UTC=no' {without the quotes}
I seem to remember that there's a question that implies that alternative during installation.

Meanwhile, the Mepis forum time continues 12 minutes behind real time.

Phil

AsRock FM2A88X-ITX+, A8-6500, 8GB, 120GB Samsung SSD (GPT), 1TB HDD (MBR), MX-15, MX-14.4
Acer Aspire One 150, Atom N270, 120GB HDD, MX-14.3

User avatar
Topher
Forum Regular
Forum Regular
Posts: 875
Joined: Sun Feb 10, 2008 5:37 pm

Re: M!! Time Problem

#6 Postby Topher » Fri Jun 08, 2012 1:59 pm

In the /etc/default/rcS file check that it's set to 'UTC=no' {without the quotes}

I'll check that file Monday when I go in - thanks.
MX15 MoBo ASUS M4A88TD-V EVO/USB3 CPU AMD Phenom II X4 945 PSU CORSAIR CX500 (CMPSU-500CX) RAM Crucial CT2KIT25664BA1339 HD WD5000AAKX Wireless EDIMAX EW 7128g

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9013
Age: 58
Joined: Wed Jul 12, 2006 2:26 pm

Re: M!! Time Problem

#7 Postby kmathern » Fri Jun 08, 2012 2:03 pm

Gaer Boy wrote:
kmathern wrote:In the /etc/default/rcS file check that it's set to 'UTC=no' {without the quotes}
I seem to remember that there's a question that implies that alternative during installation.

Meanwhile, the Mepis forum time continues 12 minutes behind real time.

Phil

There is a question about it while running the installer, I forget what it defaults to if you just press 'Enter' .



Btw, the UTC setting has been removed from the /etc/default/rcS file in sid {and probably wheezy as well}.

snippet from man:rcS

... The UTC setting is replaced by the UTC or LOCAL setting in /etc/adjtime, and should have been migrated automatically.
See hwclock(5) and hwclock(8) for further details on configuring the system clock.

fine print: this doesn't apply to Mepis 11.0 but will when Mepis 12 comes out

User avatar
uncle mark
Forum Veteran
Forum Veteran
Posts: 5360
Age: 2015
Joined: Sat Nov 11, 2006 10:42 pm

Re: M!! Time Problem

#8 Postby uncle mark » Fri Jun 08, 2012 3:14 pm

I believe the key is to have the bios set to local time. I've never had that issue when the bios is set to local time, then re-setting the time and time zone settings in both Win and Lin. In MEPIS, you'll need to do it through the System Settings dialog as root, and the first time you change it it might not stick. I've had to fight it on occasion.

The problem seems to be that Win assumes that the machine bios is set to local time, while unless told otherwise, Lin thinks it's set to UTC.
Desktop: Custom build Asus/AMD/nVidia -- MX-15 KDE, MEPIS 11
Laptop: Acer Aspire 5250 -- MX-15

User avatar
DBeckett
Forum Veteran
Forum Veteran
Posts: 3067
Joined: Sat May 16, 2009 3:59 pm

Re: M!! Time Problem

#9 Postby DBeckett » Fri Jun 08, 2012 3:20 pm

kmathern wrote:snippet from man:rcS

... The UTC setting is replaced by the UTC or LOCAL setting in /etc/adjtime, and should have been migrated automatically.
See hwclock(5) and hwclock(8) for further details on configuring the system clock.

From Wheezy's /etc/default/rcS:

# assume that the BIOS clock is set to UTC time (recommended)
#UTC=no # OBSOLETE; see /etc/adjtime and hwclock(8).
Gigabyte 990FXA-UD3, AMD FX-6100 hex-core, 3.3GHz, 8G, Radeon HD6570

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9013
Age: 58
Joined: Wed Jul 12, 2006 2:26 pm

Re: M!! Time Problem

#10 Postby kmathern » Fri Jun 08, 2012 3:30 pm

DBeckett wrote:
kmathern wrote:snippet from man:rcS

... The UTC setting is replaced by the UTC or LOCAL setting in /etc/adjtime, and should have been migrated automatically.
See hwclock(5) and hwclock(8) for further details on configuring the system clock.

From Wheezy's /etc/default/rcS:

# assume that the BIOS clock is set to UTC time (recommended)
#UTC=no # OBSOLETE; see /etc/adjtime and hwclock(8).

Those comment lines mentioning 'BIOS clock' and 'UTC' have been removed from sid's /etc/default/rcS file. It just changed yesterday, it hasn't made it to Wheezy yet. You'll probably see it in the next week or so in Wheezy.

It's an update of the initscripts package 2.88dsf-22.1 --> 2.88dsf-26.
Last edited by kmathern on Fri Jun 08, 2012 3:42 pm, edited 1 time in total.


Return to “Mepis 11”

Who is online

Users browsing this forum: No registered users and 0 guests